HDU 1908 Double Queue<Set>

Problem Description

The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of the
bank is identified by a positive integer K and, upon arriving to the bank for some services, he or she receives a positive integer priority P. One of the inventions of the young managers of the bank shocked the software engineer of the serving system. They
proposed to break the tradition by sometimes calling the serving desk with the lowest priority instead of that with the highest priority. Thus, the system will receive the following types of request:

Your task is to help the software engineer of the bank by writing a program to implement the requested serving policy.

Input

Each line of the input contains one of the possible requests; only the last line contains the stop-request (code 0). You may assume that when there is a request to include a new client in the list (code 1), there is no other request
in the list of the same client or with the same priority. An identifier K is always less than 106, and a priority P is less than 107. The client may arrive for being served multiple times, and each time may obtain a different priority.

Output

For each request with code 2 or 3, the program has to print, in a separate line of the standard output, the identifier of the served client. If the request arrives when the waiting list is empty, then the program prints zero (0) to
the output.

Sample Input

2
1 20 14
1 30 3
2
1 10 99
3
2
2
0

Sample Output

0
20
30
10
0

STL乃神器,set的使用。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
#include<set>
using namespace std;
struct node{
    int v,p;
    bool operator<(const node &a)const//p大的优先
    {   return p>a.p;    }
};

int main()
{
    int u;
    set<node>q;
    node temp;
    while(~scanf("%d",&u))
    {
        if(u==0)
            break;
        if(u==1)
        {
            scanf("%d%d",&temp.v,&temp.p);
            q.insert(temp);
        }
        else if(q.empty())
            puts("0");
        else if(u==2)
        {
            printf("%d\n",q.begin()->v);
            q.erase(q.begin());
        }
        else
        {
            set<node>::iterator it=q.end();
            it--;
            printf("%d\n",it->v);
            q.erase(it);
        }
    }
    return 0;
}

HDU 1908 Double Queue<Set>,布布扣,bubuko.com

时间: 2024-10-08 02:50:36

HDU 1908 Double Queue<Set>的相关文章

hdu 1908 Double Queue

题目连接 http://acm.hdu.edu.cn/showproblem.php?pid=1908 Double Queue Description The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using mod

POJ 3481 &amp; HDU 1908 Double Queue (map运用)

题目链接: PKU:http://poj.org/problem?id=3481 HDU:http://acm.hdu.edu.cn/showproblem.php?pid=1908 Description The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by

hdu 1908 Double Queue (map)

# include <stdio.h> # include <algorithm> # include <iostream> # include <string.h> # include <string> # include <map> using namespace std; int main() { map<int,int>q; map<int,int>::iterator p; int n,name,nu

HDU 1908 Double Queue(set)

Problem Description The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of th

hdu 1908 double queues

http://acm.hdu.edu.cn/showproblem.php?pid=1908 看到有两个优先级,然后题目中又有queue...就想到了优先队列... 但是优先队列的cmp函数没搞懂,因为比较的是结构体,好像要重载< 什么的. 然而并不会. 其实用map就可以做... map在插入的时候可以自动按关键字排序,简直好评如潮! #include <algorithm> #include <cstdio> #include <iostream> #incl

POJ 题目3481 Double Queue(SBT ro map)

Double Queue Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 11824   Accepted: 5385 Description The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provid

【Map】Double Queue

Double Queue Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 13258   Accepted: 5974 Description The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provid

treap树---Double Queue

HDU   1908 Description The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of

AVL树(模板题)—— POJ 3481 Double Queue

对应POJ题目:点击打开链接 Double Queue Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 11741   Accepted: 5335 Description The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing env