poj - 3080-Blue Jeans

                                            Blue Jeans

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 17434   Accepted: 7728

Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated.

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers.

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC.

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:

  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT

Source

South Central USA 2006

16558378 sunshinestyle 3080 Accepted 700K 16MS G++ 1245B 2017-02-08 22:06:52

题解:

初级题目, 采用暴力即可。求出两两的最长连续子串,逐个匹配。

//p-3080  

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
using namespace std;
const int MAXN = 65;
const int MAXM = 11; 

int dp[MAXN][MAXN];
char data[MAXM][MAXN], LCS[MAXN], comp[MAXN]; 

int function(int idx){
	memset(dp, 0, sizeof(dp));
	int max_len = 0, pt = -1;
	for(int i=1; i<=60; ++i){
		for(int j=1; j<=strlen(comp+1); ++j){
			if(data[idx][i] == comp[j]){
				dp[i][j] = dp[i-1][j-1] + 1;
				if(dp[i][j] > max_len){
					max_len = dp[i][j];
					pt = j;
				} else if(dp[i][j] == max_len){
					if(comp[j-max_len+1] < comp[pt-max_len+1]){
						pt = j;
					}
				}
			}
		}
	}
	if(max_len >= 3){
		for(int i=1; i<=max_len; ++i){
			LCS[i] = comp[pt-max_len+i];
		}
		LCS[max_len+1] = ‘\0‘;
	}
	return max_len;
}

int main(){
	freopen("in.txt", "r", stdin); 

	int test_num, m;
	scanf("%d", &test_num);
	while(test_num--){
		scanf("%d", &m);
		scanf("%s", comp+1);
		for(int i=0; i<m-1; ++i){
			scanf("%s", data[i]+1);
		}
		int idx = 0, flag = 1;
		while(idx<(m-1)){
			if(function(idx) < 3){
				flag = 0;
				break;
			}
			strcpy(comp+1, LCS+1);
			idx++;
		}
		if(flag == 0 || strlen(LCS+1) < 3){
			printf("no significant commonalities\n");
		}else{
			printf("%s\n", LCS+1 );
		}
	}
	return 0;
}

  

时间: 2024-08-19 21:51:54

poj - 3080-Blue Jeans的相关文章

POJ 3080 Blue Jeans(KMP 最长公共子串)

Blue Jeans Description The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. As an IBM researcher, you ha

POJ 3080 Blue Jeans Trie后缀树解法

题目是牛仔裤的意思,不过看不出题意和Blue Jeans有什么关系. 本题的数据是很水的,数据量小,故此可以使用非常暴力的方法过,也可以使用不那么暴力的KMP过. 这里使用更加不暴力的Trie后缀树过,这种解法就一点都不水了,呵呵. 思路: 1 建立所有字符串的后缀Trie树 2 增加额外信息,看每过路径是否是所有的字符串都经过了,如果是,那么就是合法的字符串了,查找最长的这样的字符串 3 优化一下:如果不是所有字符串的经过的路径,那么就可以直接返回,不往下搜索了 最后,我发现删除Trie都是很

POJ 3080 Blue Jeans 三种暴力法

本题可以使用暴力法直接求解,思路也挺简单的,不过实现起来也挺麻烦的. 本题最暴力直接使用strstr过. 这里使用hash表的方法过,这种方法好像有个学名的,主要思路就是把一个需要查找的字符串赋予一个数值,那么就可以把一串字符串的比较转换为一个值的比较了,那么就可以加速字符串的查找了. #include <stdio.h> #include <string.h> #include <stdlib.h> const long long MOD = (int)(1E9+7)

poj 3080 Blue Jeans (kmp暴力)

# include <stdio.h> # include <algorithm> # include <cstring> using namespace std; int next[100]; char pat[100]; char a[100][100]; int ma; int lenp; int n; void Getnext() { int i=0,j=-1; next[0]=-1; while(i<=lenp) { if(j==-1||pat[j]==

POJ 3080 Blue Jeans KMP解法

使用KMP寻找最长的前缀的方法,比一般的暴力法有快了很多. 本题一般的暴力法需要的是O(m*n*n*n),其中m是有多少字符串,而n是字符串长度,而使用KMP就可以把时间效率提高到O(m*n*n),减少了一个n,提高了一个档次啦. 速度快很多. 准确来说应该是利用KMP寻找一个字符串A,在另一个字符串B任意位置出现的A的最长的前缀字符串. 理解好KMP的next table就好办了.每次查找到相等字符的时候,保存好最长的前缀. 注意本题的条件:选取最前的字典顺序输出.老害我错的条件. #incl

poj 3080 Blue Jeans (KMP)

http://poj.org/problem?id=3080 Blue Jeans Description The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populate

poj 3080 Blue Jeans 暴力

Blue Jeans Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 14283   Accepted: 6356 Description The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousa

POJ 3080 Blue Jeans(后缀数组+二分答案)

[题目链接] http://poj.org/problem?id=3080 [题目大意] 求k个串的最长公共子串,如果存在多个则输出字典序最小,如果长度小于3则判断查找失败. [题解] 将所有字符串通过拼接符拼成一个串,做一遍后缀数组,二分答案,对于二分所得值,将h数组大于这个值的相邻元素分为一组,判断组内元素是否覆盖全字典,是则答案成立,对于答案扫描sa,输出第一个扫描到的子串即可. [代码] #include <cstdio> #include <cstring> #inclu

POJ 3080 Blue Jeans(串)

题目网址:http://poj.org/problem?id=3080 思路: 以第一个DNA序列s为参考序列,开始做以下的操作. 1.将一个字母s[i]作为匹配串.(i为当前遍历到的下标) 2.遍历所有序列,看是否是所有序列的公共子串 3.是所有序列的子串的话,再往后增加一个字母,组成一个长度len+1的匹配串(设原先匹配串长度为len),重复步骤2 4.不是所有序列的子串的话,i=len+i;判断len是否大于3,是的话保存子串.len=0;重复步骤1.(为什么 i=len+i呢?因为len

poj 3080 Blue Jeans(kmp)

Description The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. As an IBM researcher, you have been tas