1003 Emergency

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output

2 4

我觉得我好笨,这个题目我本来以为很简单的结果写的时候才发现我这个渣渣;我连for都写错了  天哪   调试半天才发现  太久没写代码了然后我起初用的是队列  因为我大概在脑子里过了一遍就是取出从前到后不会对新值有影响,以为不会出现在后面更新了最短路条数更新的情况我错了  我想成bfs了 这里还要加一个dis 做成优先队列  叹气
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<functional>
#include<queue>
using namespace std;
int Len,head[505],vis[505],dis[505],dp[505],sum[505],num[505],a[505];
int N,M,C1,C2;
struct Data{
int next,to,w;
}data[12505];
const int MAX=0xffffff;
struct number1{
    int x,y;
    bool operator < (const number1 &a) const {
        return x>a.x;//最小值优先
    }
};
void add_Edge(int a,int b,int c)
{
    data[Len].to=b;
    data[Len].w=c;
    data[Len].next=head[a];
    head[a]=Len;
    Len++;
}
void Read()
{
    for(int i=0;i<N;i++)scanf("%d",&num[i]);
        int a,b,c;
        for(int i=0;i<N;i++)
            dis[i]=MAX;
        for(int i=0;i<M;i++){
        scanf("%d%d%d",&a,&b,&c);
           add_Edge(a,b,c);
           add_Edge(b,a,c);
        }
}
void init()
{
    Len=0;
    memset(vis,0,sizeof vis);
    memset(head,-1,sizeof head);
    memset(sum,0,sizeof sum);
    memset(dp,0,sizeof dp);

}
void Solve()
{
    dis[C1]=0;
    sum[C1]=num[C1];
    dp[C1]=1;
    priority_queue<number1>q;
    //queue<int> q;
    number1 k;
    k.x=dis[C1];
    k.y=C1;
    q.push(k);
    while(!q.empty())
    {
        k=q.top();
        q.pop();
        int u=k.y;
        if(vis[u])continue;
        vis[u]=1;
        for(int i=head[u];i!=-1;i=data[i].next)
        {
            int v=data[i].to;
            if(dis[v]>dis[u]+data[i].w)
            {
                dp[v]=dp[u];
                dis[v]=dis[u]+data[i].w;
                sum[v]=sum[u]+num[v];
                k.x=dis[v];
                k.y=v;
                q.push(k);
            }
            else if(dis[v]==dis[u]+data[i].w)
            {
            dp[v]+=dp[u];
            sum[v]=max(sum[v],sum[u]+num[v]);
            }
        }
    }
    printf("%d %d\n",dp[C2],sum[C2]);
}
int main()
{

    while(~scanf("%d%d%d%d",&N,&M,&C1,&C2))
    {
        init();
        Read();
        Solve();
    }

}

  

时间: 2024-10-16 13:15:28

1003 Emergency的相关文章

PAT (Advanced Level) Practise 1003 Emergency(SPFA+DFS)

1003. Emergency (25) 时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount

PAT 1003. Emergency

1003. Emergency (25) As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between an

1003. Emergency (25)——PAT (Advanced Level) Practise

题目信息: 1003. Emergency (25) 时间限制 400 ms 内存限制 32000 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads.

PAT 1003. Emergency (25)

1003. Emergency (25) As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between an

PAT 甲级 1003. Emergency (25)

1003. Emergency (25) 时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount

PAT 1003 Emergency (25)(25 分)

1003 Emergency (25)(25 分) As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road betwe

1003 Emergency(25 分)C语言版本(提问求解答)

1003 Emergency(25 分) As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between an

甲级1003 Emergency

1003 Emergency (25 分) As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between a

【PAT甲级】1003 Emergency (25分)

1003 Emergency (25分) As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between an