PAT1027

People in Mars represent the colors in their computers in a similar way as the Earth people.

火星人在他们的计算机上颜色的表示方式和地球人相似。

That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for

就是,一种颜色用6位数字表示,前两位表示红色,中间两位表示绿色,最后两位表示蓝色。

Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16.

只有一点不同就是在,他们使用的是13进制取代了我们的16进制。

Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

现在给出一个颜色的三个十进制数。每个数字从0-168,你需要输出他们的火星RGB值。

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

输入案例:每个输入文件包含一个测试案例,包含一行,3个十进制颜色值。

Output

For each test case you should output the Mars RGB value in the following format:

对于每一个输出样例,你应该输出一个火星的RGB值,并符合以下的形式:

first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

先输出一个“#”,然后接着输出6位数字,所有的英文字符必须大写。如果只有一个颜色只有一个数字,必须左边加0表示。

Sample Input

15 43 71

Sample Output

#123456
 
#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<algorithm>

using namespace std;

char a[20]={
    ‘0‘,‘1‘,‘2‘,‘3‘,‘4‘,‘5‘,‘6‘,‘7‘,‘8‘,‘9‘,‘A‘,‘B‘,‘C‘
};

int main()
{
    int r,g,b;
    cin>>r>>g>>b;
    cout<<"#"<<a[r/13]<<a[r%13]<<a[g/13]<<a[g%13]<<a[b/13]<<a[b%13]<<endl;
    return 0;
}

代码简练一些,我觉得这样已经可以算是简练了,很简单的一道题目,学习一下英语吧

时间: 2024-08-10 00:07:41

PAT1027的相关文章

pat1027. Colors in Mars (20)

1027. Colors in Mars (20) 时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the

PAT1027. 打印沙漏(20)

本题要求你写个程序把给定的符号打印成沙漏的形状.例如给定17个“*”,要求按下列格式打印 ***** *** * *** ***** 所谓“沙漏形状”,是指每行输出奇数个符号:各行符号中心对齐:相邻两行符号数差2:符号数先从大到小顺序递减到1,再从小到大顺序递增:首尾符号数相等. 给定任意N个符号,不一定能正好组成一个沙漏.要求打印出的沙漏能用掉尽可能多的符号. 输入格式: 输入在一行给出1个正整数N(<=1000)和一个符号,中间以空格分隔. 输出格式: 首先打印出由给定符号组成的最大的沙漏形

PAT1027. Colors in Mars

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The