[POJ 3264]Balanced Lineup(ST算法求RMQ)

Description

For the daily milking, Farmer John‘s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range
of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤
height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and
Q.

Lines 2..N+1: Line i+1 contains a single integer that is the height of cow
i

Lines N+2..N+Q+1: Two integers A and B (1 ≤
ABN), representing the range of cows from A to
B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

USACO 2007 January Silver

题目很水,裸的RMQ自然不必多说,对于每次询问输出区间最大值与最小值绝对值之差,不过要注意输入输出用cin cout会超时,只能用scanf printf,最终速度为1719ms

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

#define MAXN 50100

using namespace std;

int max(int a,int b)
{
    if(a>b) return a;
    return b;
}

int min(int a,int b)
{
    if(a<b) return a;
    return b;
}

int minRMQ[MAXN][18],maxRMQ[MAXN][18];

int getMinRMQ(int l,int r)
{
    int pos=(int)(log((r-l+1)*1.0)/log(2.0));
    return min(minRMQ[l][pos],minRMQ[r-(1<<pos)+1][pos]);
}

int getMaxRMQ(int l,int r)
{
    int pos=(int)(log((r-l+1)*1.0)/log(2.0));
    return max(maxRMQ[l][pos],maxRMQ[r-(1<<pos)+1][pos]);
}

int main()
{
    int n,m,q;
    scanf("%d%d",&n,&q);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&minRMQ[i][0]);
        maxRMQ[i][0]=minRMQ[i][0];
    }
    m=(int)(log(n*1.0)/log(2.0));
    for(int i=1;i<20;i++)
        for(int j=1;j<=n;j++)
        {
            if(j+(1<<i)-1<=n)
            {
                maxRMQ[j][i]=max(maxRMQ[j][i-1],maxRMQ[j+(1<<(i-1))][i-1]);
                minRMQ[j][i]=min(minRMQ[j][i-1],minRMQ[j+(1<<(i-1))][i-1]);
            }
        }
    for(int i=1;i<=q;i++)
    {
        int a,b;
        scanf("%d%d",&a,&b);
        printf("%d\n",getMaxRMQ(a,b)-getMinRMQ(a,b));
    }
    return 0;
}



时间: 2024-08-04 03:26:00

[POJ 3264]Balanced Lineup(ST算法求RMQ)的相关文章

[POJ] 3264 Balanced Lineup [ST算法]

Balanced Lineup Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 34306   Accepted: 16137 Case Time Limit: 2000MS Description For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer Joh

POJ 3264 Balanced Lineup ST表

链接:http://poj.org/problem?id=3264 题意:给一串数字,多次询问,求区间最大值和区间最小值的差. 思路:RMQ问题,可以用O(N^2)的预处理,然后每次O(1)的查询,可以用线段树,O(N)的建树,O(logN)的查询,可以用ST表记录,O(NlogN)的预处理,O(1)的查询. 实际上ST表的预处理过程也是一个DP的过程dp[i][j]表示从第i位开始连续2^j位的区间最值. 预处理:dp[i][j]=min(dp[i][j],dp[i+2^j][j]),查询:q

poj 3264 Balanced Lineup(线段数求区间最大最小值)

链接:http://poj.org/problem?id=3264 Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 32772   Accepted: 15421 Case Time Limit: 2000MS Description For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order.

POJ 3264 Balanced Lineup (线段树||RMQ)

A - Balanced Lineup Crawling in process... Crawling failed Time Limit:5000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Submit Status Practice POJ 3264 Description For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always li

poj 3264 Balanced Lineup(一维RMQ)

题意:每次操作求区间[L,R]中最大值与最小值之差: 参考:http://blog.csdn.net/liang5630/article/details/7917702 思路:可以用线段树写,但ST算法求RMQ更方便: dp[i][j]表示从第i个数开始到i+2^j中的最值: 在操作之前,预处理出每段区间的最值,采用二分区间求极值的思想,降低复杂度: 查询时,覆盖查询区间,长度R-L+1,对于dp中,j=log(R-L+1),在这段区间中二分区间求极值即可; #include<cstdio>

poj 3264 Balanced Lineup

题目链接:http://poj.org/problem?id=3264 题目大意:就是给你一串数,问你最大数和最小数的差值....... 思路:最基本的线段树,只需要建树和查询,修改都省啦,但是查询要写两个,一个查询最大值,一个查询最小值......然后就能AC掉.....但是话说poj把它分类到RMQ中.... code: #include<cstdio> #include<cmath> #include<algorithm> #include<iostream

POJ - 3264 Balanced Lineup (RMQ问题求区间最值)

RMQ (Range Minimum/Maximum Query)问题是指:对于长度为n的数列A,回答若干询问RMQ(A,i,j)(i,j<=n),返回数列A中下标在i,j里的最小(大)值,也就是说,RMQ问题是指求区间最值的问题. Balanced Lineup Time Limit: 5000MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u Submit Status Description For the daily

POJ 3264 Balanced Lineup(st或者线段树)

A - Balanced Lineup Time Limit:5000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Submit Status Practice POJ 3264 Appoint description:  System Crawler  (2015-08-03) Description For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,00

poj 3264 Balanced Lineup 区间极值RMQ

题目链接:http://poj.org/problem?id=3264 For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he wil