hdu 2822 Dogs

Dogs

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 8   Accepted Submission(s) : 2

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

Prairie dog comes again! Someday one little prairie dog Tim wants to visit one of his friends on the farmland, but he is as lazy as his friend (who required Tim to come to his place instead of going to Tim‘s), So he turn to you for help to point out how could him dig as less as he could.

We know the farmland is divided into a grid, and some of the lattices form houses, where many little dogs live in. If the lattices connect to each other in any case, they belong to the same house. Then the little Tim start from his home located at (x0, y0) aim at his friend‘s home ( x1, y1 ). During the journey, he must walk through a lot of lattices, when in a house he can just walk through without digging, but he must dig some distance to reach another house. The farmland will be as big as 1000 * 1000, and the up left corner is labeled as ( 1, 1 ).

Input

The input is divided into blocks. The first line in each block contains two integers: the length m of the farmland, the width n of the farmland (m, n ≤ 1000). The next lines contain m rows and each row have n letters, with ‘X‘ stands for the lattices of house, and ‘.‘ stands for the empty land. The following two lines is the start and end places‘ coordinates, we guarantee that they are located at ‘X‘. There will be a blank line between every test case. The block where both two numbers in the first line are equal to zero denotes the end of the input.

Output

For each case you should just output a line which contains only one integer, which is the number of minimal lattices Tim must dig.

Sample Input

6 6
..X...
XXX.X.
....X.
X.....
X.....
X.X...
3 5
6 3

0 0

Sample Output

3

Hint

Hint: Three lattices Tim should dig: ( 2, 4 ), ( 3, 1 ), ( 6, 2 ).

Source

2009 Multi-University Training Contest 1 - Host by TJU

思路: 采用优先队列,哪个点时间少哪个点先处理

#include <iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int n,m,i,j,sx,sy,tx,ty;
char mp[1005][1005];
bool vis[1005][1005];  //int爆内存,用bool型

struct node
{
    int x,y,ti;
    node(int a,int b,int c){x=a;y=b;ti=c;}
};
int dr[4][2]={{1,0},{-1,0},{0,1},{0,-1} };
struct cmp
{
    bool operator()(node a,node b)
    {
        return a.ti>b.ti;
    }
};
bool check(int x,int y)
{
    if(x>=0 && x<n && y>=0 && y<m && !vis[x][y])  return 1;
     return 0;
}
int bfs()
{
    priority_queue<node,vector<node>,cmp> Q;
    Q.push(node(sx,sy,0));
    vis[sx][sy]=1;
    while(!Q.empty())
    {
        node p=Q.top();
        Q.pop();
       for(int i=0;i<4;i++)
       {
           int xx=p.x+dr[i][0];
           int yy=p.y+dr[i][1];
           if(!check(xx,yy)) continue;
           vis[xx][yy]=1;
           int ti=0;
           if (mp[xx][yy]==‘X‘) ti=p.ti;
                  else ti=p.ti+1;
             Q.push(node(xx,yy,ti));
           if (xx==tx && yy==ty) return ti;
       }
    }
}
int main()
{
    while(scanf("%d%d",&n,&m))
    {
        if(n==0 && m==0) break;//以0 0 结束
        for(i=0;i<n;i++)
         scanf("%s",&mp[i]);
            scanf("%d%d",&sx,&sy);
            scanf("%d%d",&tx,&ty);
            sx--;
            sy--;
            tx--;
            ty--;
            memset(vis,0,sizeof(vis));
            if (sx==tx && sy==ty) printf("0\n");
                        else  printf("%d\n",bfs());
    }

    return 0;
}
时间: 2024-10-14 08:53:53

hdu 2822 Dogs的相关文章

hdu - 2822 Dogs (优先队列+bfs)

http://acm.hdu.edu.cn/showproblem.php?pid=2822 给定起点和终点,问从起点到终点需要挖几次只有从# 到 .或者从. 到  . 才需要挖一次. #include <cstdio> #include <queue> #include <cstring> using namespace std; const int maxn = 1001; int n,m; int sx,sy,ex,ey; char maze[maxn][maxn

HDU 2822 (BFS+优先队列)

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=2822 题目大意:X消耗0,.消耗1, 求起点到终点最短消耗 解题思路: 每层BFS的结点,优先级不同,应该先搜cost小的.直接退化为最短路问题. 优先队列优化. 卡输入姿势.如果O(n^2)逐个读的话会T掉.要用字符串读一行. #include "cstdio" #include "queue" #include "cstring" using

【HDOJ】2822 Dogs

bfs. 1 /* 2822 */ 2 #include <iostream> 3 #include <cstdio> 4 #include <cstring> 5 #include <cstdlib> 6 #include <queue> 7 using namespace std; 8 9 #define MAXN 1005 10 #define INF 0xffffff 11 12 typedef struct node_t { 13 in

hdu 2822 bfs

问题可以抽象为求起点到终点的最短路,其中经过x的代价是0,而经过.的代价是1,bfs的时候用优先队列即可. 1 #include <iostream> 2 #include <cstring> 3 #include <cstdio> 4 #include <queue> 5 using namespace std; 6 7 const int N = 1001; 8 char maze[N][N]; 9 bool visit[N][N]; 10 int dx

hdu 2822 ~!!!!!!坑死我

首先 在此哀悼...  为我逝去的时间哀悼...  每一步都确定再去写下一步吧...日狗 不过还是有点收获的..  对优先队列的使用 有了进一步的理解 先上代码 #include<iostream>#include<cstdio>#include<queue>#include<string.h>using namespace std;int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};char mapp[1001][1001]

hdu 2828 Dogs

优先队列bfs,无难度,走x不用花时间,走"."时间为1: #include<iostream> #include<queue> #include<cstring> #define maxn 1000+5 using namespace std; char mapp[maxn][maxn]; int visit[maxn][maxn]; int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}}; int n,m; int s

HDU 专题分类

[背包问题] 2602 Bone Collector 1114 Piggy-Bank 1203 I NEED A OFFER! 1171 Big Event in HDU 1059 Dividing 2844 Coins 2191 悼念512汶川大地震遇难同胞--珍惜现在,感恩生活 2159 FATE 1561 The more, The Better 1011 Starship Troopers 2639 Bone Collector II 3033 I love sneakers! 2955

HDU——T 2818 Building Block

http://acm.hdu.edu.cn/showproblem.php?pid=2818 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 5935    Accepted Submission(s): 1838 Problem Description John are playing with blocks. There are N

(KMP 水)Wow! Such Doge! -- hdu -- 4847

http://acm.hdu.edu.cn/showproblem.php?pid=4847 Wow! Such Doge! Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 4847 Description Chen, Adrian (November 7, 2013). “Doge Is An Ac- tually Good Inter