[BZOJ2761][JLOI2011]不重复数字

试题描述

给出N个数,要求把其中重复的去掉,只保留第一次出现的数。

例如,给出的数为1 2 18 3 3 19 2 3 6 5 4,其中2和3有重复,去除后的结果为1 2 18 3 19 6 5 4。

输入

输入第一行为正整数T,表示有T组数据。

接下来每组数据包括两行,第一行为正整数N,表示有N个数。第二行为要去重的N个正整数。

输出

对于每组数据,输出一行,为去重后剩下的数字,数字之间用一个空格隔开。

输入示例

2
11
1 2 18 3 3 19 2 3 6 5 4
6
1 2 3 4 5 6

输出示例

1 2 18 3 19 6 5 4
1 2 3 4 5 6

数据规模及约定

对于30%的数据,1 <= N <= 100,给出的数不大于100,均为非负整数;

对于50%的数据,1 <= N <= 10000,给出的数不大于10000,均为非负整数;

对于100%的数据,1 <= N <= 50000,给出的数在32位有符号整数范围内。

题解

直接上哈希。。。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <stack>
#include <vector>
#include <queue>
#include <cstring>
#include <string>
#include <map>
#include <set>
using namespace std;

int read() {
    int x = 0, f = 1; char c = getchar();
    while(!isdigit(c)){ if(c == ‘-‘) f = -1; c = getchar(); }
    while(isdigit(c)){ x = x * 10 + c - ‘0‘; c = getchar(); }
    return x * f;
}

#define MOD 100007
#define LL long long
int head[MOD], nxt[MOD], ans[MOD], cnt, val[MOD], ToT;
void insert(int x) {
	int p = (x % MOD + MOD) % MOD;
	nxt[++ToT] = head[p]; head[p] = ToT; val[ToT] = x;
	return ;
}
bool Find(int x) {
	int p = (x % MOD + MOD) % MOD;
	for(int i = head[p]; i; i = nxt[i]) if(x == val[i]) return 1;
	return 0;
}

int main() {
	int T = read();
	while(T--) {
		int n = read(); cnt = ToT = 0;
		memset(head, 0, sizeof(head));
		for(int i = 1; i <= n; i++) {
			int x = read();
			if(!Find(x)) insert(x), ans[++cnt] = x;
		}
		for(int i = 1; i <= cnt; i++) printf("%d%c", ans[i], i < cnt ? ‘ ‘ : ‘\n‘);
	}

	return 0;
}
时间: 2024-10-06 06:30:07

[BZOJ2761][JLOI2011]不重复数字的相关文章

[BZOJ2761] [JLOI2011] 不重复数字 (set)

Description 给出N个数,要求把其中重复的去掉,只保留第一次出现的数. 例如,给出的数为1 2 18 3 3 19 2 3 6 5 4,其中2和3有重复,去除后的结果为1 2 18 3 19 6 5 4. Input 输入第一行为正整数T,表示有T组数据. 接下来每组数据包括两行,第一行为正整数N,表示有N个数.第二行为要去重的N个正整数. Output 对于每组数据,输出一行,为去重后剩下的数字,数字之间用一个空格隔开. Sample Input 2 11 1 2 18 3 3 19

bzoj2761: [JLOI2011]不重复数字(hash)

题目大意:给出N个数,要求把其中重复的去掉,只保留第一次出现的数.例如,给出的数为1 2 18 3 3 19 2 3 6 5 4,其中2和3有重复,去除后的结果为1 2 18 3 19 6 5 4. 随意哈希一下...[我不会什么set啊treap啊之类QAQ 代码如下: var t,n,i,x:longint; v:array[0..500009]of boolean; vv,b,a,ans:array[0..500009]of int64; function hash(x:int64):lo

【set】bzoj2761 [JLOI2011]不重复数字

set去重. 1 #include<cstdio> 2 #include<set> 3 using namespace std; 4 set<int>S; 5 int T,n,x,a[50001],b[50001],en; 6 int main() 7 { 8 scanf("%d",&T); 9 for(;T>0;T--) 10 { 11 scanf("%d",&n); S.clear(); en=0; 12

[JLOI2011]不重复数字

2761: [JLOI2011]不重复数字 Time Limit: 10 Sec  Memory Limit: 128 MBSubmit: 2459  Solved: 939[Submit][Status][Discuss] Description 给出N个数,要求把其中重复的去掉,只保留第一次出现的数. 例如,给出的数为1 2 18 3 3 19 2 3 6 5 4,其中2和3有重复,去除后的结果为1 2 18 3 19 6 5 4. Input 输入第一行为正整数T,表示有T组数据. 接下来

2761: [JLOI2011]不重复数字

2761: [JLOI2011]不重复数字 Time Limit: 10 Sec  Memory Limit: 128 MBSubmit: 1770  Solved: 675[Submit][Status] Description 给出N个数,要求把其中重复的去掉,只保留第一次出现的数. 例如,给出的数为1 2 18 3 3 19 2 3 6 5 4,其中2和3有重复,去除后的结果为1 2 18 3 19 6 5 4. Input 输入第一行为正整数T,表示有T组数据. 接下来每组数据包括两行,

BZOJ 2761: [JLOI2011]不重复数字 水题

2761: [JLOI2011]不重复数字 Time Limit: 10 Sec  Memory Limit: 162 MBSubmit: 2100  Solved: 809 题目连接 http://www.lydsy.com/JudgeOnline/problem.php?id=2761 Description 给出N个数,要求把其中重复的去掉,只保留第一次出现的数. 例如,给出的数为1 2 18 3 3 19 2 3 6 5 4,其中2和3有重复,去除后的结果为1 2 18 3 19 6 5

2761: [JLOI2011]不重复数字(平衡树)

2761: [JLOI2011]不重复数字 Time Limit: 10 Sec  Memory Limit: 128 MBSubmit: 2133  Solved: 825[Submit][Status][Discuss] Description 给出N个数,要求把其中重复的去掉,只保留第一次出现的数. 例如,给出的数为1 2 18 3 3 19 2 3 6 5 4,其中2和3有重复,去除后的结果为1 2 18 3 19 6 5 4. Input 输入第一行为正整数T,表示有T组数据. 接下来

题解 P4305 【[JLOI2011]不重复数字】

来一波用vector的最短代码题解 P4305 [JLOI2011]不重复数字 关于hash表的部分大家可以看一看其他的题解,我就不说了 不定长数组vector的几个基本用法: 定义: vector<数据类型> 数组名称 访问: a[pos]//访问a数组下标为pos的元素 尾部加入元素: a.push_back(x) 判断是否为空: a.empty()//空返回true,非空返回false 代码: #include <iostream> #include <cstdio&g

【bzoj2761】[JLOI2011]不重复数字

水题 set判重即可 oj上没有忽略行末空格 #include<algorithm> #include<iostream> #include<cstdlib> #include<cstring> #include<cstdio> #include<cmath> #include<set> using namespace std; typedef long long LL; set<LL>S; LL T; LL