活动选择 |
难度级别:C; 运行时间限制:500ms; 运行空间限制:51200KB; 代码长度限制:2000000B |
试题描述 |
学校最近几天有n个活动,这些活动都需要使用学校大礼堂,在同一时间,礼堂只能被一个活动使用。由于有些活动时间上有冲突,学校办公室人员只好让一些活动放弃使用礼堂而是用教室。 现在给出n个活动使用礼堂的起始时间begini和结束时间endi,请你帮助办公室人员安排一些活动来使用礼堂,使得安排的活动尽量多。 |
输入 |
第一行一个整数n。 接下来n行,每行2个整数,第一个begini,第二个endi。 |
输出 |
最多能安排的活动个数。 |
输入示例 |
11 3 5 1 4 12 14 8 12 0 6 8 11 6 10 5 7 3 8 5 9 2 13 |
输出示例 |
4 |
其他说明 |
1<=n<=1000,begini<=endi<=32767 SCX编写 |
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
struct ss
{
int x,y;
}p[1010];
bool cmp(ss a,ss b)
{
if(a.y!=b.y) return a.y<b.y;
else if(a.x!=b.x) return a.x<b.x;
}
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
int i;
for(i=0;i<n;i++)
scanf("%d%d",&p[i].x,&p[i].y);
sort(p,p+n,cmp);
int a=p[0].y,cnt=1;
for(i=1;i<n;i++)
if(a<=p[i].x)
{
cnt++;
a=p[i].y;
}
printf("%d\n",cnt);
}
return 0;
}
时间: 2024-10-25 02:58:48