hdu 1019 Least Common Multiple

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 54584    Accepted Submission(s):
20824

Problem Description

The least common multiple (LCM) of a set of positive
integers is the smallest positive integer which is divisible by all the numbers
in the set. For example, the LCM of 5, 7 and 15 is 105.

Input

Input will consist of multiple problem instances. The
first line of the input will contain a single integer indicating the number of
problem instances. Each instance will consist of a single line of the form m n1
n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the
integers. All integers will be positive and lie within the range of a 32-bit
integer.

Output

For each problem instance, output a single line
containing the corresponding LCM. All results will lie in the range of a 32-bit
integer.

Sample Input

2
3 5 7 15
6 4 10296 936 1287 792 1

Sample Output

105
10296

只要掌握基本的求最大公约数 与 最小公倍数的方法 即可简单解决该问题~

//求最小公倍数算法:

//最小公倍数=两整数的乘积 ÷最大公约数

//求最大公约数算法:

其中之一  --> 辗转相除法:

//有两整数a和b;

//① a%b得余数c

//② 若c=0,则b即为两数的最大公约数

//③ 若c≠0,则a=b,b=c,再回去执行①

代码如下:

#include <iostream>
#define N 10010
using namespace std;

long long gcd(long long a,  long long b)
{
  if(a % b == 0)
  {
    return b;
  }
  else
  {
    return gcd(b,a % b);
  }
}

long long num[N];
int main()

{
  int n, a;
  long long c;
  scanf("%d", &n);
  while(n--)
  {
    c= 1;
    scanf("%d", &a);
    for(int i = 0;i < a; ++i)
    {
      scanf("%I64d", &num[i]);
    }
    for(int i = 0;i < a; ++i)
    {
      if(c % num[i] == 0)
      {
        continue;
      }
      else
      {
        c = c*num[i]/gcd(c,num[i]);
      }
    }
    printf("%ld\n", c);
  }
  return 0;
}

时间: 2024-08-02 13:40:33

hdu 1019 Least Common Multiple的相关文章

HDU 1019 Least Common Multiple (最小公倍数)

Least Common Multiple Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 30285    Accepted Submission(s): 11455 Problem Description The least common multiple (LCM) of a set of positive integers is

HDU 1019 Least Common Multiple 数学题解

求一组数据的最小公倍数. 先求公约数在求公倍数,利用公倍数,连续求所有数的公倍数就可以了. #include <stdio.h> int GCD(int a, int b) { return b? GCD(b, a%b) : a; } inline int LCM(int a, int b) { return a / GCD(a, b) * b; } int main() { int T, m, a, b; scanf("%d", &T); while (T--)

HDU 1019 Least Common Multiple 数学题

Problem Description The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105. Input Input will consist of multiple prob

HDU 1019 Least Common Multiple (最小公倍数_水题)

Problem Description The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105. Input Input will consist of multiple prob

HDU - 1019 - Least Common Multiple - 质因数分解

http://acm.hdu.edu.cn/showproblem.php?pid=1019 LCM即各数各质因数的最大值,搞个map乱弄一下就可以了. #include<bits/stdc++.h> using namespace std; typedef long long ll; typedef unsigned int ui; map<ui,ui> M; ll _pow(ui f,ui s){ ll res=1; while(s){ res*=f; s--; } retur

ACM学习历程—HDU 3092 Least common multiple(数论 &amp;&amp; 动态规划 &amp;&amp; 大数)

hihoCoder挑战赛12 Description Partychen like to do mathematical problems. One day, when he was doing on a least common multiple(LCM) problem, he suddenly thought of a very interesting question: if given a number of S, and we divided S into some numbers

HDUJ 1019 Least Common Multiple

Least Common Multiple Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 29480    Accepted Submission(s): 11136 Problem Description The least common multiple (LCM) of a set of positive integers is

1019 Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 51959    Accepted Submission(s): 19706   Problem Description The least common multiple (LCM) of a set of positive integers is the smallest positiv

hdu 2028 Lowest Common Multiple Plus(最小公倍数)

Lowest Common Multiple Plus Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 34980    Accepted Submission(s): 14272 Problem Description 求n个数的最小公倍数. Input 输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数. Out