hdu-5673 Robot(默次金数)

题目链接:

Robot

Time Limit: 12000/6000 MS (Java/Others)

Memory Limit: 65536/65536 K (Java/Others)

问题描述

有一个机器人位于坐标原点上。每秒钟机器人都可以向右移到一个单位距离,或者在原地不动。如果机器人的当前位置在原点右侧,它同样可以
向左移动单位距离。一系列的移动(左移,右移,原地不动)定义为一个路径。问有多少种不同的路径,使得nn秒后机器人仍然位于坐标原点?
答案可能很大,只需输出答案对1,000,000,0071,000,000,007的模。

输入描述

输入包含多组数据. 第一行有一个整数T (1\leq T\leq 100)T(1≤T≤100), 表示测试数据的组数. 对于每组数据:
输入一个整数 n (1\leq n\leq 1,000,000)n(1≤n≤1,000,000)。

输出描述

对于每组数据,输出一个整数

输入样例

3
1
2
4

输出样例

1
2
9

思路:

比赛的时候一直推不出公式,还是得好好补补组合数学;

AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
using namespace std;
typedef long long ll;
const ll mod=1e9+7;
const int N=1e6+6;
ll dp[N];

ll fastpow(ll a,ll b)
{
    ll ans=1,base=a;
    while(b)
    {
        if(b&1)
        {
            ans=ans*base;
            ans%=mod;
        }
        base*=base;
        base%=mod;
        b=(b>>1);
    }
    return ans;
}
void fun()
{
    dp[1]=1;
    dp[2]=2;
    for(int i=3;i<N;i++)
    {
        ll x=(ll)(i+3);
        ll y=(ll)(2*i+1);
        ll z=(ll)(3*i-3);
        dp[i]=(y*dp[i-1]%mod+z*dp[i-2]%mod)*fastpow((ll)(i+2),mod-2)%mod;
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    fun();
    while(t--)
    {
        int n;
        scanf("%d",&n);
        printf("%I64d\n",dp[n]);
    }

    return 0;
}
时间: 2024-12-21 13:15:00

hdu-5673 Robot(默次金数)的相关文章

HDU5673 Robot 默慈金数

分析: 注:然后学了一发线性筛逆元的姿势 链接:http://blog.miskcoo.com/2014/09/linear-find-all-invert #include<iostream> #include<algorithm> #include<set> #include<vector> #include<queue> #include<cstdlib> #include<cstdio> #include<c

hdu5673 Robot 卡特兰数 / 默慈金数

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5673 分析: 这道题是一道裸的默慈金数,比较容易想到的是用卡特兰数来做.不了解的可以先学习一下. 卡特兰数:http://www.cnblogs.com/yaoyueduzhen/p/5456490.html 默慈金数:http://www.cnblogs.com/yaoyueduzhen/p/5456530.html 记路径长度为nn,那么机器人最多向右走⌊?n/2??⌋步并向左走⌊?n/2??⌋

HDU 3723 Delta Wave(默慈金数)

传送门 Delta Wave Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1160    Accepted Submission(s): 370 Problem Description A delta wave is a high amplitude brain wave in humans with a frequency of 1

51NOD 1556 计算 (默慈金数)

传送门 有一个1*n的矩阵 固定第一个数为1 其他填正整数 且相邻数的差不能超过1 求方案数%1e9+7的结果 Input 一个数n 表示1*n的矩阵(n<=10^6) Output 一个数 表示方案数%1e9+7的结果 Input示例 3 Output示例 5 解题思路: 这是一个默慈金数的题目,那么什么叫默慈金数呢. 默慈金数是在数学中,一个给定的数n的默慈金数是"在一个圆上的n个点间,画出彼此不相交的弦的全部方法的总数".--摘自百度百科 默慈金数的实例表示:像例如在一个&

HDU 5673 Robot 卡特兰数

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=5673 题目描述: 一个人从原点开始向右走, 要求N秒后回到原点, 且过程中不能到负半轴, 人有两种操作, 走动或者停止, 问总共有多少种方案? 解题思路: 类似于括号匹配问题, 和那个我去年这个时候接触到的最裸的不能越过对角线的正方形走到对角问题, 卡特兰数, 从2开始枚举走动步数, 然后剩下的就是不动的步数, 用不动的步数做个填充就可以了, 设计到取模, 需要逆元 代码: #include <i

hdu 5673 Robot 卡特兰数+逆元

Robot Time Limit: 12000/6000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Problem Description There is a robot on the origin point of an axis.Every second, the robot can move right one unit length or do nothing.If the robot is on the

HDU 5673 Robot(卡特兰数)

题目链接:点击打开链接 思路:卡特兰数可以用来求括号序列的个数, 用了组合数学的知识. 该题其实就等价于求一个括号序列的个数, 因为满足任意时刻, 向右的步数大于等于向左的步数. 但是该题还有停止不动的情况, 所以我们不妨枚举向右的步数, 然后求出括号序列的组合数, 然后剩下的就是停止不动的步数, 用组合数插空即可. 另外, 除法取模要取逆元, 我们可以线性预处理出所有逆元. 细节参见代码: #include<cstdio> #include<cstring> #include&l

[ACM] HDU 4576 Robot (概率DP,滚动数组)

Robot Problem Description Michael has a telecontrol robot. One day he put the robot on a loop with n cells. The cells are numbered from 1 to n clockwise. At first the robot is in cell 1. Then Michael uses a remote control to send m commands to the ro

hdu 5177 (1e18范围的卡特兰数)

hdu 5177 (1e18范围的卡特兰数) 题意: 求第n个卡特兰数,模3814697265625 (5^18) 限制: 有20组数据,1 <= n <= 1e18 思路: 1. 卡特兰数的表达式: ans = 1/(n+1) * C(2*n,n) -> ans = 1/(n+1) * (2n)! / n! / n!    ---1式 2. 因为要模5^18,求逆元要求互质,所以先把"1式"中的因子5全部去掉 3. 然后看不含因子5的阶乘,f(n!) 4. 设g(x