hdu 4185 Oil Skimming(二分匹配)

Oil Skimming

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 883    Accepted Submission(s): 374

Problem Description

Thanks to a certain "green" resources company, there is a new profitable industry of oil skimming. There are large slicks of crude oil floating in the Gulf of Mexico just waiting to be scooped up by enterprising oil barons. One such oil baron has a special
plane that can skim the surface of the water collecting oil on the water‘s surface. However, each scoop covers a 10m by 20m rectangle (going either east/west or north/south). It also requires that the rectangle be completely covered in oil, otherwise the product
is contaminated by pure ocean water and thus unprofitable! Given a map of an oil slick, the oil baron would like you to compute the maximum number of scoops that may be extracted. The map is an NxN grid where each cell represents a 10m square of water, and
each cell is marked as either being covered in oil or pure water.

Input

The input starts with an integer K (1 <= K <= 100) indicating the number of cases. Each case starts with an integer N (1 <= N <= 600) indicating the size of the square grid. Each of the following N lines contains N characters that represent the cells of a row
in the grid. A character of ‘#‘ represents an oily cell, and a character of ‘.‘ represents a pure water cell.

Output

For each case, one line should be produced, formatted exactly as follows: "Case X: M" where X is the case number (starting from 1) and M is the maximum number of scoops of oil that may be extracted.

Sample Input

1
6
......
.##...
.##...
....#.
....##
......

Sample Output

Case 1: 3

解题思路:把这些元素(#)抽象出来,然后,把这些属于两个部分的元素重新建图。

然后,求出最大匹配就OK了。可以用邻接表、或容器存储新图的信息。

#include"stdio.h"
#include"string.h"
#include"stdlib.h"
#include"vector"
using namespace std;
#define N 605
#define M 6005
vector<int>g[M];
int id[N][N],cnt;
int mark[M],link[M];
int dir[4][2]={0,1,0,-1,-1,0,1,0};
char str[N][N];
int find(int k)
{
    int i;
    for(i=0;i<g[k].size();i++)
    {
        int v=g[k][i];
        if(!mark[v])
        {
            mark[v]=1;
            if(link[v]==-1||find(link[v]))
            {
                link[v]=k;
                return 1;
            }
        }
    }
    return 0;
}
int solve(int n)
{
    int i,ans=0;
    memset(link,-1,sizeof(link));
    for(i=0;i<n;i++)
    {
        memset(mark,0,sizeof(mark));
        ans+=find(i);
    }
    return ans;
}
int main()
{
    int i,j,n,T,cas=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        cnt=0;
        for(i=0;i<n;i++)
        {
            scanf("%s",str[i]);
            for(j=0;j<n;j++)
            {
                if(str[i][j]=='#')
                {
                    id[i][j]=cnt++;
                }
            }
        }
        for(i=0;i<M;i++)
            g[i].clear();
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                int x,y,u,v,k;
                if(str[i][j]=='.')
                    continue;
                u=id[i][j];
                for(k=0;k<4;k++)
                {

                    x=dir[k][0]+i;
                    y=dir[k][1]+j;
                    if(x>=0&&x<n&&y>=0&&y<n&&str[x][y]=='#')
                    {
                        v=id[x][y];
                        g[u].push_back(v);
                        g[v].push_back(u);
                    }
                }
            }
        }
        int ans=solve(cnt);
        printf("Case %d: %d\n",cas++,ans/2);     //每条边建了两次,除以2
    }
    return 0;
}

hdu 4185 Oil Skimming(二分匹配),布布扣,bubuko.com

时间: 2024-10-05 13:40:22

hdu 4185 Oil Skimming(二分匹配)的相关文章

HDU 4185 ——Oil Skimming——————【最大匹配、方格的奇偶性建图】

Oil Skimming Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 4185 Description Thanks to a certain "green" resources company, there is a new profitable industry of oil skimming. There ar

HDU 4185 Oil Skimming(离散化 + 二分图匹配)

#include <iostream> #include <cstring> #include <cstdlib> #include <cstdio> #include <vector> #include <queue> #include <stack> #include <cmath> #include <algorithm> #define LL long long #define FOR(i,

HDU 4185 Oil Skimming

二分图的最大匹配 #include<stdio.h> #include<iostream> #include<algorithm> #include<string.h> #include<vector> using namespace std; const int MAXN=1505; int linker[MAXN]; bool used[MAXN]; vector<int>map[MAXN]; int uN; char m[MAX

HDU 1281 棋盘游戏(二分匹配 与 删边)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1281 根据题目描述,什么是重要点?在求出最大匹配后,进行枚举,依次删边,看最大匹配数会不会发生改变,改变的话,那么该点就是重要点. #include <iostream> #include <cstdio> #include <cstdlib> #include <cstring> #include <algorithm> #include <

HDU 2119 Matrix 简单二分匹配

行做x集,列做y集,1就给该行该列连一条边,输出最大匹配边即可 #include<cstdio> #include<cstring> #include<algorithm> #include<iostream> #include<vector> #include<set> using namespace std; #define N 105 int lef[N], pn;//lef[v]表示Y集的点v 当前连接的点 , pn为x点集的

HDU 1083 裸的二分匹配

Courses Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 3424    Accepted Submission(s): 1650 Problem Description Consider a group of N students and P courses. Each student visits zero, one or

hdu 1054 Strategic Game (二分匹配)

Strategic Game Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 4697    Accepted Submission(s): 2125 Problem Description Bob enjoys playing computer games, especially strategic games, but somet

hdu 1281 棋盘游戏 (二分匹配)

//是象棋里的车 符合二分匹配 # include<stdio.h> # include<algorithm> # include<string.h> using namespace std; int n,m,pp[110][110],map[110],vis[110]; int bfs(int x) { for(int i=1;i<=m;i++) { if(!vis[i]&&pp[x][i]) { vis[i]=1; if(!map[i]||bf

hdu 1281 棋盘游戏(二分匹配)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1281 棋盘游戏 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 2905    Accepted Submission(s): 1702 Problem Description 小希和Gardon在玩一个游戏:对一个N*M的棋盘,在格子里放尽