HDU-1034-Candy Sharing Game(C++ && 简单模拟)

Candy Sharing Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3703    Accepted Submission(s): 2311

Problem Description

A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right.
Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.

Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.

Input

The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is
on a line by itself.

Output

For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.

Sample Input

6
36
2
2
2
2
2
11
22
20
18
16
14
12
10
8
6
4
2
4
2
4
6
8
0

Sample Output

15 14
17 22
4 8

Hint

The game ends in a finite number of steps because:
1. The maximum candy count can never increase.
2. The minimum candy count can never decrease.
3. No one with more than the minimum amount will ever decrease to the minimum.
4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.

Source

Greater New York 2003

Recommend

We have carefully selected several similar problems for you:  1035 1037 1038 1018 1028

参照了网上的方法,不得不说,实在是精辟!精简并且容易理解,学习了!

首先解释一下题目:

一定数量的学生围成一个圈,老师站在圆的中心。每个学生最开始有偶数个糖果数。当老师吹一声哨子的时候,每一个学生同时给自己右边的邻居一半的糖果数。所有的学生,在执行这个处理之后,如果他当前的糖果数是奇数个,那么他就可以从老师手中格外获得一个糖果。这个游戏结束的条件是所有的学生都拥有相同的糖果数。写一个程序来求出游戏结束的时候老师吹口哨的次数和每个学生拥有的相同糖果数是多少。

祝室友程教主,和老赵北京蓝桥之战大获全胜!!

接下来上每日一水代码(ps.其实好像没有保证每天都有做......):

//这题是一道简单模拟,注意处理边界条件就行了!

#include<iostream>
#include<cstdio>
#define N 100
using namespace std;
int main()
{
    int s[N],n,i,k,t,p;
    while(scanf("%d",&n) == 1 && n)
    {
        for(i=0;i<n;i++)
            scanf("%d",s+i);
        for(k=1;;k++)
        {
            t=s[n-1]/2;                       //首先t存取最后一个人糖果数的一半,即处理边界条件!
            for(i=0;i<n;i++)
            {
                p=s[i]/2;                     //p存取当前糖果数的一半用来给右边的同学
                s[i]=s[i]/2+t;                //自己减一半再加上左边同学给的一半
                t=p;                          //给完一个同学当然换下一个
                if(s[i]%2!=0)                 //当前处理完如果为奇数,那就还得收老师一个
                    s[i]++;
            }
            t=s[0];
            for(i=1;i<n&&s[0]==s[i];i++);     //如果每个同学拥有的糖果数相同则游戏结束!
            if(i==n)
            {
                break;
            }
        }
        printf("%d %d\n",k,t);                //输出游戏次数和每个人最终的糖果数
    }
    return 0;
}
时间: 2024-10-13 23:27:42

HDU-1034-Candy Sharing Game(C++ && 简单模拟)的相关文章

HDU 1034 Candy Sharing Game 模拟题

一个分糖游戏,找了会规律,没找到,只能直接模拟玩了. 果然0ms过了,看来数据不大,只是考编码能力罢了. #include <stdio.h> #include <vector> #include <string.h> #include <algorithm> #include <iostream> #include <string> #include <limits.h> #include <stack> #

hdu 1034 Candy Sharing Game

Candy Sharing Game Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 4942    Accepted Submission(s): 3020 Problem Description A number of students sit in a circle facing their teacher in the cente

HDU 1048 What Is Your Grade? (简单模拟)

 What Is Your Grade? Problem Description "Point, point, life of student!" This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in

HDU 4891 简单模拟

The Great Pan Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 1035    Accepted Submission(s): 355 Problem Description As a programming contest addict, Waybl is always happy to take part in vario

HDU 4772 Zhuge Liang&#39;s Password (简单模拟题)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4772 题面: Zhuge Liang's Password Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1404    Accepted Submission(s): 926 Problem Description In the anc

hdu 1800 Flying to the Mars(简单模拟,string,字符串)

题目 又来了string的基本用法 //less than 30 digits //等级长度甚至是超过了int64,所以要用字符串来模拟,然后注意去掉前导零 //最多重复的个数就是答案 //关于string的修改增加的用法 #include <cstdio> #include<iostream> #include <cstring> #include <algorithm> #include<string> using namespace std

HDU ACM 1057 A New Growth Industry 简单模拟

题意:给一个天数N,求20*20方阵内细菌的变化情况.每次变化加上一个d[k],d数组有给定的16个数.k是某个格子它本身加上它上下左右的四个数. 简单模拟题. 分析: #include<iostream> using namespace std; int dir[4][2]={{-1,0},{1,0},{0,-1},{0,1}}; char den[]=".!X#"; int D[16]; int map[20][20],tmp[20][20]; void Fun() {

(hdu step 8.1.6)士兵队列训练问题(数据结构,简单模拟——第一次每2个去掉1个,第二次每3个去掉1个.知道队伍中的人数&lt;=3,输出剩下的人 )

题目: 士兵队列训练问题 Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 56 Accepted Submission(s): 37   Problem Description 某部队进行新兵队列训练,将新兵从一开始按顺序依次编号,并排成一行横队,训练的规则如下:从头开始一至二报数,凡报到二的出列,剩下的向小序号方向靠拢,再从头开始进行一至三

ACM-模拟之Candy Sharing Game——hdu1034

Candy Sharing Game Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 2897    Accepted Submission(s): 1811 Problem Description A number of students sit in a circle facing their teacher in the cent