UVa 133 The Dole Queue

 The Dole Queue 

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a
large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1‘s left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while
another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again
at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each
set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by
the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0

Sample output

 4  8,  9  5,  3  1,  2  6,  10,  7

where  represents a space.

N个人按逆时针从一到n排成一个环  官员1从1开始每次逆时针走过k个人  选出停留地方的人  官员2从n开始每次顺时针走过m个人  选出停留地方的人

若停留地方相同   则只选出一个人   求这些人被选出的顺序   直接模拟就行了;

#include<cstdio>
#include<cstring>
using namespace std;
const int N = 22;
int a[N], n, k, m, r, t1, t2;

int main()
{
    while (scanf ("%d%d%d", &n, &k, &m), n)
    {
        memset (a, -1, sizeof (a));
        t2 = 1;
        t1 = r = n;
        while (r)
        {
            for (int i = 1; i <= k; ++i)
                do t1 = ((t1 == n) ? 1 : t1 + 1); while (a[t1] == 0);
            for (int i = 1; i <= m; ++i)
                do t2 = ((t2 == 1) ? n : t2 - 1); while (a[t2] == 0);

            r = (t1 == t2 ? r - 1 : r - 2);
            if (t1 == t2)  printf ("%3d", t1);
            else printf ("%3d%3d", t1, t2);
            a[t1] = a[t2] = 0;
            if (r)  printf (",");
        }
        printf ("\n");
    }
    return 0;
}

UVa 133 The Dole Queue,布布扣,bubuko.com

时间: 2024-11-08 00:44:42

UVa 133 The Dole Queue的相关文章

UVA - 133 The Dole Queue(模拟链表)

点击打开链接 n的人围成一个环,然后按逆时针编号1-n,一个人从1开始逆时针数k个数,另一个人从N开始顺时针数m个数,然后 数出来的两个人出列(两个人可能一样)出列,然后继续此过程,直到全部人都出列为止. 思路是用循环链表来模拟,注意 要分情况来讨论. #include <iostream> #include <cstdio> #include <cmath> #include <vector> #include <cstring> #inclu

uva - 133 The Dole Queue(成环状态下的循环走步方法)

类型:循环走步 1 #include <iostream> 2 #include <sstream> 3 #include <cstdio> 4 #include <cstring> 5 #include <cmath> 6 #include <string> 7 #include <vector> 8 #include <set> 9 #include <cctype> 10 #include &

133 - The Dole Queue

The Dole Queue In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is

The Dole Queue UVA - 133

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily cho

uva The Dole Queue

题目如下: The Dole Queue  In a serious attempt to downsize (reduce) the dole queue, The NewNational Green Labour Rhinoceros Party has decided on the followingstrategy. Every day all dole applicants will be placed in a largecircle, facing inwards. Someone

UVA 133(循环链表)

C - The Dole Queue Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu Submit Status Description  The Dole Queue  In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided

The Dole Queue

Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu Submit cid=1036#status//A/0" class="ui-button ui-widget ui-state-default ui-corner-all ui-button-text-only" style="font-family:Verdana,Arial,sans-serif; font-si

uva133 The Dole Queue ( 约瑟夫环的模拟)

题目链接: 啊哈哈,选我选我 思路是: 相当于模拟约瑟夫环,仅仅只是是从顺逆时针同一时候进行的,然后就是顺逆时针走能够编写一个函数,仅仅只是是走的方向的标志变量相反..还有就是为了(pos+flag+n-1)%n+1的妙用... 题目:  The Dole Queue  In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decid

UVa 133 救济金发放

题意:所有n个人围成一个圈,一边从1号开始逆时针数k个,出局:一边从n号开始顺时针数m个,出局.两个同时发生.如果这两个数到同一个人,就这个人出局. facing inwards 面朝里: counter 相反地,clockwise 顺时针,counter-clockwise 逆时针 思路:双向循环链表来模拟.按以前书上介绍的实现的,有一个头指针,首尾都指向它.但这里由于要找第k个.第m个,需要进行头指针的判断,所以觉得这里不增加头指针比较好,或者头指针只指向头结点,而头结点和尾结点是互指的,不