杨辉三角实例菱形实例

杨辉三角实例

public class Hui {
    public static void main (String [] args){

        int [][] a =new int [10][10];
        for(int i=0;i<a.length;i++){
            for(int j=0;j<=i;j++){
                if(j==0||i==j){
                    System.out.print(" "+(a[i][j]=1));
                }else
                {a[i][j]=a[i-1][j-1]+a[i-1][j];
                System.out.print(" "+a[i][j]);
                }
            }System.out.println("");
        }
    }

}

菱形 和  三角形

public class lingxing {
    public static void main(String []args){
        /*random();*/
       lingxing();
        for(int a=1;a<=5;a++){
            for(int b=5;b>a;b--){
                System.out.print(" ");
            }
            for(int c=1;c<=2*a-1;c++){
                if(c==1||c==2*a-1&a<=4){
                    System.out.print("*");
                }else if(a==5){
                    System.out.print("*");
                }else{
                    System.out.print(" ");
                }

            }
            System.out.println("");

        }

    }

    private static void lingxing() {
        int n=5;
        for(int i=5;i>0;i--){
            for(int j=1;j<=i;j++){
            System.out.print(" ");
            }
            for(int a=1;a<=(6-i)*2-1;a++){
                 System.out.print("*");
            }
            System.out.println();
        }

    for(int i=4;i>0;i--){    //三角形
        for(int j=1;j<=5-i;j++){
        System.out.print(" ");
        }System.out.print(" ");
        for(int a=1;a<=2*i-1;a++){
             System.out.print("*");
        }
        System.out.println("");
    }

 

时间: 2024-10-12 08:10:32

杨辉三角实例菱形实例的相关文章

java 实例之杨辉三角

public class study{ public static void main(String args[]){ int i,j,level=7; int Yang[][] = new int[level][]; System.out.println("杨辉三角"); for(i = 0;i<Yang.length;i++){ Yang[i] = new int[i+1]; } Yang[0][0] = 1; //第一个元素为1 } for(i = 1;i<Yang.

列表生成式的复习以及生成器的练习, 杨辉三角实例(非常巧妙)

列表生成式 print('昨日复习--------------------') d = {'a':1, 'b':2, 'c':3} for key in d: print(key) for value in d.values(): print(value) for k, v in d.items(): print(k, v) for ch in 'ABC': print(ch) from collections import Iterable t = isinstance(123, Iterab

HDU 2032 杨辉三角

杨辉三角 Problem Description 还记得中学时候学过的杨辉三角吗?具体的定义这里不再描述,你可以参考以下的图形: 1 1 1 1 2 1 1 3 3 1 1 4 6 4 1 1 5 10 10 5 1 Input 输入数据包含多个测试实例,每个测试实例的输入只包含一个正整数n(1<=n<=30),表示将要输出的杨辉三角的层数. Output 对应于每一个输入,请输出相应层数的杨辉三角,每一层的整数之间用一个空格隔开,每一个杨辉三角后面加一个空行. Sample Input 2

hdoj 2032 杨辉三角

杨辉三角 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 41563    Accepted Submission(s): 17414 Problem Description 还记得中学时候学过的杨辉三角吗?具体的定义这里不再描述,你可以参考以下的图形:11 11 2 11 3 3 11 4 6 4 11 5 10 10 5 1 Inpu

杨辉三角 杭电2032

11 11 2 11 3 3 11 4 6 4 11 5 10 10 5 1 Input 输入数据包含多个测试实例,每个测试实例的输入只包含一个正整数n(1<=n<=30),表示将要输出的杨辉三角的层数. Output 对应于每一个输入,请输出相应层数的杨辉三角,每一层的整数之间用一个空格隔开,每一个杨辉三角后面加一个空行. Sample Input 2 3 Sample Output 1 1 1 1 1 1 1 2 1 #include<stdio.h> int main() {

HDOJ2032杨辉三角

★杨辉三角的规律是很明显的: ◇每一行的第一个数和最后一个数都为1: ◇从第三行开始,除去第一个数和最后一个数,其余的数都是上一行中两个数的和: ◇每个实例最后一行的数字个数都等于这个实例的层数: 因此这个题目的关键就是用代码将上述规律描述清楚的过程,没有复杂的数据结构和算法. ★代码实现: #include <stdio.h> static int a[100][100]; int main() { int i,j,num; while(scanf("%d",&n

&lt;hdu-2032&gt;杨辉三角

这是杭电hdu上杨辉三角的链接:http://acm.hdu.edu.cn/showproblem.php?pid=2032 Problem Description: 还记得中学时候学过的杨辉三角吗?具体的定义这里不再描述,你可以参考以下的图形: 1 1 1 1 2 1 1 3 3 1 1 4 6 4 1 1 5 10 10 5 1 Input: 输入数据包含多个测试实例,每个测试实例的输入只包含一个正整数n(1<=n<=30),表示将要输出的杨辉三角的层数. Output: 对应于每一个输入

一维数组实现杨辉三角

杨辉三角 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 43411    Accepted Submission(s): 18254 Problem Description 还记得中学时候学过的杨辉三角吗?具体的定义这里不再描述,你可以参考以下的图形: 1 1 1 1 2 1 1 3 3 1 1 4 6 4 1 1 5 10 10 5

杭州电子科技大学 Online Judge 之 “杨辉三角(ID2032)”解题报告

杭州电子科技大学 OnlineJudge 之 "杨辉三角(ID2032)"解题报告 巧若拙(欢迎转载,但请注明出处:http://blog.csdn.net/qiaoruozhuo) Problem Description 还记得中学时候学过的杨辉三角吗?具体的定义这里不再描述,你可以参考以下的图形: 1 1 1 1 2 1 1 3 3 1 1 4 6 4 1 1 5 10 10 5 1 Input 输入数据包含多个测试实例,每个测试实例的输入只包含一个正整数n(1<=n<