kruskal算法求最小生成树(jungle roads的kruskal解法)

注意:

  注意数组越界问题(提交出现runtimeError代表数组越界)

  刚开始提交的时候,边集中边的数目和点集中点的数目用的同一个宏定义,但是宏定义是按照点的最大数定义的,所以提交的时候出现了数组越界问题,以后需要注意啦。

Description


The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30
//数组越界会出现runtimeerror的错误,注意边的数目和点的数目不一样,用一个宏定义的时候注意是否会出现数组越界问题

/*
    题意:
        多组案例
        每组案例第一行输入一个数字n
        下面n-1行
        每行的第一个数据都是一个字符start,字符从A往后依次排列
        每行的第二个数据是一个数字num,表示有num个节点与该行第一个字符表示的节点相连
        每行接下来的数据是num组end,cost,表示start到end的花费为cost
        具体输入输出看案例就会懂
    解法:Kruskal算法
*/
#include <stdio.h>
#include <algorithm>
#include <stdlib.h>
#include <iostream>
using namespace std;
const int MAXN=30;
/*边结构*/
typedef struct{
    int start;//道路起点
    int end;//道路终点
    double value;//道路权值
}Edge;
Edge road[80];

/*节点集合*/
int node[MAXN];
/*寻根函数*/
int Find_set(int n){
    if(node[n]==-1) return n;
    return node[n] == n ? node[n] : Find_set(node[n]);
    //return node[n]=Find_set(node[n]);
}
/*排序中的比较函数*/
bool cmp(Edge a,Edge b){
    if(a.value<b.value) return true;
    return false;
}
/*合并:将棵树合并成一棵树*/
bool Merge(int a,int b){
    int r1=Find_set(a);
    int r2=Find_set(b);
    if(r1==r2) return false;
    if(r1<r2) node[r2]=r1;
    if(r2<r1) node[r1]=r2;
    return true;
}
/*克鲁斯卡尔算法*/
int Kruskal(int N,int M){ //N 顶点数  M 边数
     int num=0;
     int cost=0;
     sort(road,road+M,cmp);
     for(int i=0;i<M;i++){
         if(Merge(road[i].start,road[i].end)){
             num++;
             cost+=road[i].value;
         }
         if(num==N-1) break;
     }
     if(num!=N-1) return -1;  //不能产生最小生成树
     else return cost;
}
int main()
{
    int n;
    //freopen("input.txt", "r", stdin);
    while(scanf("%d", &n) != EOF)
    {
        if(n == 0)
            break;
        for(int i = 0; i < n; i++)
            node[i] = i;
        char s, e;
        int num, cost, k = 0;
        for(int i = 0; i < n-1; i++)
        {
            cin >> s >> num;
            for(int j = 0; j < num; j++, k++)
            {
                cin >> e >> cost;
                road[k].start = s - ‘A‘;
                road[k].end = e - ‘A‘;
                road[k].value = cost;
            }
        }
        sort(road, road+k, cmp);
        int ret = Kruskal(n, k);
        printf("%d\n", ret);
    }
    return 0;
}
时间: 2024-10-19 03:07:36

kruskal算法求最小生成树(jungle roads的kruskal解法)的相关文章

利用Kruskal算法求最小生成树解决聪明的猴子问题 -- 数据结构

题目:聪明的猴子 链接:https://ac.nowcoder.com/acm/problem/19964 在一个热带雨林中生存着一群猴子,它们以树上的果子为生.昨天下了一场大雨,现在雨过天晴,但整个雨林的地 表还是被大水淹没着,部分植物的树冠露在水面上.猴子不会游泳,但跳跃能力比较强,它们仍然可以在露出水面 的不同树冠上来回穿梭,以找到喜欢吃的果实.现在,在这个地区露出水面的有N棵树,假设每棵树本身的直径都 很小,可以忽略不计.我们在这块区域上建立直角坐标系,则每一棵树的位置由其所对应的坐标表

Prim算法和Kruskal算法求最小生成树

Prim算法 连通分量是指图的一个子图,子图中任意两个顶点之间都是可达的.最小生成树是连通图的一个连通分量,且所有边的权值和最小. 最小生成树中,一个顶点最多与两个顶点邻接:若连通图有n个顶点,则最小生成树中一定有n-1条边. Prim算法需要两个线性表来进行辅助: visited: 标记已经加入生成树的顶点:(它的功能可以由tree取代) 初始状态:生成树根节点为真,其它为0. tree: 记录生成树,tree[x]保存顶点x的直接根节点下标,若x为树的根节点则tree[x]为其自身. 初始状

Kruskal算法求最小生成树

求加权连通图的最小生成树的算法.kruskal算法总共选择n- 1条边,(共n条边)所使用的贪婪准则是:从剩下的边中选择一条不会产生环路的具有最小耗费的边加入已选择的边的集合中.注意到所选取的边若产生环路则不可能形成一棵生成树.kruskal算法分e 步,其中e 是网络中边的数目.按耗费递增的顺序来考虑这e 条边,每次考虑一条边.当考虑某条边时,若将其加入到已选边的集合中会出现环路,则将其抛弃,否则,将它选入. 克鲁斯卡尔算法(Kruskal's algorithm)是两个经典的最小生成树算法的

Prime算法求最小生成树 (邻接表)

/* Name: Prime算法求最小生成树 (邻接表) Copyright: Author: 巧若拙 Date: 25/11/14 13:38 Description: 实现了 Prime算法求最小生成树 (邻接表)的普通算法和最小堆优化算法. */ #include<stdio.h> #include<stdlib.h> #define MAX 2000   //最大顶点数量 #define INFINITY 999999   //无穷大 typedef int VertexT

Prime算法求最小生成树 (邻接矩阵)

/* Name: Prime算法求最小生成树 (邻接矩阵) Copyright: Author: 巧若拙 Date: 25/11/14 13:38 Description: 实现了 Prime算法求最小生成树 (邻接矩阵)的普通算法和最小堆优化算法. */ #include<stdio.h> #include<stdlib.h> #define MAX 2000   //最大顶点数量 #define INFINITY 999999   //无穷大 typedef struct Mi

最小生成树 克鲁斯卡尔(Kruskal)算法求最小生成树

Kruskal算法的过程: (1) 将全部边按照权值由小到大排序. (2) 按顺序(边权由小到大的顺序)考虑没条边,只要这条边和我们已经选择的边步构成圈,就保留这条边,否则放弃这条边.算法 成功选择(n-1)条边后,形成一个棵最小生成树,当然如果算法无法选择出(n-1)条边,则说明原图不连通. 图中的路径按照权值的大小的排序为 AF 1; BE 4; BD 5; BC 6; DC:10; BF 11; DF 14; AE 16; AB 17; EF 33; 算法的处理过程如下 先选A,F不在一个

hdu 1875 畅通工程再续(kruskal算法计算最小生成树)

畅通工程再续 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 18411    Accepted Submission(s): 5769 Problem Description 相信大家都听说一个"百岛湖"的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现.现在政府决定大力发展百岛湖,发展首先

Kruskal算法(最小生成树)

Kruskal算法:首先按照边的权值进行从小到大排序,每次从剩余的边中选择权值最小的边且不会产生回路的边加入到生成树中,直到加入n-1条边就结束: 算法难点在与如何判断是否会产生回路.这个可以通过并查集实现,将所有加入生成树的结点加入同一个集合: 代码: #include <string.h> #include<iostream> #include<vector> #include<queue> #include <algorithm> usin

Kruskra算法求最小生成树

算法思想: (1)创建图,将每个节点的根节点,标记为-1. (2)对图中的边按权重排序 (3)遍历每条边,获取边两端的根节点 如果两个端点的根节点相等,且均是-1,则代表这是一条孤立的边(同时修改目的节点的父节点设为源节点),把这条边计入生成树 如果两个端点的根节点相等,且不是-1(可能是-2,-3,之类),这说明加入这条边构成环路,不需要任何操作 如果两个端点的根节点不相等,这说明这条边连接了两棵树,(同时修改目的节点根节点的父节点设为源节点),把这条边计入生成树 注:其实我们知道最小生成树,