PAT 1004 To Fill or Not to Fill (25)

题目描写叙述

With highways available, driving a car from Hangzhou to any other city is easy.  But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time.  Different gas station may give different price.  You are asked to carefully design the cheapest route to go.

输入描写叙述:

Each input file contains one test case.  For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations.  Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,...N.  All the numbers in a line are separated by a space.

输出描写叙述:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places.  It is assumed that the tank is empty at the beginning.  If it is impossible to reach the destination, print "The maximum travel distance = X" where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

输入样例:

50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

输出样例:

749.17
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <climits>

using namespace std;

typedef struct Node
{
	double price;
	double distance;
}Node;

bool cmp(const Node& lhs, const Node& rhs)
{
	return lhs.distance<rhs.distance;
}

int main()
{
	double Cm,D,cur,cost,minCost,maxDistance;
	int Da,N;
	int i,j,k,l,ans;
	while(cin>>Cm>>D>>Da>>N)
	{
		maxDistance=Cm*Da;
		Node *node=new Node[N+1];
		for(i=0;i<N;i++)
			cin>>node[i].price>>node[i].distance;

		sort(node,node+N,cmp);

		node[N].price=0;
		node[N].distance=D;

		ans=cur=cost=0;
		for(i=0;i<N-1;i++)
		{
			if((node[i+1].distance-node[i].distance)>maxDistance)
				break;
		}
		if(i<N-1)
		{
			printf("The maximum travel distance = %.2lf\n",node[i].distance+maxDistance);
		}
		else
		{
			for(i=0;i<N;)
			{

				//后面假设有比当前更廉价的汽油,如今先少弄点,够到那个地方就OK
				l=i;
				minCost=node[i].price;
				for(j=i+1;j<=N && (node[i].distance+maxDistance>=node[j].distance);j++)
				{
					if(minCost>node[j].price)
					{
						l=j;
						break;
					}
				}
				if(l!=i)
				{
					cost=cost+((node[l].distance-node[i].distance)/Da-cur)*node[i].price;
					cur=0;
					i=l;
					continue;
				}
				//假设找不到更廉价的加油站。找出相对最廉价的加油站。而且在当前加油站加满油
				l=i;
				minCost=1e18;
				for(j=i+1;j<=N && (node[i].distance+maxDistance>=node[j].distance);j++)
				{
					if(minCost>node[j].price)
					{
						minCost=node[j].price;
						l=j;
					}
				}
				cost=cost+(Cm-cur)*node[i].price;
				cur=Cm-(node[l].distance-node[i].distance)/Da;
				i=l;
			}
			printf("%.2lf",cost);
		}
/*

		for(i=0;i<N;i++)
			cout<<node[i].price<<" "<<node[i].distance<<endl;

*/
	}
	return 0;
}

贴个图

时间: 2024-10-06 00:41:06

PAT 1004 To Fill or Not to Fill (25)的相关文章

PAT 1033. To Fill or Not to Fill (25)(贪心)

解题思路: 其实题目本身不难,难就难在对贪心策略的选取 在每一个加油点应该做这样的判断: 1.首先计算从本加油点做多可能达到的加油点 2.如果有可达加油点的话: 2.1 寻找有无比当前加油点油价便宜的加油点,如果有的话就跑到该便宜的加油点,油量加到支持到该加油点即可 2.2 如果没有比当前加油点更便宜的加油点的话,又分两种情况: 2.2.1.如果本次加油可能直接到终点,就加可以到达终点的油量 2.2.2.否则的话,加满 3.如果没有可达加油点的话: 3.1 看是否可以直接达到终点 3.2 不能达

【贪心】PAT 1033. To Fill or Not to Fill (25)

1033. To Fill or Not to Fill (25) 时间限制 10 ms 内存限制 32000 kB 代码长度限制 16000 B 判题程序 Standard 作者 ZHANG, Guochuan With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to fin

PAT 1033 To Fill or Not to Fill[dp]

1033 To Fill or Not to Fill(25 分) With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may gi

九度oj 1437 To Fill or Not to Fill 2012年浙江大学计算机及软件工程研究生机试真题

题目1437:To Fill or Not to Fill 时间限制:1 秒 内存限制:128 兆 特殊判题:否 提交:1488 解决:345 题目描述: With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way fro

PAT 1004. Counting Leaves (30)

A family hierarchy is usually presented by a pedigree tree.  Your job is to count those family members who have no child. Input Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tre

pat1033. To Fill or Not to Fill (25)

1033. To Fill or Not to Fill (25) 时间限制 10 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 ZHANG, Guochuan With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to fin

1033 To Fill or Not to Fill (25 分)

1033 To Fill or Not to Fill (25 分) With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may g

PAT (Advanced Level) 1055. The World&#39;s Richest (25)

排序.随便加点优化就能过. #include<iostream> #include<cstring> #include<cmath> #include<algorithm> #include<cstdio> #include<map> #include<queue> #include<string> #include<stack> #include<vector> using names

PAT 1033. To Fill or Not to Fill

#include <cstdio> #include <cstdlib> #include <vector> #include <algorithm> using namespace std; int main() { int N; double mcap, dist, davg; scanf("%lf%lf%lf%d", &mcap, &dist, &davg, &N); double price, id