HDU 1114 Piggy-Bank(完全背包)

题目:

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it‘s weight in grams.

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

Sample Input

3

10 110

2

1 1

30 50

10 110

2

1 1

50 30

1 6

2

10 3

20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.

The minimum amount of money in the piggy-bank is 100.

This is impossible.

题意:

比较简单的完全背包,注意状态转移方程就行了

状态转移方程:

dp[j] = min(dp[j],dp[j-w[i]]+p[i]) (w[i]储存的为重量)

多的不逼逼,直接贴代码

实现代码:

#include<iostream>
using namespace std;

int main()
{
    long long  m,x,y,p[50005],w[10005],dp[10005],i,j,wei,n;
    cin>>m;
    while(m--)
    {
        cin>>x>>y;
        wei = y - x;
        cin>>n;
        for(i=0;i<n;i++)
        {
            cin>>p[i]>>w[i];
        }
        for(i=1;i<=wei;i++)
            dp[i] =  100000000;
        dp[0] = 0;
        for(i=0;i<n;i++)
        {
            for(j=w[i];j<=wei;j++)
            {
                dp[j] = min(dp[j],dp[j-w[i]]+p[i]);
            }
        }
        if(dp[wei] == 100000000)
            cout<<"This is impossible."<<endl;
        else
            cout<<"The minimum amount of money in the piggy-bank is "<<dp[wei]<<"."<<endl;
    }
    return 0;
}
时间: 2024-10-14 15:19:16

HDU 1114 Piggy-Bank(完全背包)的相关文章

HDU 1114 (dp 完全背包)

鏈接:http://acm.hdu.edu.cn/showproblem.php?pid=1114 Problem Description Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The i

hdu(1114)——Piggy-Bank(完全背包)

唔..最近在练基础dp 这道题挺简单的(haha),但是我只想说这里得注意一个细节. 首先题意: 有T组样例,然后给出储蓄罐的起始重量E,结束重量F(也就是当它里面存满了零钱的时候),然后给你一个数N,代表现在有N种类型的硬币. 然后接下来N行,每行分别有两个数字P,W,P代表的是这种类型零钱的价值,W则代表的是这种类型零钱的重量,零钱的数量不限. 然后要你输出在满足当前重量就是F的情况下(也就是重量刚好为F),输出所需零钱价值最少的情况. 思路: 很显然,这明显就是一个完全背包.但是这里唯一要

hdu(1114)——Piggy-Bank(全然背包)

唔..近期在练基础dp 这道题挺简单的(haha).可是我仅仅想说这里得注意一个细节. 首先题意: 有T组例子,然后给出储蓄罐的起始重量E,结束重量F(也就是当它里面存满了零钱的时候).然后给你一个数N,代表如今有N种类型的硬币. 然后接下来N行,每行分别有两个数字P,W,P代表的是这样的类型零钱的价值,W则代表的是这样的类型零钱的重量,零钱的数量不限. 然后要你输出在满足当前重量就是F的情况下(也就是重量刚好为F),输出所需零钱价值最少的情况. 思路: 非常显然,这明显就是一个全然背包.可是这

HDU 1114 Piggy-Bank--DP--(裸完全背包)

题意:有n种硬币可放进存钱罐,已重量知每种硬币的重量和价值,又知存钱罐的重量为e和装了硬币之后的重量为f,求存钱罐里最少有多少钱 分析:模型就是完全背包,跟求用的最少的n种面值不同的钱凑成s元一样,就是求在总重量(f-e)一定的情况下这些硬币最少能凑 多少钱 dp[i]表示重量为i的时候最少的价值,状态转移方程:dp[i]=min(dp[i],dp[i-w[j]]+p[i]),其中i>=w[j],最终答案就是dp[f-e],注意有无解的情况 代码: #include<iostream>

HDU 1114 Piggy-Bank(完全背包 DP)

题意  知道空存钱罐的重量和装满钱的存钱罐的重量及每种币值的重量   求存钱罐里至少有多少钱 裸的完全背包  但是是求最小值  所以初始0要变成初始INF  max也要变成min #include<cstdio> #include<cstring> #include<algorithm> using namespace std; const int N = 10005, INF = 0x3f3f3f3f; int val[N], wei[N], d[N]; int ma

F - Piggy-Bank HDU 1114 (完全背包的变形+初始化细节)

F - Piggy-Bank Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u Submit Status Practice HDU 1114 Description Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for th

HDU 1114 Piggy-Bank(一维背包)

题目地址:HDU 1114 把dp[0]初始化为0,其它的初始化为INF.这样就能保证最后的结果一定是满的,即一定是从0慢慢的加上来的. 代码例如以下: #include <algorithm> #include <iostream> #include <cstring> #include <cstdlib> #include <cstdio> #include <queue> #include <cmath> #incl

hdu 1114 完全背包问题

题意:给定背包体积与物品的体积与价值 求正好放完的最小价值#include<iostream> using namespace std; int min(int a,int b) { if(a<b) return a; return b; } int main() { int t,m1,m2,n,i,j; int v[502],w[502],dp[10005],m; cin>>t; while(t--) { cin>>m1>>m2; m=m2-m1;

[2016-03-27][HDU][1114][Piggy-Bank]

时间:2016-03-27 16:37:56 星期日 题目编号:[2016-03-27][HDU][1114][Piggy-Bank] 遇到的问题:注意f == e的情况,即dp[0] = 0; #include <cstring> #include <cstdio> #include<algorithm> using namespace std; int dp[10000 + 10]; int w[500 + 10],c[500 + 10]; int main(){