Anniversary party

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9354   Accepted: 5400

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests‘ conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0

Output

Output should contain the maximal sum of guests‘ ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

Source

Ural State University Internal Contest October‘2000 Students Session

题目大意:要开派对 n个人来派对会贡献一定的快乐值 有n-1个关系 K L为L为K的直接上司

i和他的直接上司不能一起参加派对 求最大的快乐值

题解

树形dp dp[i][0]为第i个点不去的最大值,dp[i][1]为第i个点去的最大值。

最后答案为dp[rt][0]和dp[rt][1]的最大值。

代码

#include<iostream>
#include<cstdio>
using namespace std;

int n,x,y,rt;
int dp[6005][3],dad[6005];

void tree_dp(int now){
    for(int i=1;i<=n;i++)
     if(dad[i]==now){
         tree_dp(i);
         dp[now][1]+=dp[i][0];
         dp[now][0]+=max(dp[i][0],dp[i][1]);
     }
}

int main(){
    scanf("%d",&n);
    for(int i=1;i<=n;i++)scanf("%d",&dp[i][1]);
    for(int i=1;i<n;i++)scanf("%d%d",&x,&y),dad[x]=y;
    rt=n;
    while(dad[rt])rt=dad[rt];
    tree_dp(rt);
    printf("%d",max(dp[rt][1],dp[rt][0]));
    return 0;
}
时间: 2024-10-12 21:42:22

Anniversary party的相关文章

HDU1520——树形DP——Anniversary party

Problem Description There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E.

POJ1020 Anniversary Cake

Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 16683   Accepted: 5442 Description Nahid Khaleh decides to invite the kids of the "Shahr-e Ghashang" to her wedding anniversary. She wants to prepare a square-shaped chocolate cake wit

BestCoder 1st Anniversary

problem 1001 Souvenir Accepts: 901 Submissions: 2743 Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others) 问题描述 今天是BestCoder一周年纪念日. 比赛管理员Soda想要给每个参赛者准备一个纪念品. 商店里纪念品的单价是p元, 同时也可以花q元购买纪念品套装, 一个套装里有mm个纪念品. 今天总共有nn个参赛者, Soda想

ural 1039 Anniversary Party

1039. Anniversary Party Time limit: 0.5 secondMemory limit: 8 MB Background The president of the Ural State University is going to make an 80'th Anniversary party. The university has a hierarchical structure of employees; that is, the supervisor rela

poj2342 Anniversary party 简单树形dp

http://poj.org/problem?id=2342 Anniversary party Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 4322   Accepted: 2459 Description There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The Universi

HDOJ 题目1520 Anniversary party(树形dp)

Anniversary party Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6271    Accepted Submission(s): 2820 Problem Description There is going to be a party to celebrate the 80-th Anniversary of the

HDU-1520 Anniversary party (树形DP)

Problem Description There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E.

BestCoder 2nd Anniversary的前两题

Oracle Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)Total Submission(s): 79    Accepted Submission(s): 41 Problem Description There is once a king and queen, rulers of an unnamed city, who have three daughters

hdu 1520 Anniversary party || codevs 1380 树形dp

Anniversary party Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Problem Description There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical