poj1251 最小生成树

Description

The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.

Sample Input

9

A 2 B 12 I 25

B 3 C 10 H 40 I 8

C 2 D 18 G 55

D 1 E 44

E 2 F 60 G 38

F 0

G 1 H 35

H 1 I 35

3

A 2 B 10 C 40

B 1 C 20

0

Sample Output

216

30

大致题意:在相通n个岛屿的所有桥都坏了,要重修,重修每一个桥所用的时间不同,求重修使每个岛屿都间接或直接与其他岛屿相连时所用的的最短时间(只有修完一个桥后才可修下一个桥)。简言之就是求最小生成树。
对于数据,数据输入的第一行n代表岛屿的个数,当为0是结束程序,接着n-1行开始时为这岛屿的编号,用大写字母表示,接着是一个整数m,表示与该岛屿连接的字典序大于该岛屿编号的个数,然后该行输入m对数据,每对数据的第一个字母表示与该岛屿连通的岛屿的编号,第二个数字表示要重修两岛屿之间桥所需要的时间,输出数据见样例及原题。
该题图为稀疏图,用Kruskal算法比较好,经过昨天对于生成树的题目的训练

prim:// 不懂见百度百科

思路:一直找最小的边直到所有的点都被加到最小生成树中

#include<iostream>
using namespace std;
#define mx 1<<29

int map[30][30];
int r[30],v[30];
int n,m,t,i,j,p,mi;
char a,b;

void prim()
{
    for(i=0; i<n; i++)
    {
        r[i]=map[0][i];
        v[i]=0;
    }
    for(i=1; i<=n; i++)
    {
        mi=mx;
        for(j=0; j<n; j++)
            if(!v[j] && r[j]<mi)
                mi=r[j],p=j;
        v[p]=1;
        for(j=0; j<n; j++)
            if(!v[j] && map[p][j]<r[j])
                r[j]=map[p][j];
    }
    for(i=1; i<n; i++) r[0]+=r[i];
    cout<<r[0]<<endl;
}
int main()
{
    while(cin>>n && n)
    {
        for(i=0; i<n; i++)
            for(j=0; j<n; j++)
                if(i==j) map[i][j]=0;
                else map[i][j]=mx;
        for(i=1; i<n; i++)
        {
            cin>>a>>m;
            while(m--)
            {
                cin>>b>>t;
                map[a-‘A‘][b-‘A‘]=map[b-‘A‘][a-‘A‘]=t;
            }
        }
        prim();
    }
    return 0;
}

Kruskal: 假设 WN=(V,{E}) 是一个含有 n 个顶点的连通网,则按照克鲁斯卡尔算法构造最小生成树的过程为:先构造一个只含 n 个顶点,而边集为空的子图,若将该子图中各个顶点看成是各棵树上的根结点,则它是一个含有 n 棵树的一个森林。之后,从网的边集 E 中选取一条权值最小的边,若该条边的两个顶点分属不同的树,则将其加入子图,也就是说,将这两个顶点分别所在的两棵树合成一棵树;反之,若该条边的两个顶点已落在同一棵树上,则不可取,而应该取下一条权值最小的边再试之。依次类推,直至森林中只有一棵树,也即子图中含有 n-1条边为止。

代码:

#include<iostream>
#include<algorithm>
using namespace std;

struct Edge
{
    int b,e,w;
} r[900];
int p[30];
int n,m,t,k,q,ans;
char a,b;
int i,j;
int cmp(Edge x,Edge y)
{
    return x.w<y.w;
}

int Find(int x)
{
    if(x!=p[x]) p[x]=Find(p[x]);
    return p[x];
}

void Union(int x,int y)
{
    x=Find(x);
    y=Find(y);
    p[y]=x;
}

void kruskal()
{
    q=0;
    ans=0;
    for(i=0; i<k; i++)
    {
        if(Find(r[i].b) != Find(r[i].e))
        {
            ans+=r[i].w;
            Union(r[i].b,r[i].e);
            q++;
        }
        if(q==n-1) break;
    }
    cout<<ans<<endl;
}

int main()
{
    while(cin>>n && n)
    {
        for(i=0; i<n; i++)
            p[i]=i;
        k=0;
        for(i=1; i<n; i++)
        {
            cin>>a>>m;
            while(m--)
            {
                cin>>b>>t;
                r[k].b=a-‘A‘;
                r[k].e=b-‘A‘;
                r[k++].w=t;
            }
        }
        sort(r,r+k,cmp);
        kruskal();
    }
    return 0;
}
//注意一下有时候用到并查集的路径压缩
时间: 2024-12-07 19:16:46

poj1251 最小生成树的相关文章

poj1251最小生成树

#include <cstdio> #include <cstring> #include <algorithm> #include <climits> #include <string> #include <iostream> #include <map> #include <cstdlib> #include <list> #include <set> #include <qu

poj----(1251)Jungle Roads(最小生成树)

Jungle Roads Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 19265   Accepted: 8806 Description The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some

hdu1301&amp;poj1251 Jungle Roads(最小生成树之prim果题)

转载请注明出处:http://blog.csdn.net/u012860063 题目链接: HDU:http://acm.hdu.edu.cn/showproblem.php?pid=1301 POJ: http://poj.org/problem?id=1251 一道prim算法的果题! 题目很长,这里就不贴题目了. 题意: 给你每个村庄之间的维护道路的费用,求最小的费用. 代码如下: #include <cstdio> #include <cstring> #include &

POJ1251 Jungle Roads 【最小生成树Prim】

Jungle Roads Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 19536   Accepted: 8970 Description The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some

最小生成树练习1(克鲁斯卡尔算法Kruskal)

今天刷一下水题练手入门,明天继续. poj1861 Network(最小生成树)新手入门题. 题意:输出连接方案中最长的单根网线长度(必须使这个值是所有方案中最小的),然后输出方案. 题解:本题没有直接求生成树,但如果连接n个集线器的方案多于n-1条边,那么必存在回路,因此去掉某些边剩下的边和所有顶点构成一个生成树.对于一个图的最小生成树来说,它的最大边满足所有生成树的最大边里最小,正和题意. 吐槽:题目样例是错的... 1 #include<cstdio> 2 #include<cst

POJ-1251 Jungle Roads---MST裸题(需要编号)

题目链接: https://vjudge.net/problem/POJ-1251 题目大意: 首先给你一个图,需要你求出最小生成树,输入N个节点,用大写字母表示了节点,然后节点与节点之间有权值. 思路:这里需要编号,其他的就是模板 1 #include<iostream> 2 #include<cstdio> 3 #include<cstring> 4 #include<algorithm> 5 #include<cmath> 6 #inclu

「题解」kuangbin 最小生成树

POJ-1251 Jungle Roads (水题,%c) POJ-1287 Networking (水) POJ-2031 Building a Space Station (%f浮点数尴尬精度,两球间距离) POJ-2421 Constructing Roads (一些边已建好,简单处理一下) ZOJ-1586 QS Network (处理一下边权) HDU-1233 还是畅通工程 (水) HDU-1875 畅通工程再续 (浮点数,条件连边) HDU-1301 Jungle Roads (重

次最小生成树 模版

次小生成树(转) 转载(http://www.cnblogs.com/z360/p/6875488.html) 所谓次小生成树,顾名思义就是从生成树中取出的第二小的生成树. 我们在前面已经说过最小生成树的概念及代码实现了,所以接下来要说的次小生成树应该比较简单理解了. 求次小生成树的两种方法 1:首先求出最小生成树T,然后枚举最小生成树上的边,计算除了枚举的当前最小生成树的边以外的所有边形成的最小生成树Ti,然后求最小的Ti就是次小生成树.2:首先计算出最小生成树T,然后对最小生成树上任意不相邻

HDU1863 畅通工程---(最小生成树)

畅通工程 Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 27972    Accepted Submission(s): 12279 Problem Description 省政府"畅通工程"的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可).经过调查评估,得到的统计表中列出