poj1734 Sightseeing trip

Sightseeing trip

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6919   Accepted: 2646   Special Judge

Description

There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this attraction, the agency has accepted a shrewd decision: it is necessary to find the shortest route which begins and ends at the same place. Your task is to write a program which finds such a route.

In the town there are N crossing points numbered from 1 to N and M two-way roads numbered from 1 to M. Two crossing points can be connected by multiple roads, but no road connects a crossing point with itself. Each sightseeing route is a sequence of road numbers y_1, ..., y_k, k>2. The road y_i (1<=i<=k-1) connects crossing points x_i and x_{i+1}, the road y_k connects crossing points x_k and x_1. All the numbers x_1,...,x_k should be different.The length of the sightseeing route is the sum of the lengths of all roads on the sightseeing route, i.e. L(y_1)+L(y_2)+...+L(y_k) where L(y_i) is the length of the road y_i (1<=i<=k). Your program has to find such a sightseeing route, the length of which is minimal, or to specify that it is not possible,because there is no sightseeing route in the town.

Input

The first line of input contains two positive integers: the number of crossing points N<=100 and the number of roads M<=10000. Each of the next M lines describes one road. It contains 3 positive integers: the number of its first crossing point, the number of the second one, and the length of the road (a positive integer less than 500).

Output

There is only one line in output. It contains either a string ‘No solution.‘ in case there isn‘t any sightseeing route, or it contains the numbers of all crossing points on the shortest sightseeing route in the order how to pass them (i.e. the numbers x_1 to x_k from our definition of a sightseeing route), separated by single spaces. If there are multiple sightseeing routes of the minimal length, you can output any one of them.

Sample Input

5 7
1 4 1
1 3 300
3 1 10
1 2 16
2 3 100
2 5 15
5 3 20

Sample Output

1 3 5 2

Source

CEOI 1999

分析:经典的最小环问题,当然是用经典的算法:floyd解决啦!

一个最小环肯定是由两个点之间的最短路和次短路连接而成,如果我们求出了最短路再一条一条地删边求次短路,复杂度会很高,而且不止要求一对点,所以换个角度,我们考虑点k在不在最短路上。

假设k不在最短路上,那么处理出d[i][j],再求出经过k的路,a[i][k] + a[k][j],这3个数加起来就构成了一个环,这样就把删边操作改成了每次我们“添加”点时分不经过k的最短路和经过k的路考虑,这样一定会得到一条最短路和次短路的组合,至于如何控制到底经不经过k和怎么求最短路,当然是用到floyd算法。n <= 100,这就是很明显的提示,而且要求任意两点之间的最短路,还要控制到底经不经过k,这就是floyd算法的原理啊,每次我们先把没有更新k的结果算出来,然后再更新k.

至于怎么记录路径,类似于spfa的方法,每次记录到达当前点的前驱,不断向前更新就好了.

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<cmath>
#include<map>

using namespace std;

const int inf = 0x7ffffff;

int n, m, a[110][110], d[110][110],pre[110][110],ans = inf,tot,print[110];

void floyd()
{
    for (int k = 1; k <= n; k++)
    {
        for (int i = 1; i < k; i++)
            for (int j = i + 1; j < k; j++)
            {
            if (d[i][j] + a[i][k] + a[k][j] < ans)
            {
                ans = d[i][j] + a[i][k] + a[k][j];
                tot = 0;
                int t = j;
                while (t != i)
                {
                    print[++tot] = t;
                    t = pre[i][t];
                }
                print[++tot] = i;
                print[++tot] = k;
            }
            }
        for (int i = 1; i <= n; i++)
            for (int j = 1; j <= n; j++)
                if (d[i][j] > d[i][k] + d[k][j])
                {
            d[i][j] = d[i][k] + d[k][j];
            pre[i][j] = pre[k][j];
                }
    }
}

int main()
{
    scanf("%d%d", &n, &m);
    for (int i = 1; i <= n; i++)
        for (int j = 1; j <= n; j++)
        {
        a[i][j] = a[j][i] = d[i][j] = d[j][i] = inf;
        pre[i][j] = i;   //记录了i到j的最短路中j的前驱
        }
    for (int i = 1; i <= m; i++)
    {
        int u, v, w;
        scanf("%d%d%d", &u, &v, &w);
        a[u][v] = a[v][u] = d[u][v] = d[v][u] = min(w,a[u][v]);
    }
    floyd();
    if (ans == inf)
        printf("No solution.\n");
    else
    {
        printf("%d", print[1]);
        for (int i = 2; i <= tot; i++)
            printf(" %d", print[i]);
        printf("\n");
    }

    return 0;
}
时间: 2024-12-21 22:04:38

poj1734 Sightseeing trip的相关文章

POJ1734 Sightseeing trip 【Floyd】+【最小环】+【路径记录】

Sightseeing trip Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 4830   Accepted: 1857   Special Judge Description There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attra

POJ1734 Sightseeing trip【Floyd】【最小环】

Sightseeing trip Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 5038 Accepted: 1930 Special Judge Description There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions

POJ-1734 Sightseeing trip(floyd求最小环)

Sightseeing trip Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 6491   Accepted: 2486   Special Judge Description There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attra

1999 Central European Olympiad in Informatics - Sightseeing Trip

算法提示 最小环问题 题目大意 在一张带权无向图上,找出至少含 3 个点且权值和最小的环,并按环上的循序输出环上的点.存在重边,无自环. 做法分析 参考最小环问题,在更新 dist[i][j] 时,记录更新其的点 k,便于回溯路径. 参考代码 1 #include <cstdio> 2 #include <cstring> 3 #include <cmath> 4 #include <queue> 5 #include <algorithm> 6

POJ 1734:Sightseeing trip

Sightseeing trip Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 6831 Accepted: 2612 Special Judge Description There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions

URAL 1004 Sightseeing Trip(最小环)

Sightseeing Trip Time limit: 0.5 secondMemory limit: 64 MB There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this a

poj 1734 Sightseeing trip判断最短长度的环

Sightseeing trip Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 5590   Accepted: 2151   Special Judge Description There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attra

POJ 1734 Sightseeing trip (Floyd 最小环+记录路径)

Sightseeing trip Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 5040   Accepted: 1932   Special Judge Description There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attra

Sightseeing trip

Sightseeing trip Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Submit Status Practice POJ 1734 Description There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many o