Kattis - CD

CD

Jack and Jill have decided to sell some of their Compact Discs, while they still have some value. They have decided to sell one of each of the CD titles that they both own. How many CDs can Jack and Jill sell?

Neither Jack nor Jill owns more than one copy of each CD.

Input

The input consists of a sequence of test cases. The first line of each test case contains two non-negative integersNN and MM, each at most one million, specifying the number of CDs owned by Jack and by Jill, respectively. This line is followed by NN lines listing the catalog numbers of the CDs owned by Jack in increasing order, and MMmore lines listing the catalog numbers of the CDs owned by Jill in increasing order. Each catalog number is a positive integer no greater than one billion. The input is terminated by a line containing two zeros. This last line is not a test case and should not be processed.

Output

For each test case, output a line containing one integer, the number of CDs that Jack and Jill both own.

Sample Input 1 Sample Output 1
3 3
1
2
3
1
2
4
0 0
2

题意

计算两个人的CD的序号有多少个相同的

代码

#include<bits/stdc++.h>
using namespace std;
#define LL long long
const int maxn = 10010000;
LL n, m;
LL a[maxn];
int main() {
    while(cin >> n >> m) {
        if(n == m && n == 0)
            break;
        LL x, cnt = 0;
        memset(a, 0, sizeof(a));
        for(LL i = 0; i < n; i++) {
            cin >> x;
            a[x] = 1;
        }
        for(LL i = 0; i < m; i++) {
            cin >> x;
            if(a[x])
                cnt++;
        }
        cout << cnt << endl;
    }
}
时间: 2024-10-24 11:02:08

Kattis - CD的相关文章

Linux常用命令(echo、date、ls、cd、history、cat)

一.linux常用命令有很多今天我们来总结一下常用的入门命令: 1.linux下关机命令:poweroff.init 0.halt.shutdown -h now 2.linux下重启命令:reboot.init 6.shutdown -r now 3.shutdown命令: 格式:shutdown  options TIME 其中options有以下几个: -r:执行重启 -c:取消shutdown命令 -h:执行关机 其中TIME有以下几个: now:表示现在 +m:相对时间表示法,从命令提

每天一个linux命令-cd

cd命令在linux中,用于切换目录,是linux中最常用的命令之一. 命令功能 切换当前目录至指定目录 命令格式 cd [diretory] 常用范例 例一:进入到/目录 命令: cd / 输出: [[email protected] ~]# cd / [[email protected] /]# pwd / [[email protected] /]# 用pwd命令可以查看当前所在目录的绝对路径. 例二:返回当前目录的上一层目录,使用../..的用法可以返回上上层目录,../../..,以此

linux命令(29):cd命令

例1:进入系统根目录 cd  / cd ../.. // [直接退到当前根目录] 例2:使用 cd 命令进入当前用户主目录 cd 例3:跳转到指定目录 cd  /home/test 例4:返回进入此目录之前所在的目录 cd – 例5:把上个命令的参数作为cd参数使用 cd !$

Linux终端切换和ls、cd、date、shutdown相关命令

控制台终端:tty1-tty6 虚拟终端:pts 控制台切换快捷键:ctrl +(shift) +alt + F2-F6(有些笔记本需加Fn) 切换到其它终端:Alt + F1-F6 +(Fn) 可通过过滤命令查看打开的终端:ps aux | grep pts ps aux | grep tty 打开新的终端:Ctrl+shift+T 终端切换:Alt+数字键 关闭所有终端:Alt + F4 将终端字体放大:Ctrl+shift+(+号) 将终端字体缩小:Ctrl+(-号) ls命令 ls 目录

sql server 2005 32位+64位、企业版+标准版、CD+DVD 下载地址大全

企业版DVD SQL Server 2005 Enterprise Edition(支持超大型企业) 32 位DVD: ed2k://|file|cs_sql_2005_ent_x86_dvd.iso|972310528|4CEEF4B959894FD78C8F8416B4BA533E|/ 64 位DVD: ed2k://|file|cs_sql_2005_ent_x64_dvd.iso|1019222016|10FD11133A3E70DAD665BEDC1090AD28|/ 标准版CD SQ

linux初级运维 之目录管理命令(ls,cd,pwd,mkdir)

ls命令:-list directory contents     命令描述:列出目录内容 常用命令选项 -l:使用详细格式列表. -a:列出所有的文件和目录(用来显示以.开头的隐藏文件). -A:显示所有文件和目录但不包括.和..(.表示当前目录...表示上级目录). -h:做单位换算(把字节换算成易读的b-->kb) -d:显示目录自身属性 -i:显示文件的缩影节点号(普天之下莫非王土,所有的文件都挂载在以根为树节点的树上,每个文件都有一个缩影节点号) -r:逆序显示文件 -R:递归显示(显

笔记3 (目录结构、文件类型、环境变量、命令:ls、cd、mkdir、rmdir、rm、alias、cp、mv)

系统目录结构 ls /  查看根下面的目录 tree命令以树状图列出文件目录结构 tree -L 2 只查看两层 /usr/bin/  /usr/sbin/  /bin/  /sbin/  都是存平时用的命令 /sbin/  下面的命令一般都是root用户的 /bin/   下面的都是普通用户的 /boot/  是存系统启动相关的文件 /dev/   是linux系统里边特有的设备文件 /etc/   是系统一些配置文件所在的路径 /home/  用户的家目录 /lib/ /lib64/ 存系统

Java调用Linux命令(cd的处理)

一.Java调用Linux系统的命令非常简单 这是一个非常常用的调用方法示例: 1 public String executeLinuxCmd(String cmd) { 2 System.out.println("got cmd job : " + cmd); 3 Runtime run = Runtime.getRuntime(); 4 try { 5 Process process = run.exec(cmd); 6 InputStream in = process.getIn

冲突域和CSMA/CD

★冲突域 最早的以太网是将许多的计算机连接到一根总线上,因为当初认为这种方法既简单又可靠,因为在那个时代普遍认为"有源器件不可靠,而无源的电缆线才是最可靠的"(现在听起来是不是觉得前辈们也有不靠谱的时候?只不过或许我们现在的许多技术迟早也会在后人看来觉得很是不成熟吧).然后这个总线上只要有一台计算机发送数据,总线的传输资源就会被占用.这样的一个会产生冲突的区域就是冲突域. ★CSMA/CD Carrier Sense Multiple Access with Collision Det