POJ 3083 Children of the Candy Corn(搜索)

Children of the Candy Corn

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10975   Accepted: 4731

Description

The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find the exit.

One popular maze-walking strategy guarantees that the visitor will eventually find the exit. Simply choose either the right or left wall, and follow it. Of course, there‘s no guarantee which strategy (left or right) will be better, and the path taken is seldom
the most efficient. (It also doesn‘t work on mazes with exits that are not on the edge; those types of mazes are not represented in this problem.)

As the proprieter of a cornfield that is about to be converted into a maze, you‘d like to have a computer program that can determine the left and right-hand paths along with the shortest path so that you can figure out which layout has the best chance of confounding
visitors.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of mazes. Each maze will consist of one line with a width, w, and height, h (3 <= w, h <= 40), followed by h lines of w characters each that represent the maze
layout. Walls are represented by hash marks (‘#‘), empty space by periods (‘.‘), the start by an ‘S‘ and the exit by an ‘E‘.

Exactly one ‘S‘ and one ‘E‘ will be present in the maze, and they will always be located along one of the maze edges and never in a corner. The maze will be fully enclosed by walls (‘#‘), with the only openings being the ‘S‘ and ‘E‘. The ‘S‘ and ‘E‘ will also
be separated by at least one wall (‘#‘).

You may assume that the maze exit is always reachable from the start point.

Output

For each maze in the input, output on a single line the number of (not necessarily unique) squares that a person would visit (including the ‘S‘ and ‘E‘) for (in order) the left, right, and shortest paths, separated by a single space each. Movement from one
square to another is only allowed in the horizontal or vertical direction; movement along the diagonals is not allowed.

Sample Input

2
8 8
########
#......#
#.####.#
#.####.#
#.####.#
#.####.#
#...#..#
#S#E####
9 5
#########
#.#.#.#.#
S.......E
#.#.#.#.#
#########

Sample Output

37 5 5
17 17 9

Source

South Central USA 2006

题意:

给定一个迷宫,S是起点,E是终点,#是墙不可走,.可以走

先输出左转优先时,从S到E的步数

再输出右转优先时,从S到E的步数

最后输出S到E的最短步数

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<iostream>
#include<algorithm>

using namespace std;

char map[1001][1101];
int pxy[4][2]= {{0,-1},{1,0},{0,1},{-1,0}};
int qxy[4][2]= {{0,1},{1,0},{0,-1},{-1,0}};
int n,m;
int a,b,aa,bb;
int ans;
int anss;
struct node
{
    int x,y,z;

}q[5000010];
int v[1001][1001];
int jx[] = {0,1,0,-1};
int jy[] = {1,0,-1,0};

int DFS1(int x,int y,int count)
{
    if(x == aa && y == bb)
    {
        return count+1;
    }
    if(x<0 || x >=n || y<0 || y>=m || map[x][y] == '#')
    {
        return 0;
    }
    int temp = 0;
    anss = (anss + 3) % 4;
    while(1)
    {
        temp = DFS1(x+pxy[anss][0],y+pxy[anss][1],count+1);
        if(temp>0)
        {
            break;
        }
        anss = (anss + 1) % 4;
    }
    return temp;
}

int DFS2(int x,int y,int count)
{
    if(x == aa && y == bb)
    {
        return count+1;
    }
    if(x<0 || x>=n || y<0 || y>=m || map[x][y] == '#')
    {
        return 0;
    }
    int tempp = 0;
    ans = (ans + 3) % 4;
    while(1)
    {
        tempp = DFS2(x+qxy[ans][0],y+qxy[ans][1],count+1);
        if(tempp > 0)
        {
            break;
        }
        ans = (ans + 1) % 4;
    }
    return tempp;
}

int BFS(int x,int y)
{
    int s = 0,e = 0;
    struct node t,f;
    memset(q,0,sizeof(q));
    memset(v,0,sizeof(v));
    t.x = x;
    t.y = y;
    t.z = 0;
    q[e++] = t;
    v[t.x][t.y] = 1;
    while(s < e)
    {
        t = q[s++];
        if(t.x == aa && t.y == bb)
        {
            return t.z+1;
        }
        for(int i=0;i<4;i++)
        {
            f.x = t.x + jx[i];
            f.y = t.y + jy[i];
            if(f.x>=0 && f.x<n && f.y>=0 && f.y<m &&v[f.x][f.y] == 0 && map[f.x][f.y]!='#')
            {
                f.z = t.z + 1;
                q[e++] = f;
                v[f.x][f.y] = 1;
            }
        }
    }
    return 0;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&m,&n);
        for(int i=0;i<n;i++)
        {
            scanf("%s",map[i]);
            for(int j=0;j<m;j++)
            {
                if(map[i][j] == 'S')
                {
                    a = i;
                    b = j;
                }
                else if(map[i][j] == 'E')
                {
                    aa = i;
                    bb = j;
                }
            }
        }
        anss = 0;
        int nn = DFS1(a,b,0);
        ans = 0;
        int mm = DFS2(a,b,0);
        int pp = BFS(a,b);
        printf("%d %d %d\n",mm,nn,pp);
    }
    return 0;
}

版权声明:本文为博主原创文章,如有特殊需要请与博主联系 QQ : 793977586。

时间: 2024-10-26 16:27:20

POJ 3083 Children of the Candy Corn(搜索)的相关文章

POJ 3083 Children of the Candy Corn(顺时针DFS+逆时针DFS+BFS)

题目链接:POJ 3083 Children of the Candy Corn [题意]给出一个迷宫,不超过40*40,'#'代表墙,'.'代表能走,'S'是起点,'E'是终点.分别求出从起点一直沿左走,一直沿右走,走到终点所需要的步数.以及走出迷宫的最小步数. [思路]首先最小步数很简单,一个普通BFS搞定,这道题重点是一直向左走和一直向右走的DFS的方向问题,方向还和游客当时朝向有关.开始一直认为是每次都向左(右)转,直到可以走,然后就一直不对,在google了之后才知道向左走要遵循左上右

POJ 3083 -- Children of the Candy Corn(DFS+BFS)TLE

POJ 3083 -- Children of the Candy Corn(DFS+BFS) 题意: 给定一个迷宫,S是起点,E是终点,#是墙不可走,.可以走 1)先输出左转优先时,从S到E的步数 2)再输出右转优先时,从S到E的步数 3)最后输出S到E的最短步数 解题思路: 前两问DFS,转向只要控制一下旋转方向就可以 首先设置前进方向对应的数字 向上--N--0 向右--E--1 向下--S--2 向左--W--3 比如说右转优先,即为向右,向前,向左,向后,即逆时针方向for(int i

POJ 3083 Children of the Candy Corn

Children of the Candy Corn Time Limit: 1000ms Memory Limit: 65536KB This problem will be judged on PKU. Original ID: 308364-bit integer IO format: %lld      Java class name: Main The cornfield maze is a popular Halloween treat. Visitors are shown the

poj 3083 Children of the Candy Corn(bfs+dfs)

Children of the Candy Corn Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 10739   Accepted: 4626 Description The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombie

POJ 3083 Children of the Candy Corn (DFS + BFS + 模拟)

题目链接:http://poj.org/problem?id=3083 题意: 这里有一个w * h的迷宫,给你入口和出口,让你分别求以下三种情况时,到达出口的步数(总步数包括入口和出口): 第一种:当你需要选择下一个位置时,总是需要这么考虑:如果当前的左方能走,那么就走左方;否则考虑前方是否能走,如果能走,那么就选前方;否则考虑右方是否能走,如果可以,就走右方.如果不能就返回上一个位置,即当前位置的后方.总结下来选择道路的优先顺序为(以当前所处方位为准) 左 -> 上(前) -> 右 -&g

POJ 3083 Children of the Candy Corn (DFS+BFS)

题目链接:http://poj.org/problem?id=3083 题目大意:给你一个迷宫,S是起点,E是终点,#是墙,.是路,S.E在迷宫的边界,并且有唯一解:求优先左转S到E的步数,优先右转S到E的步数,以及S到E的最短步数. 题解: 1.本题的难点在于左转优先以及右转优先,下一步的方向取决于当前位置的方向,用DFS不断的按优先方向遍历一遍迷宫即可:我定义如图:   前(0)   左(1) 当前位置方向(dir) 右(3)   后(2)   以左转优先为例,便利迷宫的方向依次为:左.前.

POJ 3083:Children of the Candy Corn(DFS+BFS)

Children of the Candy Corn Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 9311 Accepted: 4039 Description The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, ch

【POJ 3083】Children of the Candy Corn

POJ[3083]Children of the Candy Corn Dfs+Bfs 分别求沿左墙到达E 沿右墙到达E 还有S到E的最短步数 前两个Dfs实现 最后一个Bfs 耐心写很容易A 主要注意方向问题 dir四个方向 上右下左 刚开始我分别用下标0 1 2 3代表 开dirx diry两个移动数组 假设前一状态朝向0(上) 沿左墙移动即为3 0 1 2(左上右下<顺时针>) 沿右墙即为1 0 3 2(右上左下<逆时针>) 同理其余方向很容易遍历 略自豪的是不断精简代码从6

K - Children of the Candy Corn

K - Children of the Candy Corn Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Submit Status Description The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze fa