解题报告 之 HDU5289 Assignment

解题报告 之 HDU5289 Assignment

Description

Tom owns a company and he is the boss. There are n staffs which are numbered from 1 to n in this company, and every staff has a ability. Now, Tom is going to assign a special task to some staffs who were in the same group. In a group,
the difference of the ability of any two staff is less than k, and their numbers are continuous. Tom want to know the number of groups like this.

Input

In the first line a number T indicates the number of test cases. Then for each case the first line contain 2 numbers n, k (1<=n<=100000, 0<k<=10^9),indicate the company has n persons, k means the maximum difference between abilities
of staff in a group is less than k. The second line contains n integers:a[1],a[2],…,a[n](0<=a[i]<=10^9),indicate the i-th staff’s ability.

Output

For each test,output the number of groups.

Sample Input

2
4 2
3 1 2 4
10 5
0 3 4 5 2 1 6 7 8 9 

Sample Output

5
28 

Hint

First Sample, the satisfied groups include:[1,1]、[2,2]、[3,3]、[4,4] 、[2,3]
         

题目大意:给你一个序列,1~n。问你有几个连续子序列满足其中最大值和最小值的差小于k。

分析:又是一道单调队列的题,我们设立两个指针i、j,从头开始往右移动,力求在O(n)的复杂度扫描一遍解决问题。单调队列的作用是什么呢,它是以很小的时间代价动态更新当前序列中的最大最小值。(此处如果有不懂请自行学习单调队列,此处只需要知道它动态更新最大最小值即可)。[j,i-1]表示当前关注的序列,我们将i指针一直向前,去更新最大最小值,直到[j,i]的最值之差>=k,说明此时的[j,i-1]是极限了。那么以
j 为起点的序列就只能从[j,i-1]选一个终点,有i-j种选法。然后j向前移动一位,重复以上过程,一直到 i 更新完整个序列。

上代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<deque>
using namespace std;

const int MAXN = 1e5 + 10;

int numbers[MAXN];

deque<int> high;
deque<int> low;

int main()
{
	int kase;
	cin >> kase;
	int n, k;
	while(kase--)
	{
		cin >> n >> k;
		for(int i = 1; i <= n; i++)
		{
			scanf( "%d", &numbers[i] );
		}
		high.clear();
		low.clear();

		int i, j; //i is pre pointer
		long long ans = 0;
		for(i = j = 1; i <= n; i++)
		{

			while(!high.empty() && high.back() < numbers[i]) high.pop_back();
			high.push_back( numbers[i] );

			while(!low.empty() && low.back() > numbers[i]) low.pop_back();
			low.push_back( numbers[i] );

			while(!high.empty() && !low.empty() && high.front() - low.front() >= k)
			{
				ans += i - j;
				if(high.front() == numbers[j]) high.pop_front();
				if(low.front() == numbers[j]) low.pop_front();
				//如果j已经前移出了最小值所在位置,则弹出
				j++;
			}
		}
		while(j <= n)
		//不要忘记
		{
			ans += i - j;
			j++;

		}

		cout << ans << endl;

	}
	return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-10-13 17:49:14

解题报告 之 HDU5289 Assignment的相关文章

解题报告 之 SOJ1942 Foto

解题报告 之 SOJ1942 Foto Description The election campaign just started, so PSOS decided to make some propagation. One of the representatives came with a great idea - he proposes to make an photography of their Parliament Club. Unfortunatelly, even after

解题报告 之 POJ3057 Evacuation

解题报告 之 POJ3057 Evacuation Description Fires can be disastrous, especially when a fire breaks out in a room that is completely filled with people. Rooms usually have a couple of exits and emergency exits, but with everyone rushing out at the same time

hdu 1541 Stars 解题报告

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1541 题目意思:有 N 颗星星,每颗星星都有各自的等级.给出每颗星星的坐标(x, y),它的等级由所有比它低层(或者同层)的或者在它左手边的星星数决定.计算出每个等级(0 ~ n-1)的星星各有多少颗. 我只能说,题目换了一下就不会变通了,泪~~~~ 星星的分布是不是很像树状数组呢~~~没错,就是树状数组题来滴! 按照题目输入,当前星星与后面的星星没有关系.所以只要把 x 之前的横坐标加起来就可以了

【百度之星2014~初赛(第二轮)解题报告】Chess

声明 笔者最近意外的发现 笔者的个人网站http://tiankonguse.com/ 的很多文章被其它网站转载,但是转载时未声明文章来源或参考自 http://tiankonguse.com/ 网站,因此,笔者添加此条声明. 郑重声明:这篇记录<[百度之星2014~初赛(第二轮)解题报告]Chess>转载自 http://tiankonguse.com/ 的这条记录:http://tiankonguse.com/record/record.php?id=667 前言 最近要毕业了,有半年没做

2016 第七届蓝桥杯 c/c++ B组省赛真题及解题报告

2016 第七届蓝桥杯 c/c++ B组省赛真题及解题报告 勘误1:第6题第4个 if最后一个条件粗心写错了,答案应为1580. 条件应为abs(a[3]-a[7])!=1,宝宝心理苦啊.!感谢zzh童鞋的提醒. 勘误2:第7题在推断连通的时候条件写错了,后两个if条件中是应该是<=12 落了一个等于号.正确答案应为116. 1.煤球数目 有一堆煤球.堆成三角棱锥形.详细: 第一层放1个, 第二层3个(排列成三角形), 第三层6个(排列成三角形), 第四层10个(排列成三角形). -. 假设一共

[noip2011]铺地毯(carpet)解题报告

最近在写noip2011的题,备战noip,先给自己加个油! 下面是noip2011的试题和自己的解题报告,希望对大家有帮助,题目1如下 1.铺地毯(carpet.cpp/c/pas) [问题描述]为了准备一个独特的颁奖典礼,组织者在会场的一片矩形区域(可看做是平面直角坐标系的第一象限)铺上一些矩形地毯.一共有n 张地毯,编号从1 到n.现在将这些地毯按照编号从小到大的顺序平行于坐标轴先后铺设,后铺的地毯覆盖在前面已经铺好的地毯之上.地毯铺设完成后,组织者想知道覆盖地面某个点的最上面的那张地毯的

ACdream 1203 - KIDx&#39;s Triangle(解题报告)

KIDx's Triangle Time Limit: 2000/1000MS (Java/Others) Memory Limit: 128000/64000KB (Java/Others) Submit Statistic Next Problem Problem Description One day, KIDx solved a math problem for middle students in seconds! And than he created this problem. N

解题报告 之 CodeForces 91B Queue

解题报告 之 CodeForces 91B Queue Description There are n walruses standing in a queue in an airport. They are numbered starting from the queue's tail: the 1-st walrus stands at the end of the queue and the n-th walrus stands at the beginning of the queue.

解题报告 之 POJ1226 Substrings

解题报告 之 POJ1226 Substrings Description You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings. Input The first li