HDU2607 Let the Balloon Rise II

Let the Balloon Rise II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 131    Accepted Submission(s): 37

Problem Description

Contest will be end at 17:00! How excited it is to see balloons floating around.

I knew you had solved the HDOJ 1004 Let the Balloon Rise already, so please settle the another version quickly. I have a lot of balloons and each has a color and I give each of them a number, same color has the same number. For example, red balloon is No.1,
pink is No.2, black is No.3 . etc. I also have many rooms to store all the balloons.

There are some rules :

1. Every room stores several balloons but no two have the same color.

2. Collect all the balloons, we can find each color has even number of times of balloons except one.

Your task is to find which is the odd color and calculate its number of times.

Input

Input file consists from multiple data sets separated by one or more empty lines.

Each data set represents a sequence of 32-bit (positive) integers (references) which are stored in compressed way.

Each line of input set consists from three single space separated 32-bit (positive) integers X Y Z and they represent following sequence of No.X, X+Z, X+2*Z, X+3*Z, …, X+K*Z, …(while (X+K*Z)<=Y). This line represents that in this room there exists (K+1) balloons
whose No. is No.X, No.X+Z, No.X+2*Z, No.X+3*Z, …, No.X+K*Z, …etc.

Output

For each input data set you should print to standard output new line of text with two integers separated by single space (first one is No. that occurs odd number of times and second one is count of that kind of balloon).

If all have even number of times output “None.”

Sample Input

1 10 1
1 10 1

1 5 1
6 10 1
1 10 1
4 4 1

1 5 1
2 5 1
2 5 1
2 5 1

Sample Output

None.
4 3
1 1

Author

WhereIsHeroFrom

Source

HDU 1st “Vegetable-Birds Cup” Programming Open Contest

#include <stdio.h>
#include <string.h>

#define maxn 100002

int X[maxn], Y[maxn], Z[maxn];
char buf[40];

int main() {
    // freopen("data.in", "r", stdin);
    int i, id = 0, cnt = 0, ret = 0; // id记录数据块中条数, ret记录最终结果
    while (gets(buf)) {
        if (*buf == NULL) {
            if (id)
                if (ret == 0) puts("None.");
                else {
                    while (id--) {
                        if (ret >= X[id] && ret <= Y[id] && (ret - X[id]) % Z[id] == 0)
                            ++cnt;
                    }
                    printf("%d %d\n", ret, cnt);
                }
            id = cnt = ret = 0;
            continue;
        }

        sscanf(buf, "%d%d%d", &X[id], &Y[id], &Z[id]);
        for (i = X[id]; i <= Y[id]; i += Z[id])
            ret ^= i;
        ++id;
    }
    if (id)
        if (ret == 0) puts("None.");
        else {
            while (id--) {
                if (ret >= X[id] && ret <= Y[id] && (ret - X[id]) % Z[id] == 0)
                    ++cnt;
            }
            printf("%d %d\n", ret, cnt);
        }
    return 0;
}
时间: 2024-11-02 23:34:53

HDU2607 Let the Balloon Rise II的相关文章

hdu 1004 Let the Balloon Rise

Let the Balloon Rise Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 80469    Accepted Submission(s): 30293 Problem Description Contest time again! How excited it is to see balloons floating aro

HDU 1004 Let the Balloon Rise【STL&lt;map&gt;】

Let the Balloon Rise Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 123800    Accepted Submission(s): 48826 Problem Description Contest time again! How excited it is to see balloons floating ar

杭电1004 Let the Balloon Rise

Let the Balloon Rise Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 120507    Accepted Submission(s): 47270 Problem Description Contest time again! How excited it is to see balloons floating ar

HDU 1004 Let the Balloon Rise map

Let the Balloon Rise Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 104108    Accepted Submission(s): 40046 Problem Description Contest time again! How excited it is to see balloons floating ar

Let the Balloon Rise(map)

Let the Balloon Rise Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 91684    Accepted Submission(s): 34910 Problem Description Contest time again! How excited it is to see balloons floating aro

Let the Balloon Rise HDU 1004

Let the Balloon Rise Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other) Total Submission(s) : 150   Accepted Submission(s) : 63 Problem Description Contest time again! How excited it is to see balloons floating around. B

HDUOJ Let the Balloon Rise 1004

 /* Let the Balloon Rise Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 89272    Accepted Submission(s): 33796 Problem Description Contest time again! How excited it is to see balloons float

HDU 1004 Let the Balloon Rise (map使用)

分析:题意简单,就用map的知识即可 #include <stdio.h> #include <iostream> #include <string.h> #include <map> using namespace std; int main() { int i,a,b,k; int N; char num[10]; while (~scanf("%d",&N)) { map<string,int> mp; whil

HDU-1004-Let the Balloon Rise(直接new一个字符串数组compareTo!)

Let the Balloon Rise Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 85666    Accepted Submission(s): 32330 Problem Description Contest time again! How excited it is to see balloons floating ar