HDU1757矩阵的简单运用

原题http://acm.hdu.edu.cn/showproblem.php?pid=1757

A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2526    Accepted Submission(s): 1469

Problem Description

Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.

If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);

And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.

Input

The problem contains mutiple test cases.Please process to the end of file.

In each case, there will be two lines.

In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )

In the second line , there are ten integers represent a0 ~ a9.

Output

For each case, output f(k) % m in one line.

Sample Input

10 9999
1 1 1 1 1 1 1 1 1 1
20 500
1 0 1 0 1 0 1 0 1 0

Sample Output

45
104
//本题只要把矩阵构造出来,接下来的就是套模板了
//构建的矩阵相乘的类型为AAAAAAB,B为已知的函数前几项
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <math.h>
#include <algorithm>
#include <iostream>
#include <stack>
#include <queue>
#include <deque>
#include <vector>
#include <map>
#include <set>
using namespace std;
#define max 15
int k,mod;

struct Matrix{
	int m[max][max];
};

Matrix unit,init;

void Init(){
	int i;
	memset(init.m,0,sizeof(init.m));
	for(i=1;i<10;i++){
		init.m[i][i-1] = 1;//自己构建的那个矩阵
	}
	memset(unit.m,0,sizeof(unit.m));
	for(i=0;i<10;i++){
		unit.m[i][i] = 1;
	}
}

Matrix Mul(Matrix a,Matrix b){
	Matrix c;
	int i,j,k;
	for(i=0;i<10;i++){
		for(j=0;j<10;j++){
			c.m[i][j] = 0;
			for(k=0;k<10;k++){
				c.m[i][j]+=(a.m[i][k]*b.m[k][j])%mod;
			}
			c.m[i][j]%=mod;
		}
	}

	return c;
}

Matrix Pow(Matrix a,Matrix b,int x){
	while(x){
		if(x&1){
			b = Mul(a,b);
		}
		a = Mul(a,a);
		x>>=1;
	}

	return b;
}

int main(){
	int i;

	while(~scanf("%d%d",&k,&mod)){
		Init();
		for(i=0;i<10;i++){
			scanf("%d",&init.m[0][i]);
		}
		if(k < 10){
			printf("%d\n",k%mod);
		}
		Matrix res = Pow(init,unit,k-9);
		int ans = 0;
		for(i=0;i<10;i++){
			ans+=(res.m[0][i]*(9-i))%mod;//因为这个函数的前10项为9,8,7,6,5,4,3,2,1,0
		}
		ans%=mod;
		printf("%d\n",ans);
	}

	return 0;
}

HDU1757矩阵的简单运用

时间: 2024-08-30 06:55:08

HDU1757矩阵的简单运用的相关文章

java学习-zxing生成二维码矩阵的简单例子

这个例子需要使用google的开源项目zxing的核心jar包 core-3.2.0.jar 可以百度搜索下载jar文件 也可使用maven添加依赖 <dependency> <groupId>com.google.zxing</groupId> <artifactId>core</artifactId> <version>3.2.0</version> </dependency> 最简单的生成二维码的方法,

矩阵乘法&lt;简单总结&gt;

原理:矩阵相乘最重要的方法是一般矩阵乘积.它只有在第一个矩阵的 行数 和第二个矩阵的 列数 相同时才可进行.若A为m×n矩阵,B为n×p矩阵,则他们的乘积AB会是一个m×p矩阵. 若A=    a    b    c        d    e    f        g    h    i    B=    A    D        B    E        C    F    A*B=CC=    aA+bB+cC    aD+bE+cF        dA+eB+fC    dD+eE

线性代数中矩阵的简单计算

#include"iostream" #include"time.h" using namespace std; class matrix{ private: double **a; int list; int line; public: matrix(int line,int list); void creatmatrix(double *a1); //通过一维数组创建矩阵 void cinmatrix(); //通过输入创建矩阵 void show(); //显

PAT 甲级 1105 Spiral Matrix (25分)(螺旋矩阵,简单模拟)

1105 Spiral Matrix (25分) This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The

kuangbin带你飞,矩阵(简单数学推导题)

A - Jzzhu and Sequences Time Limit:1000MS     Memory Limit:262144KB     64bit IO Format:%I64d & %I64u Submit Status Description Jzzhu has invented a kind of sequences, they meet the following property: You are given x and y, please calculate fn modul

matlab矩阵的表示和简单操作

原地址:http://www.cnblogs.com/Ran_Ran/archive/2010/12/11/1903070.html 一.矩阵的表示在MATLAB中创建矩阵有以下规则:a.矩阵元素必须在"[ ]"内:b.矩阵的同行元素之间用空格(或",")隔开:c.矩阵的行与行之间用";"(或回车符)隔开:d.矩阵的元素可以是数值.变量.表达式或函数:e.矩阵的尺寸不必预先定义. 二,矩阵的创建:1.直接输入法最简单的建立矩阵的方法是从键盘直接输

邻结矩阵的建立和 BFS,DFS;;

邻结矩阵比较简单,, 它的BFS,DFS, 两种遍历也比较简单,一个用队列, 一个用数组即可!!!但是邻接矩阵极其浪费空间,尤其是当它是一个稀疏矩阵的时候!!!---------------------------------------------------------------------------------------------------------------------------------------//邻接矩阵的建立和 其BFS, DFS, 遍历 #include <

Matlab矩阵基本操作(定义,运算)

转自:http://blog.csdn.net/perfumekristy/article/details/8119861 一.矩阵的表示在MATLAB中创建矩阵有以下规则: a.矩阵元素必须在”[ ]”内: b.矩阵的同行元素之间用空格(或”,”)隔开: c.矩阵的行与行之间用”;”(或回车符)隔开: d.矩阵的元素可以是数值.变量.表达式或函数: e.矩阵的尺寸不必预先定义. 二,矩阵的创建: 1.直接输入法 最简单的建立矩阵的方法是从键盘直接输入矩阵的元素,输入的方法按照上面的规则.建立向

C++ 开源矩阵 运算工具——Eigen

***************************************转载请注明出处:http://blog.csdn.net/lttree******************************************** 这几天,一直忙着帮学院一个老师做一个软件的功能模块, 模块要求是 矩阵的一系列运算, 本来是要自己写的,后来,发现有现成的工具,很多,我最后选择了Eigen, 因为它方便啊~  只需要把文件夹放到include文件夹下,就可以用了,打包什么也方便. 而且,跟别的