A - Alignment of Code(推荐)

You are working in a team that writes Incredibly Customizable Programming Codewriter (ICPC) which is basically a text editor with bells and whistles. You are working on a module that takes a piece of code containing some definitions or other tabular information and aligns each column on a fixed vertical position, while keeping the resulting code as short as possible, making sure that only whitespaces that are absolutely required stay in the code. So, that the first words on each line are printed at position p1 = 1; the second words on each line are printed at the minimal possible position p2, such that all first words end at or before position p2 - 2; the third words on each line are printed at the minimal possible position p3, such that all second words end at or before position p3 - 2, etc.

For the purpose of this problem, the code consists of multiple lines. Each line consists of one or more words separated by spaces. Each word can contain uppercase and lowercase Latin letters, all ASCII punctuation marks, separators, and other non-whitespace ASCII characters (ASCII codes 33 to 126 inclusive). Whitespace consists of space characters (ASCII code 32).

Input

The input file contains one or more lines of the code up to the end of file. All lines (including the last one) are terminated by a standard end-of-line sequence in the file. Each line contains at least one word, each word is 1 to 80 characters long (inclusive). Words are separated by one or more spaces. Lines of the code can have both leading and trailing spaces. Each line in the input file is at most 180 characters long. There are at most 1000 lines in the input file.

Output

Write to the output file the reformatted, aligned code that consists of the same number of lines, with the same words in the same order, without trailing and leading spaces, separated by one or more spaces such that i-th word on each line starts at the same position pi.

Note for the Sample:

The `‘ character in the example below denotes a space character in the actual files (ASCII code 32).

Sample Input

  start:  integer;    // begins here
stop: integer; //  ends here
 s:  string;
c:   char; // temp

Sample Output

start: integer; // begins here
stop:  integer; // ends   here
s:     string;
c:     char;    // temp
 
    #include <bits/stdc++.h>
    using namespace std;
    const int N = 1005, M = 200;
    string s[N][M], line;
    int cw[M], cn[N];

    int main()
    {
        int r = 0, c = 0;
        while(getline(cin, line))
        {
            stringstream ss(line);
            while(ss >> s[r][c])
            {
                if(s[r][c].length() > cw[c])
                    cw[c] = s[r][c].length();
                ++c;
            }
            cn[r++] = c;
            c = 0;
        }

        for(int i = 0; i < r; ++i)
        {
            for(int j = 0; j < cn[i] - 1; ++j)
                cout << left << setw(cw[j] + 1) << s[i][j];
            cout << s[i][cn[i] - 1] << endl;
        }
        return 0;
    }

  

时间: 2024-10-20 07:08:19

A - Alignment of Code(推荐)的相关文章

UVa 1593 Alignment of Code(字符串)

题意  按要求对齐代码 字符串流的应用 #include <bits/stdc++.h> using namespace std; const int N = 1005, M = 200; string s[N][M], line; int cw[M], cn[N]; int main() { int r = 0, c = 0; while(getline(cin, line)) { stringstream ss(line); while(ss >> s[r][c]) { if(

poj 3959 Alignment of Code

Description You are working in a team that writes Incredibly Customizable Programming Codewriter (ICPC) which is basically a text editor with bells and whistles. You are working on a module that takes a piece of code containing some definitions or ot

Alignment of Code 解题心得

原题: ou are working in a team that writes Incredibly Customizable Programming Codewriter (ICPC) which is basically a text editor with bells and whistles. You are working on a module that takes a piece of code containing some definitions or other tabul

UVa 1593 - Alignment of Code

题目描述 : 输入若干行代码,按照要求格式输出,.各列单词尽量靠左,单词之间至少要一个空格. 思路 : 利用字符串数组找规律.  只要控制好边界其他的都很简单.  连测试用例都没有用,因为UVa网页老刷不出来.直接交代码QuickSubmit,只是担心会超时,但结果令人意外,竟然是AC.再来两道吧.      对了 我又不好意思的用了正则表达式. 代码 : <p>import java.util.*; import java.util.regex.Matcher; import java.ut

UVA 1593: Alignment of Code(模拟 Grade D)

题意: 格式化代码.每个单词对齐,至少隔开一个空格. 思路: 模拟.求出每个单词最大长度,然后按行输出. 代码: #include <cstdio> #include <cstdlib> #include <cstring> char words[1200][190][90]; int maxLen[190]; char tmp[200]; typedef char * pchar; int readStr(pchar &str, char *out) { in

UVa 1593 (水题 STL) Alignment of Code

话说STL的I/O流用的还真不多,就着这道题熟练一下. 用了两个新函数: cout << std::setw(width[j]);    这个是设置输出宽度的,但是默认是在右侧补充空格 所以就要用cout.setf(ios::left);来设置一下左对齐. 1 #include <iostream> 2 #include <cstdio> 3 #include <sstream> 4 #include <vector> 5 #include &l

代码对齐 (Alignment of Code,ACM/ICPC NEERC 2010,UVa1593)

题目描述: 解题思路: 输入时提出单个字符串,并用一个数组记录每列最长长度,格式化输出 1 #include <iostream> 2 #include <algorithm> 3 #include <string> 4 #include <sstream> 5 #include <vector> 6 using namespace std; 7 8 vector<string> words[1005] ; 9 int lmax[25

YASM User Manual

This document is the user manual for the Yasm assembler. It is intended as both an introduction and a general-purpose reference for all Yasm users. 1.?Introduction Yasm is a BSD-licensed assembler that is designed from the ground up to allow for mult

学习js函数--自执行函数

我在写代码时候经常会在tpl的<script>里写类似的代码: $(function(){ alert("我好饿"); }); 刚开始的时候只知道写了它不需要调用,直接执行,就这样依葫芦画瓢,我写了很多代码.说道这,还要说说这货的加载顺序,如果把代码直接写到script标签里,当页面加载完这个script标签就会执行里边的代码了.如果在这代码里用到了未加载的dom或者调用了未加载的方法,是会报错的.言归正传,这个函数其实就是自执行函数,很多人会比较专业地称为"立即