1083 List Grades (25 分)排序

1083 List Grades (25 分)

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade‘s interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student‘s name and ID, separated by one space. If there is no student‘s grade in that interval, output NONE instead.

Sample Input 1:

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output 1:

Mike CS991301
Mary EE990830
Joe Math990112

Sample Input 2:

2
Jean AA980920 60
Ann CS01 80
90 95

Sample Output 2:

NONE思路:  排序包括区间端点
#include<iostream>
#include<vector>
#include<algorithm>
#include<queue>
#include<string>
#include<map>
#include<set>
using namespace std;
struct Node
{
    string name;
    string id;
    int grade;
};

bool cmp(Node&A,Node&B)
{
    return A.grade>B.grade;
}

int main()
{
    int n;
    cin>>n;
    Node node[n];
    for(int i=0;i<n;i++)
        cin>>node[i].name>>node[i].id>>node[i].grade;
    int grade1,grade2;
    cin>>grade1>>grade2;
    sort(node,node+n,cmp);
    bool flag=false;
    for(int i=0;i<n;i++)
    {
        if(node[i].grade>=grade1&&node[i].grade<=grade2)
        {
            cout<<node[i].name<<" "<<node[i].id<<endl;
            flag=true;
        }

    }
    if(flag)
        cout<<"NONE";
    return 0;
}
 

原文地址:https://www.cnblogs.com/zhanghaijie/p/10308233.html

时间: 2024-08-12 06:53:38

1083 List Grades (25 分)排序的相关文章

1083. List Grades (25)【水题】——PAT (Advanced Level) Practise

题目信息 1083. List Grades (25) 时间限制400 ms 内存限制65536 kB 代码长度限制16000 B Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of w

PAT 1083. List Grades (25)

1083. List Grades (25) Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval. In

1083. List Grades (25)

1083. List Grades (25) Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval. In

1083. List Grades (25)-简单的排序

给定区间[L,R],给出在这区间之内的学生,并且按照他们的成绩非升序的顺序输出. #include <iostream> #include <cstdio> #include <string.h> #include <algorithm> using namespace std; const int maxn=10005; struct Stu{ char name[15]; char id[15]; int grade; bool operator<

PAT (Advanced Level) 1083. List Grades (25)

简单排序. #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<map> #include<stack> #include<queue> #include<string> #include<iostream> #include<algorithm> using namespace std

PAT(A) 1083. List Grades (25)

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval. Input Specification: Each

A1083 List Grades (25 分)

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval. Input Specification: Each

PAT:1083. List Grades (25) AC

#include<stdio.h> #include<algorithm> using namespace std; struct Student { char name[15]; char ID[15]; int gread; }STU[66666]; bool cmp(Student a,Student b) { return a.gread>b.gread; } int main() { int n; scanf("%d",&n); for(

pat1083. List Grades (25)

1083. List Grades (25) 时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output t

1083. List Grades

1083. List Grades (25) 时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output t