自己想的比较好的一个算法,时间大大节省
时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CAO, Peng
Given a sequence of positive integers and another positive integer p. The sequence is said to be a "perfect sequence" if M <= m * p where M and m are the maximum and minimum numbers in the sequence, respectively.
Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.
Input Specification:
Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (<= 105) is the number of integers in the sequence, and p (<= 109) is the parameter. In the second line there are N positive integers, each is no greater than 109.
Output Specification:
For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.
Sample Input:
10 8 2 3 20 4 5 1 6 7 8 9
Sample Output:
8
来源: <http://www.patest.cn/contests/pat-a-practise/1085>
#include <iostream>
#include <stdio.h>
#include <vector>
#include <algorithm>
#pragma warning(disable:4996)
using namespace std;
vector<long long int> num;
int main(void) {
int n, p, temp;
cin >> n >> p;
while (n--)
{
scanf("%d", &temp);
num.push_back(temp);
}
sort(num.begin(), num.end());
int count = 0, max = 0;
n = num.size();
for (int i = 0; i < n; i++) {
count=0;
if (n - max <= i) {
break;
}
if (num[i + max] <= num[i] * p) {
for (int j = i; j < n; j++) {
if (num[j] <= num[i] * p) {
count++;
}
else
break;
}
}
if (count > max)
max = count;
}
cout << max;
return 0;
}