hdu 1016 dfs+素数表打表

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first
circle should always be 1.

Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row
represents a series of circle numbers in the ring beginning from 1 clockwisely
and anticlockwisely. The order of numbers must satisfy the above requirements.
Print solutions in lexicographical order.

You are to write a program that
completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

题意    环上任意相邻的两个数相加为素数

代码:

#include<iostream>
#include<string.h>
#include<cstring>
using namespace std;
int n;
#define maxn 10000
int ans[1005] = {0};
bool a[10005]={0};
int su[1500];
int tol = 0;
int vis[1005];
bool ppap(int a)
{
for (int i = 0; i < tol;i++)
if (a%su[i] == 0)return 0;
return 1;
}
void parm()
{
for (int i = 2; i < maxn;i++)
if (ppap(i))
{
su[tol++] = i; a[i] = 1;
}
}
void dfs(int k)
{
if (k == n&&a[ans[0]+ans[k-1]])
{
for (int i = 0; i < n-1; i++)
cout << ans[i] <<" ";
cout <<ans[n-1]<< endl;
return;
}
for (int i = 2; i <=n; i++)
{
if (!vis[i] && a[i + ans[k-1]])
{
ans[k] = i;
vis[i] = 1;
dfs(k + 1);
vis[i] = 0;
}
}
}
int main()
{
int i=1;
while (cin >> n)
{

memset(vis, 0, sizeof(vis));
parm();
ans[0] = 1;
cout<<"Case "<<i<<":"<<endl;
dfs(1);
i++;
}
return 0;

}

时间: 2024-10-14 03:23:09

hdu 1016 dfs+素数表打表的相关文章

HDU 1016 DFS

很简单的深搜 只要看出来是深搜... 注意判断最后一点是否与加一为质数 #include<stdio.h> #include<string.h> #include<algorithm> #include<map> #include<math.h> using namespace std; int n; int ans[30]; bool vis[30]; bool ok[105]; void init()///素数打表 { memset(ok,t

hdu 1016 dfs素数环

背景:周赛e题,当时很快就有人出,我能看出来是dfs但是却不能实现,哎以为自己能力不可写出,结果低估自己了. 学习:1.打了一个素数表,比较快捷,还有素数判别方法的函数,只需要枚举到该数的平方根即可,因为大于它的平方·根之后商都小于1,不可能再整除了. int isPrime(int x) { int i; for (i = 2; i <= sqrt(x*1.0); i++)//sqrt函数操作的是double. { if (x % i == 0) return 0; } return 1; }

[HDU]1016 DFS入门题

题目的意思就是在1到n的所有序列之间,找出所有相邻的数相加是素数的序列.Ps:题目是环,所以头和尾也要算哦~ 典型的dfs,然后剪枝. 这题目有意思的就是用java跑回在tle的边缘,第一次提交就tle了(服务器负载的问题吧),一模一样的第二次提交就ac了,侧面也反应了递归对stack的开销影响效率也是严重的.好了,上代码!! 题目传送门: HDU_1016 import java.util.Scanner; public class Main { public static final int

HDU 1016 Prime Ring Problem (素数筛+DFS)

题目链接 题意 : 就是把n个数安排在环上,要求每两个相邻的数之和一定是素数,第一个数一定是1.输出所有可能的排列. 思路 : 先打个素数表.然后循环去搜..... 1 //1016 2 #include <cstdio> 3 #include <cstring> 4 #include <iostream> 5 6 using namespace std ; 7 8 bool vis[21]; 9 int prime[42] ,cs[21]; 10 int n ; 11

HDU 1016 Prime Ring Problem --- 经典DFS

思路:第一个数填1,以后每个数判断该数和前一个数想加是否为素数,是则填,然后标记,近一步递归求解. 然后记得回溯,继续判断下一个和前一个数之和为素数的数. /* HDU 1016 Prime Ring Problem --- 经典DFS */ #include <cstdio> #include <cstring> int n; bool primer[45], visit[25]; //primer打素数表,visit标记是否访问 int a[25]; //数组a存储放置的数 /

【dfs】hdu 1016 Prime Ring Problem

[dfs]hdu 1016 Prime Ring Problem 题目链接 刚开始接触搜索,先来一道基本题目练练手. 注意对树的深度进行dfs dfs过程中注意回退!!! 素数提前打表判断快一些 参考代码 /*Author:Hacker_vision*/ #include<bits/stdc++.h> #define clr(k,v) memset(k,v,sizeof(k)) using namespace std; const int _max=1e3+10;//素数打表 int n,pr

hdu 1016 Prime Ring Problem (简单DFS)

Prime Ring Problem Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 25700    Accepted Submission(s): 11453 Problem Description A ring is compose of n circles as shown in diagram. Put natural numb

hdu 1016 Prime Ring Problem (dfs)

一切见注释. #include <cstdio> #include <iostream> #include <cstring> #include <algorithm> using namespace std; bool vis[22]; int n; int ans[22]; int top; bool isprime(int x)//判断素数 { for(int i=2;i<x;i++) if(x%i==0)return false; return

HDU 1016 素数环(深搜)

Prime Ring Problem Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 25134 Accepted Submission(s): 11222 Problem Description A ring is compose of n circles as shown in diagram. Put natural number 1,