Saving James Bond - Easy Version (MOOC)

06-图2 Saving James Bond - Easy Version (25 分)

This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world‘s most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape -- he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head... Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:

For each test case, print in a line "Yes" if James can escape, or "No" if not.

Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12

Sample Output 1:

Yes

Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12

Sample Output 2:

No

程序总体框架:

DFS算法

int DFS ( Vertex V )
{ visited[V] = true;
if ( IsSafe(V) ) answer = YES;
else {
for ( V 的每个邻接点 W )
if ( !visited[W] ) {
answer = DFS(W);
if (answer==YES) break;
}
}
return answer;

代码:

#include<cstdio>
#include<cmath>
using namespace std;
struct node{
    int x,y;
}G[110];
int n,d;
int vis[110];
int ans=0;
bool firstJump(int i){
    int p1=pow(G[i].x,2);
    int p2=pow(G[i].y,2);
    int r=(d+7.5)*(d+7.5);
    if(p1+p2<=r)return true;
    return false;
}
bool jump(int v,int i){
    int p1=pow(G[v].x-G[i].x,2);
    int p2=pow(G[v].y-G[i].y,2);
    if(p1+p2<=d*d)return true;
    else return false;
}
bool isSave(int v){
    if(G[v].x+50<=d||50-G[v].x<=d||50+G[v].y<=d||50-G[v].y<=d)return true;
    return false;
}
//dfs 1.遍历所有结点,找到能够跳转的结点进行dfs  2.如果结点可以跳上岸,返回结果1.
int dfs(int v){
    vis[v]=1;
    if(isSave(v))return 1;
    for(int i=0;i<n;i++){
        if(!vis[i]&&jump(v,i)){
            ans=dfs(i);
        if(ans) break;//如果换成了if(!ans)return ans; sample 2出现错误。因为循环并没有结束,不能用return
        }
    }
    return ans;
}

int main(){
    scanf("%d %d",&n,&d);
    getchar();
    for(int i=0;i<n;i++){
        scanf("%d %d",&G[i].x,&G[i].y);  //struct结构存储x,y坐标
        getchar();
    }
    for(int i=0;i<n;i++){
            if(firstJump(i)&&!vis[i]){    //首先判断第一步能否跳出,同时没有遍历过该结点
                ans=dfs(i);
                if(ans)break;
            }
    }
    if(ans)printf("Yes");
    else printf("No");

    return 0;
}

原文地址:https://www.cnblogs.com/patatoforsyj/p/9887235.html

时间: 2024-08-27 21:07:35

Saving James Bond - Easy Version (MOOC)的相关文章

Saving James Bond - Hard Version(PAT)

Saving James Bond - Hard Version(30 分) This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the

06-图2 Saving James Bond - Easy Version(25 分)

This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodile

05-图2. Saving James Bond - Easy Version (25)

05-图2. Saving James Bond - Easy Version (25) 时间限制 200 ms 内存限制 65536 kB 代码长度限制 8000 B 判题程序 Standard 作者 CHEN, Yue This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was capture

05-2. Saving James Bond - Easy Version (25)

05-2. Saving James Bond - Easy Version (25) 时间限制 200 ms 内存限制 65536 kB 代码长度限制 8000 B 判题程序 Standard 作者 CHEN, Yue This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured

pat05-图2. Saving James Bond - Easy Version (25)

05-图2. Saving James Bond - Easy Version (25) 时间限制 200 ms 内存限制 65536 kB 代码长度限制 8000 B 判题程序 Standard 作者 CHEN, Yue This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was capture

PAT Saving James Bond - Easy Version

Saving James Bond - Easy Version Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of

05-2. Saving James Bond - Easy Version (PAT) - 图的遍历问题

This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodile

Saving James Bond - Easy Version

本博客的代码的思想和图片参考:好大学慕课浙江大学陈越老师.何钦铭老师的<数据结构> Question: This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured by a group of drug dealers. He was sent to a small p

PTA 06-图2 Saving James Bond - Easy Version (25分)

This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodile