PAT-1022 Digital Library (30 分) 字符串处理

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID‘s.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤104) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user‘s search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID‘s in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

题目分析 给出几本书和关键字,然后根据关键字查询书

思路分析 把所有关键字存成一个字符串即可,然后在这个字符串查找,需要注意两点

  • ZUCS Print2 如果查询"ZUCS Print"不算,所以所查找的字符串找到后还必须判断前后是不是空格,都是空格才符合要求
  • key字符串的前面必须是一个空格,最后面也得加一个空格,防止合法的查成不合法
  • 每行之间用两个空格间隔,防止出现以下错误
    比如一本书3
    1111111
    The Testing Book
    Yue Chen
    test code debug sort keywords
    ZUCS Print
    2011
    如果查询"Book Yue"可能会查到,所以应该用两个空格来间隔

AC代码

#include <iostream>
#include<bits/stdc++.h>
#define each(a,b,c) for(int a=b;a<=c;a++)
#define de(x) cout<<#x<<" "<<(x)<<endl
using namespace std;

const int maxn=1e4+5;
map<string,string>M;

/*
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla
*/
string ID[maxn];
string key[maxn];
string ans[maxn];
int cur;
int main()
{
    int n;
    cin>>n;
    getchar();
    string temp;
    string buf=" ";
    each(i,1,n)
    {
        buf=" ";///忘记清空了
        cin>>ID[i];
        getchar();///注意吃掉回车
        getline(cin,temp);
        //重复5次
        buf+=temp;
        buf+="  ";///加两个空格以免连起来
        getline(cin,temp);
        buf+=temp;
        buf+="  ";
        getline(cin,temp);
        buf+=temp;
        buf+="  ";
        getline(cin,temp);
        buf+=temp;
        buf+="  ";
        getline(cin,temp);
        buf+=temp;
        buf+="  ";
        //de(buf);
        key[i]=buf+" ";///首尾各有一个空格
    }
    int m;
    cin>>m;
    getchar();
    string order;

    while(m--)
    {
        cur=0;
        getline(cin,order);
        cout<<order<<endl;
        order=order.substr(3);
        //de(order);
        each(i,1,n)
        {
            string s;
            //de(i);
            //de(key[i]);
            int p=key[i].find(order.c_str());
            //de(p);
            if(p!=string::npos)
            {
                if(key[i][p-1]==' '&&key[i][p+(int)order.length()]==' ')
                {
                    ans[cur++]=ID[i];
                }
            }
        }
        //输出
        if(cur==0)
            puts("Not Found");
        else
        {
            sort(ans,ans+cur);
            each(i,0,cur-1)
            {
                cout<<ans[i]<<endl;
            }
        }

    }

}
/*
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
*/

原文地址:https://www.cnblogs.com/Tony100K/p/11758031.html

时间: 2024-07-30 01:11:53

PAT-1022 Digital Library (30 分) 字符串处理的相关文章

PAT Advanced 1022 Digital Library (30分)

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are s

1022. Digital Library (30) -map -字符串处理

题目如下: A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you

1022. Digital Library (30)

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are s

1022 Digital Library (30)(30 point(s))

problem A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, y

PAT A 1022. Digital Library (30)【结构体排序检索】

https://www.patest.cn/contests/pat-a-practise/1022 直接模拟, 输入,按id排序,检索 #include <iostream> #include <string> #include <algorithm> using namespace std; struct book //图书结构 { string id; string title; string author; int k; //关键词数量 string key[5

PAT:1022. Digital Library (30) (部分正确,错最后两个)

1 #include<stdio.h> 2 #include<string.h> 3 #include<map> 4 #include<string> 5 #include<set> 6 #include<iostream> 7 using namespace std; 8 int n; //n本书 9 //标题.作者.关键字.出版社.出版年份与ID的映射 10 map<string,set<int>> mpT

PAT甲题题解-1022. Digital Library (30)-map映射+vector

博主欢迎转载,但请给出本文链接,我尊重你,你尊重我,谢谢~http://www.cnblogs.com/chenxiwenruo/p/6789235.html特别不喜欢那些随便转载别人的原创文章又不给出链接的所以不准偷偷复制博主的博客噢~~ 题意:给出n本书的id.名称.作者.多个关键词.出版社.出版年然后给出m个查询,每个查询包含查询的种类.对应的内容针对每个查询,让你输出所有符合的书的id,从小到大排序,没有的话则输出No Found 首先把每个book的信息都读取处理好,然后按照id排个序

PAT (Advanced Level) 1022. Digital Library (30)

简单模拟题. 写的时候注意一些小优化,小心TLE. #include<iostream> #include<cstring> #include<cmath> #include<algorithm> #include<cstdio> #include<map> #include<queue> #include<vector> using namespace std; struct X { string id; c

STL_A1022 Digital Library (30 分)

https://pintia.cn/problem-sets/994805342720868352/problems/994805480801550336 /* *string,map,set的使用 *map<string,set<int> > *把字符串string映射到元素均为int且有序的集合set */ #include<iostream> using namespace std; #include<cstdio> #include<strin