PAT Advanced 1019 General Palindromic Number (20分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a?i?? as (. Here, as usual, 0 for all i and a?k?? is non-zero. Then N is palindromic if and only if a?i??=a?k−i?? for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0 is the decimal number and 2 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a?k?? a?k−1?? ... a?0??". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

鸣谢网友“CCPC拿不到牌不改名”修正数据!

题意:判断一个树在n进制下,是否是回文数。

我们使用两个双端队列进行存储回文。

一个从队头插入,一个从队尾插入,然后遍历一遍,比较一下两个队列的数据是否一样。

如果一样输出Yes,否则输出No。最后输出一下这个数。

#include <iostream>
#include <deque>
using namespace std;
int main(){
    int N, R;
    cin >> N >> R;
    deque<int> d, dr;
    while(N != 0){
        d.push_back(N % R);
        dr.push_front(N % R);
        N /= R;
    }
    bool right = true;
    for(int i = 0; i < d.size(); i++)
        if(d[i] != dr[i]) right = false;
    cout << (right ? "Yes" : "No") << endl;
    for(int i = 0; i < dr.size(); i++)
        if(i != 0) cout << " " << dr[i];
        else cout << dr[i];
    return 0;
}

原文地址:https://www.cnblogs.com/littlepage/p/12235726.html

时间: 2024-10-07 00:20:48

PAT Advanced 1019 General Palindromic Number (20分)的相关文章

PAT:1019. General Palindromic Number (20) AC

#include<stdio.h> #include<stdlib.h> int main() { int n,jin; scanf("%d%d",&n,&jin); if(0==n) //特判0的时候,就是回文数 { printf("Yes\n0"); return 0; } int arr[50],i=0; while(n!=0) { arr[i++]=n%jin; n/=jin; } int tag=0; for(int

PAT 甲级 1019 General Palindromic Number (进制转换,vector运用,一开始2个测试点没过)

1019 General Palindromic Number (20 分)   A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Althoug

PAT 甲级 1019 General Palindromic Number

https://pintia.cn/problem-sets/994805342720868352/problems/994805487143337984 A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit num

1019. General Palindromic Number (20)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Although palindromic numbers are most often cons

1019 General Palindromic Number (20)(20 point(s))

problem A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Although palindromic numbers are most of

PAT (Advanced Level) 1019. General Palindromic Number (20)

简单题. #include<iostream> #include<cstring> #include<cmath> #include<algorithm> #include<cstdio> #include<queue> #include<vector> using namespace std; int s[10000],tot; int n,b; bool check() { for(int i=0; i<=tot

PAT甲题题解-1019. General Palindromic Number (20)-又是水题一枚

n转化为b进制的格式,问你该格式是否为回文数字(即正着写和倒着写一样)输出Yes或者No并且输出该格式又是水题... #include <iostream> #include <cstdio> #include <algorithm> #include <cstring> using namespace std; const int maxn=30; int a[maxn]; int n,b; int main() { scanf("%d %d&q

PAT-进制转换-A1019 General Palindromic Number (20分)

题目描述: 给出两个整数n.b,问十进制整数n在b进制下是否是回文数,若是,则输出Yes:否则,输出No.在此之后输出n在b进制下的表示. 单词:Palindromic Number--回文数:decimal--十进制的. 输入格式: 输入用空格分隔的两个数,第一个数是十进制数n(0<N≤10?9),第二个数是十进制数b( 2≤b≤10?9). 输出格式: 第一行输出Yes或No,第二行输出十进制数n在b进制下的表示,用空格把每个数隔开,末尾不能有多余空格. 样例: 样例一: 输入:27 2 输

PAT Advanced 1144 The Missing Number (20分)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list. Input Specification: Each input file contains one test case. For each case, the first line gives a positive integer N (≤). Then N integers are giv