POJ 开关问题 1830【高斯消元求矩阵的秩】


Language:
Default

开关问题

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 6656   Accepted: 2541

Description

有N个相同的开关,每个开关都与某些开关有着联系,每当你打开或者关闭某个开关的时候,其他的与此开关相关联的开关也会相应地发生变化,即这些相联系的开关的状态如果原来为开就变为关,如果为关就变为开。你的目标是经过若干次开关操作后使得最后N个开关达到一个特定的状态。对于任意一个开关,最多只能进行一次开关操作。你的任务是,计算有多少种可以达到指定状态的方法。(不计开关操作的顺序)

Input

输入第一行有一个数K,表示以下有K组测试数据。

每组测试数据的格式如下:

第一行 一个数N(0 < N < 29)

第二行 N个0或者1的数,表示开始时N个开关状态。

第三行 N个0或者1的数,表示操作结束后N个开关的状态。

接下来 每行两个数I J,表示如果操作第 I 个开关,第J个开关的状态也会变化。每组数据以 0 0 结束。

Output

如果有可行方法,输出总数,否则输出“Oh,it‘s impossible~!!” 不包括引号

Sample Input

2
3
0 0 0
1 1 1
1 2
1 3
2 1
2 3
3 1
3 2
0 0
3
0 0 0
1 0 1
1 2
2 1
0 0

Sample Output

4
Oh,it‘s impossible~!!

Hint

第一组数据的说明:

一共以下四种方法:

操作开关1

操作开关2

操作开关3

操作开关1、2、3 (不记顺序)

Source

[email protected]

中文题~不翻译。。

解题思路:主要是始末矩阵的处理方法。可以让A+X=B 两边同时异或A就可以了。这样就能简单得到增广矩阵。

a[i][j]是j灯控制i灯。记得把a[i][i]的情况加上,差点忽略这点,自己当然可以控制自己啊。

AC代码:

#include <stdio.h>
#include <math.h>
#include <vector>
#include <queue>
#include <string>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define MAXN 31

using namespace std;

int equ,var;
int a[MAXN][MAXN];

int Gauss()
{
    int col=0;
    int k,max_r;
    for(k=0;col<var&&k<equ;k++,col++){
        max_r=k;
        for(int i=k+1;i<equ;i++)
            if(abs(a[i][col])>abs(a[max_r][col])) max_r=i;
        if(max_r!=k){
            for(int i=col;i<=var;i++)
                swap(a[k][i],a[max_r][i]);
        }
        if(!a[k][col]){
            k--;
            continue;
        }
        for(int i=k+1;i<equ;i++)
            if(a[i][col])
            for(int j=col;j<=var;j++)
            a[i][j]^=a[k][j];
    }
    for(int i=k;i<equ;i++)
        if(a[i][col]) return -1;
    return var-k;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        memset(a,0,sizeof(a));
        scanf("%d",&equ);
        var=equ;
        int b;
        for(int i=0;i<equ;i++){
            //a[i][i]=1;
            scanf("%d",&b);
            a[i][var]=b;
        }
        for(int i=0;i<equ;i++){
            scanf("%d",&b);
            a[i][var]^=b;
        }
        int I,J;
        while(scanf("%d%d",&I,&J),I!=0||J!=0){
            a[J-1][I-1]=1;
        }
        for(int i=0;i<equ;i++) a[i][i]=1;
        int res=Gauss();
        if(res<0)printf("Oh,it's impossible~!!\n");
        else printf("%d\n",1<<res);
    }
    return 0;
}

版权声明:本文为博主原创文章,转载请注明出处。

时间: 2025-01-05 12:33:14

POJ 开关问题 1830【高斯消元求矩阵的秩】的相关文章

Light OJ 1288 Subsets Forming Perfect Squares 高斯消元求矩阵的秩

题目来源:Light OJ 1288 Subsets Forming Perfect Squares 题意:给你n个数 选出一些数 他们的乘积是完全平方数 求有多少种方案 思路:每个数分解因子 每隔数可以选也可以不选 0 1表示 然后设有m种素数因子 选出的数组成的各个因子的数量必须是偶数 组成一个m行和n列的矩阵 每一行代表每一种因子的系数 解出自由元的数量 #include <cstdio> #include <cstring> #include <algorithm&g

【POJ】1830 开关问题(高斯消元)

http://poj.org/problem?id=1830 高斯消元无解的条件:当存在非法的左式=0而右式不等于0的情况,即为非法.这个可以在消元后,对没有使用过的方程验证是否右式不等于0(此时因为前边消元一定会使得后边的方程左式为0) 高斯消元自由变元:自由变元就是当这些未知量一旦确定,整个方程就确定了.但是这些量是未知的.(例如x+y=5,自由变元就是1,因为无论是x还是y确定,另一个就能唯一确定),而答案要求的是方案,那么显然因为自由变元是可以随便赋值的,而这些值只有2个,开和不开,那么

[ACM] POJ 2947 Widget Factory (高斯消元)

Widget Factory Time Limit: 7000MS   Memory Limit: 65536K Total Submissions: 4436   Accepted: 1502 Description The widget factory produces several different kinds of widgets. Each widget is carefully built by a skilled widgeteer. The time required to

POJ 1166 The Clocks 高斯消元 + exgcd(纯属瞎搞)

根据题意可构造出方程组,方程组的每个方程格式均为:C1*x1 + C2*x2 + ...... + C9*x9 = sum + 4*ki; 高斯消元构造上三角矩阵,以最后一个一行为例: C*x9 = sum + 4*k,exgcd求出符合范围的x9,其他方程在代入已知的变量后格式亦如此. 第一发Gauss,蛮激动的. #include <algorithm> #include <iostream> #include <cstring> #include <cstd

hdu 2262 高斯消元求期望

Where is the canteen Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 1070    Accepted Submission(s): 298 Problem Description After a long drastic struggle with himself, LL decide to go for some

高斯消元 求整数解模版

#include <iostream> #include <string.h> #include <cmath> using namespace std; const int maxn = 105; int equ, var; // 有equ个方程,var个变元.增广阵行数为equ, 分别为0到equ - 1,列数为var + 1,分别为0到var. int a[maxn][maxn]; int x[maxn]; // 解集. bool free_x[maxn]; //

hdu 3992 AC自动机上的高斯消元求期望

Crazy Typewriter Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 391    Accepted Submission(s): 109 Problem Description There was a crazy typewriter before. When the writer is not very sober, it

hdu 4418 高斯消元求期望

Time travel Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1480    Accepted Submission(s): 327 Problem Description Agent K is one of the greatest agents in a secret organization called Men in B

uva 10828 高斯消元求数学期望

Back to Kernighan-RitchieInput: Standard Input Output: Standard Output You must have heard the name of Kernighan and Ritchie, the authors of The C Programming Language. While coding in C, we use different control statements and loops, such as, if-the