HDU1198水管并查集Farm Irrigation

Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.

Farm Irrigation

Figure 1

Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map

ADC
FJK
IHE

then the water pipes are distributed like


Figure 2

Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

Input

There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of ‘A‘ to ‘K‘, denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

Output

For each test case, output in one line the least number of wellsprings needed.

Sample Input

2 2 DK HF 3 3 ADC FJK IHE -1 -1

Sample Output

2 3

Author

ZHENG, Lu

Source

Zhejiang University Local Contest 2005

Recommend

Ignatius.L

解题思路

并查集分类问题,将其分堆,等于本身的便是总共的个数

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
char a[55][55];
int pd[2505];
struct node
{
    int l;
    int r;
    int u;
    int d;
    int num;
}que[55][55];
int get(int x)
{
    if(pd[x]!=x)
        pd[x]=get(pd[x]);
    return pd[x];
}
void find(int x,int y)
{
    pd[get(y)]=get(x);
}
int main()
{
    int m,n;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
         if(m==-1&&n==-1)
            break;
            if(m==1&&n==1)
            {
                printf("1\n");
                continue;
            }
        memset(pd,0,sizeof(pd));
        memset(a,0,sizeof(a));
        int N=n*m;
        for(int i1=1;i1<=N;i1++)
            pd[i1]=i1;
        getchar();
        for(int i2=0;i2<m;i2++)
        {
            for(int j2=0;j2<n;j2++)
                scanf("%c",&a[i2][j2]);
                getchar();
        }
        int h=1;
        for(int i=0;i<m;i++)
        for(int j=0;j<n;j++)
        {
            if(a[i][j]==‘A‘) {que[i][j].l=1;que[i][j].r=0;que[i][j].u=1;que[i][j].d=0;}
            else if(a[i][j]==‘B‘) {que[i][j].l=0;que[i][j].r=1;que[i][j].u=1;que[i][j].d=0;}
            else if(a[i][j]==‘C‘) {que[i][j].l=1;que[i][j].r=0;que[i][j].u=0;que[i][j].d=1;}
            else if(a[i][j]==‘D‘) {que[i][j].l=0;que[i][j].r=1;que[i][j].u=0;que[i][j].d=1;}
            else if(a[i][j]==‘E‘) {que[i][j].l=0;que[i][j].r=0;que[i][j].u=1;que[i][j].d=1;}
            else if(a[i][j]==‘F‘) {que[i][j].l=1;que[i][j].r=1;que[i][j].u=0;que[i][j].d=0;}
           else if(a[i][j]==‘G‘) {que[i][j].l=1;que[i][j].r=1;que[i][j].u=1;que[i][j].d=0;}
           else if(a[i][j]==‘H‘) {que[i][j].l=1;que[i][j].r=0;que[i][j].u=1;que[i][j].d=1;}
           else if(a[i][j]==‘I‘) {que[i][j].l=1;que[i][j].r=1;que[i][j].u=0;que[i][j].d=1;}
           else if(a[i][j]==‘J‘) {que[i][j].l=0;que[i][j].r=1;que[i][j].u=1;que[i][j].d=1;}
            else {que[i][j].l=1;que[i][j].r=1;que[i][j].u=1;que[i][j].d=1;}
            que[i][j].num=h;
            h++;
        }
        for(int i3=0;i3<m;i3++)
        for(int j3=0;j3<n;j3++)
        {
            if(j3<n-1)
            {
                if(que[i3][j3].r==1&&que[i3][j3+1].l==1)
                    find(que[i3][j3].num,que[i3][j3+1].num);
            }

if(i3<m-1)
            {
                if(que[i3][j3].d==1&&que[i3+1][j3].u==1)
                    find(que[i3][j3].num,que[i3+1][j3].num);
            }
        }
        int sum=0;
        for(int i4=1;i4<=N;i4++)
        {
            if(pd[i4]==i4)
                  sum++;
        }
        printf("%d\n",sum);
    }
    return 0;
}

时间: 2024-08-01 16:22:06

HDU1198水管并查集Farm Irrigation的相关文章

HDU--1198 Farm Irrigation (并查集做法+DFS做法)

Problem Description Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pi

【简单并查集】Farm Irrigation

Farm Irrigation Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other) Total Submission(s) : 6   Accepted Submission(s) : 3 Font: Times New Roman | Verdana | Georgia Font Size: ← → Problem Description Benny has a spacious fa

hdu 1198 Farm Irrigation (搜索或并查集)

Farm Irrigation Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5818    Accepted Submission(s): 2521 Problem Description Benny has a spacious farm land to irrigate. The farm land is a rectangle

Farm Irrigation HDU - 1198 (并查集)

Farm Irrigation HDU - 1198 题意:给11种管道,问草地最少需要打多少个井才可以全部灌溉. 把每种管道的状态用二进制表示一下,然后对每一块草地,判断能否和上面或者左面的草地的管道连接. 然后并查集搞一下. 1 #include <bits/stdc++.h> 2 using namespace std; 3 const int maxn=55; 4 5 int g[12]={10,9,6,5,12,3,11,14,7,13,15}; 6 int f[maxn*maxn]

HDOJ1198 Farm Irrigation 【并查集】

Farm Irrigation Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5051    Accepted Submission(s): 2167 Problem Description Benny has a spacious farm land to irrigate. The farm land is a rectangle

hdu 1198 Farm Irrigation(深搜dfs || 并查集)

转载请注明出处:viewmode=contents">http://blog.csdn.net/u012860063?viewmode=contents 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1198 ----------------------------------------------------------------------------------------------------------------------

HDU 1198 Farm Irrigation (并查集)

Farm Irrigation Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 5809    Accepted Submission(s): 2516 Problem Description Benny has a spacious farm land to irrigate. The farm land is a rectangle,

HDU 1198 Farm Irrigation(并查集,自己构造连通条件)

Farm Irrigation Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 11188    Accepted Submission(s): 4876 Problem Description Benny has a spacious farm land to irrigate. The farm land is a rectangle

HDU 1198 Farm Irrigation(并查集+位运算)

Farm Irrigation Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other) Total Submission(s) : 38   Accepted Submission(s) : 24 Font: Times New Roman | Verdana | Georgia Font Size: ← → Problem Description Benny has a spacious