11877 The Coco-Cola Store

题目:    11877  The Coco-Cola Store

Once upon a time, there is a special coco-cola store. If you return three empty bottles to the shop,
  you’ll get a full bottle of coco-cola to drink. If you have n empty bottles right in your hand, how many
  full bottles of coco-cola can you drink?

Input
     There will be at most 10 test cases, each containing a single line with an integer n (1 n 100). The
  input terminates with n = 0, which should not be processed.

Output
     For each test case, print the number of full bottles of coco-cola that you can drink.
 Spoiler
       Let me tell you how to drink 5 full bottles with 10 empty bottles: get 3 full bottles with 9 empty
  bottles, drink them to get 3 empty bottles, and again get a full bottle from them. Now you have 2
  empty bottles. Borrow another empty bottle from the shop, then get another full bottle. Drink it, and
  finally return this empty bottle to the shop!

Sample Input
  3
  10
  81
  0
Sample Output
 1
 5
 40

思路:

每次用现有的空瓶n除以3,商就是新的兑换数,余数加上商就是新的的空瓶数,如此循环到新的空瓶子数小于3时跳出循环。

如果剩下两个空瓶,可以先借一瓶,再还空瓶。

#include <iostream>
using namespace std;
int main()
{
int n,i,j,x,y,sum;
cin>>n;
while(n!=0)
{
sum=0;
while(n>=3)
{
x=n%3;
y=n/3;
sum=sum+y;
n=y+x;
}
if(n==2)
sum++;
cout<<sum<<endl;
cin>>n;
}
return 0;
}

  

时间: 2024-11-07 08:32:57

11877 The Coco-Cola Store的相关文章

UVA_11877.第三次比赛C题:The Coco Cola

题目: 有一个coco cola小店,你可以用三个空瓶换一瓶coco cola饮料,如果你有n个空瓶,你可以喝到多少瓶饮料? 输入输出要求: intput:最多有10组案例,每组输入一个整数,0不被处理操作. Output:每组案例输出你能喝到的饮料数. sample intput: 3 10 81 0 sanple output: 1 5 40 代码如下: #include<iostream> #include<cstdio> using namespace std; int m

11877 The Coco-Cola Store 解题心得

---恢复内容开始--- 11877 The Coco-Cola Store Once upon a time, there is a special coco-cola store. If you return three empty bottles to the shop,you’ll get a full bottle of coco-cola to drink. If you have n empty bottles right in your hand, how manyfull bo

10.8.5如何升级(app store 出错 请稍后重试 100)

出现问题:苹果以前的老版本,OS X 10.8或是10.8.5在当年提示你升级,你又任性没升级的时候,拖过那阵,你再想升级,就是各种报复.进app store下载或是更新东西都是弹出app stpre 出错,请稍候重试 (100),然后再提示说此系统不支持银联. 现在已经是OS X 10.11了,今天接手了一个老古董,系统才OS X 10.8,按照提示升到了OS X 10.8.5,之后不管怎么点,都没法,百度了一下,10.8.5升级,瞎折腾了好久,网上的方法就一个,搞个安装包.最后还是折腾出来了

Coco都可茶饮加盟

Coco都可茶饮加盟详情 1997年诞生于台湾淡水的"CoCo都可茶饮",在台湾早已家喻户晓.2008年," CoCo都可茶饮"在台北101大楼成立旗舰店,成为唯一获准进驻该大楼的外带式茶饮品牌.在台湾精心耕耘了十年 之久,"CoCo都可茶饮"才迈出进入大陆的第一步.不过,正是因为之前积累了丰富的经验和雄厚的实力,"CoCo都可茶饮"在大陆地区的扩张之路发展得非常顺畅. 目前,CoCo都可茶饮在大陆主要采用区域授权合资经营制度

IOS上架App Store商店步骤

苹果官方在2015年05-06月开发者中心进行了改版,网上的APP Store上架大部分都不一样了,自己研究总结一下,一个最新的上架教程以备后用. 原文地址:http://www.16css.com/blog/knowledge/1300.html 1.1.前期工作 首先你需要有一个苹果的开发者帐号,一个Mac系统. 如果没有帐号可以在打开http://developer.apple.com/申请加入苹果的开发者计划.支付99美元每年,怎么申请网上有详细的介绍,在此不多做介绍. 如果你已经有了一

App Store审核条款更新(安全部分)

无论是对于iOSapp开发者还是老板来说,苹果应用商店审核条款都是极其重要的,在这次的WWDC2016大会后,苹果苹果公司发布了四个全新平台:iOS,macOS,watchOS和tvOS.并且在此之后,苹果应用商店审核条款也同时进行了更新--貌似不算进行了更新,简直就是重写!上个版本的30个章节被修改成了5大章节,但原版英文版字数从5000多个英文单词增加到了6000多个英文单词. 对于苹果应用来说,安全是首要的,所以我们先来看看对于苹果来说,什么样的应用是安全的?当我们的iOS app上传时,

lucene中Field.Index,Field.Store的一些设置

lucene在doc.add(new Field("content",curArt.getContent(),Field.Store.NO,Field.Index.TOKENIZED)); Field有两个属性可选:存储和索引. 通过存储属性你可以控制是否对这个Field进行存储: 通过索引属性你可以控制是否对该Field进行索引. 事实上对这两个属性的正确组合很重要. Field.Index Field.Store 说明 TOKENIZED(分词) YES 被分词索引且存储 TOKE

Red style books store OpenCart 主题模板 ABC-0117

Red style books store OpenCart 主题模板 ABC-0117 RED STYLE BOOKS STORE OPENCART 主题模板 ABC-0117 Designed with luxurious colorsSuitable for shop selling: Books , templates, Card, picture, Art, Photography..Designed by CSS, HTMLSupports multiple languages, m

Attractive Music Store OpenCart 自适应主题模板 ABC-0237

Attractive Music Store OpenCart 自适应主题模板 ABC-0237 模板特性 OpenCart版本1.5.5, 1.5.5.1, 1.5.6, 1.5.6.1, 1.5.6.2, 1.5.6.3, 1.5.6.4 包含文件PHP Files, CSS Files, JS Files 详情地址http://www.chinaopencart.cn/index.php?route=product/product&product_id=374