ZOJ 3818(substr函数的使用)

Pretty Poem


Time Limit: 2 Seconds      Memory Limit: 65536 KB


Poetry is a form of literature that uses aesthetic and rhythmic qualities of language. There are many famous poets in the contemporary era. It is said that a few ACM-ICPC contestants can even write poetic code. Some poems has a strict rhyme scheme like "ABABA" or "ABABCAB". For example, "niconiconi" is composed of a rhyme scheme "ABABA" with A = "ni" and B = "co".

More technically, we call a poem pretty if it can be decomposed into one of the following rhyme scheme: "ABABA" or "ABABCAB". The symbol A, B and C are different continuous non-empty substrings of the poem. By the way, punctuation characters should be ignored when considering the rhyme scheme.

You are given a line of poem, please determine whether it is pretty or not.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a line of poem S (1 <= length(S) <= 50). S will only contains alphabet characters or punctuation characters.

Output

For each test case, output "Yes" if the poem is pretty, or "No" if not.

Sample Input

3
niconiconi~
pettan,pettan,tsurupettan
wafuwafu

Sample Output

Yes
Yes
No

题目大意:

  这道题目是说,给你一个长度不超过55的文章,要求你把其中的类似与ABABA和ABABCAB的格式串找出来,如果能够找到这样的串,就输出Yes、

解题思路:

  这道题是自己关于substr(i,j)函数的学习,substr(i,j)指的是,从str[i]开始的长度为j的字符串。刚刚好,我们枚举substr(0,i)作为A

  substr(i,j)作为B,那么A的长度就是i,B的长度就是j,将这两个字符串进行拼接组合,看能否得到一个我们需要满足的字符串的形式。

  关于对于C的枚举,我们可以用len-(i+j)*3得到C的长度然后通过substr((i+j)*2, len-(i+j)*3 ).

代码:

# include<cstdio>
# include<iostream>
# include<cstring>
# include<string>

using namespace std;

# define MAX 55

char str[MAX];
string s;

int main(void)
{
    int t; scanf("%d",&t);
    while ( t-- )
    {
        scanf("%s",str);
        int len = strlen(str);
        for ( int i = 0;i < len;i++ )
        {
            if ( islower(str[i])||isupper(str[i]) )
                s+=str[i];
        }
        //cout<<s<<endl;
        len = s.size();
        int flag = 0;
        for ( int i = 1;i < len&&flag==0;i++ )
        {
            for ( int j = 1;j < len&&flag==0;j++ )
            {
                string A = s.substr(0,i);
                string B = s.substr(i,j);
                if ( A==B )
                    continue;
                if ( A+B+A+B+A==s )
                {
                    flag = 1;
                    break;
                }
                if ( len-(i+j)*3>0 )
                {
                    string AB = A+B;
                    string C = s.substr((i+j)*2,len-(i+j)*3);
                    if ( A==C||B==C )
                        continue;
                    if ( AB+AB+C+AB==s )
                    {
                        flag = 1;
                        break;
                    }
                }
            }
        }
        if (flag)
            puts("Yes");
        else
            puts("No");
        s.clear();
    }

    return 0;
}

  

时间: 2024-11-06 07:34:48

ZOJ 3818(substr函数的使用)的相关文章

ZOJ 3818 Pretty Poem (暴力模拟 string(substr))

Pretty Poem Time Limit: 2 Seconds      Memory Limit: 65536 KB Poetry is a form of literature that uses aesthetic and rhythmic qualities of language. There are many famous poets in the contemporary era. It is said that a few ACM-ICPC contestants can e

Oracle的substr函数

一.Substr函数 substr(目标字符串,开始位置,长度) 注意:这里第三个参数:长度,相当于物理中的标量,没有方向性,所以不能用负值.虽然不报错,但是选择不出任何值出来(欢迎指正) 开始位置可以有负值,表示倒数.例如:substr(ename,-2,2):表示从倒数第一个开始,截取长度为2的字符串 例子1: SQL> select ename,substr(ename,1,3) from emp; ENAME SUBSTR----------  ------SMITH SMIALLEN

【转】oracle的substr函数的用法

[转]oracle的substr函数的用法 oracle的substr函数的用法 取得字符串中指定起始位置和长度的字符串   substr( string, start_position, [ length ] ) 如:     substr('This is a test', 6, 2)     would return 'is'     substr('This is a test', 6)     would return 'is a test'     substr('TechOnThe

substr函数

定义和用法 substr() 函数返回字符串的一部分 语法 substr(string,start,length) 参数解析 参数 描述 string 必需.规定要返回其中一部分的字符串. start 必需.规定在字符串的何处开始. 正数 - 在字符串的指定位置开始 负数 - 在从字符串结尾开始的指定位置开始 0 - 在字符串中的第一个字符处开始 length 可选.规定被返回字符串的长度.默认是直到字符串的结尾. 正数 - 从 start 参数所在的位置返回的长度 负数 - 从字符串末端返回的

strlen、ord、substr函数——获取长度、ASCII码及部分字符串

strlen函数 语法:strlen(string) 定义和用法:strlen() 函数返回字符串的长度. substr函数 语法:substr(string,start,length) 定义和用法:substr() 函数返回字符串的一部分. 参数描述 string:必需.规定要返回其中一部分的字符串. start:必需.规定在字符串的何处开始.正数,在字符串的指定位置开始:负数,在从字符串结尾的指定位置开始:0,在字符串中的第一个字符处开始. charlist:可选.规定要返回的字符串长度.默

SUBSTR()函数详解

这个代码块执行之后屏幕上会显示什么?BEGIN   DBMS_OUTPUT.put_line ('-3,2='||SUBSTR ('abdefg', -3, 2));   DBMS_OUTPUT.put_line ('-7,2='||SUBSTR ('abdefg', -7, 2));END;/(A) 未处理的异常:ORA-01426: numeric overflow(B) -3,2= -7,2=(C) -3,2=ef -7,2=(D) -3,2=ed -7,2=(E) -3,2=ef-7,2

db2中left()函数和right()函数对应oracle中的substr()函数

DB2 LEFT.RIGHT函数 语法:LEFT(ARG,LENGTH).RIGHT(ARG,LENGTH) LEFT.RIGHT函数返回ARG最左边.右边的LENGTH个字符串,ARG可以是CHAR或BINARY STRING. eg:SELECT LEFT(NAME,2),RIGHT(NAME,2) FROM T1 ORACLE substr()函数 substr(字符串,截取开始位置,截取长度) //返回截取的字 substr('Hello World',0,1) //返回结果为 'H' 

JavaScript中substr函数

JavaScript中substr函数方法是返回一个从指定位置开始的指定长度的子字符串.使用方法: stringvar.substr(start [, length ]) 其中stringvar是必选项.要提取子字符串的字符串文字或 String 对象. start是必选项.所需的子字符串的起始位置.字符串中的第一个字符的索引为 0. length是可选项.在返回的子字符串中应包括的字符个数. 如果 length 为 0 或负数,将返回一个空字符串.如果没有指定该参数,则子字符串将延续到 str

oracle的常用函数 instr() 和substr()函数

from:http://1055592535.iteye.com/blog/1676235 在Oracle中 可以使用instr函数对某个字符串进行判断,判断其是否含有指定的字符. 在一个字符串中查找指定的字符,返回被查找到的指定的字符的位置. 语法: instr(sourceString,destString,start,appearPosition) instr('源字符串' , '目标字符串' ,'开始位置','第几次出现') 其中sourceString代表源字符串: destStrin