Fractal(递归,好题)

Fractal

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 8341   Accepted: 3965

Description

A fractal is an object or quantity that displays self-similarity, in a somewhat technical sense, on all scales. The object need not exhibit exactly the same structure at all scales, but the same "type" of structures must appear on all scales. 
A box fractal is defined as below :

  • A box fractal of degree 1 is simply 
    X
  • A box fractal of degree 2 is 
    X X 

    X X
  • If using B(n - 1) to represent the box fractal of degree n - 1, then a box fractal of degree n is defined recursively as following 
    B(n - 1)        B(n - 1)
            B(n - 1)
    B(n - 1)        B(n - 1)

Your task is to draw a box fractal of degree n.

Input

The input consists of several test cases. Each line of the input contains a positive integer n which is no greater than 7. The last line of input is a negative integer −1 indicating the end of input.

Output

For each test case, output the box fractal using the ‘X‘ notation. Please notice that ‘X‘ is an uppercase letter. Print a line with only a single dash after each test case.

Sample Input

1
2
3
4
-1

Sample OutputX

-
X X
 X
X X
-
X X   X X
 X     X
X X   X X
   X X
    X
   X X
X X   X X
 X     X
X X   X X
-
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
         X X   X X
          X     X
         X X   X X
            X X
             X
            X X
         X X   X X
          X     X
         X X   X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
-递归:思路很巧妙,把每个左上角的点作为起点;开始递归;代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
using namespace std;
const int INF=0x3f3f3f3f;
#define mem(x,y) memset(x,y,sizeof(x))
#define SI(x) scanf("%d",&x);
char a[2500][2500];
void dfs(int x,int y,int cur){
	if(cur==1){
		a[x][y]=‘X‘;
		return;
	}
	int n,m;
	dfs(x,y,cur-1);
	//左上
	m=x;n=y+pow(3,cur-2)*2;
	dfs(m,n,cur-1);
	//右上
	m=x+pow(3,cur-2)*2;n=y;
	dfs(m,n,cur-1);
	//左下
	m=x+pow(3,cur-2)*2;n=y+pow(3,cur-2)*2;
	dfs(m,n,cur-1);
	//右下
	m=x+pow(3,cur-2);n=y+pow(3,cur-2);
	dfs(m,n,cur-1);
	//中
}
int main(){
	int N;
	while(scanf("%d",&N),N!=-1){
		int len=pow(3,N-1);
		for(int i=0;i<len;i++){
			for(int j=0;j<len;j++)
				a[i][j]=‘ ‘;
			a[i][len]=‘\0‘;
		}
		dfs(0,0,N);
		for(int i=0;i<len;i++){
			printf("%s\n",a[i]);
		}
		puts("-");
	}
	return 0;
}

  

 
时间: 2024-10-14 06:03:40

Fractal(递归,好题)的相关文章

递归小题中的空间换时间思想

题目: 如数: 1  1  2  3   5   8   13   21  34  55 ...... 序号: 0  1  2  3   4   5   6     7    8    9 ...... 由用户输入序号,输出对应的数值. 效果: 实现代码: #include <stdio.h> int bian(int num); //static int shu[100]={1,1}; int main() { int num; while ( printf("请输入编号数:&qu

HDU 2044(递推&amp;递归_A题)解题报告

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2044 ------------------------------------------------------------------------------------ 题意:只能爬向+1或者+2的房间,求第a个房间到第b个房间的路线多少. 思路:递归,爬向第k个房间只能从第k-1或者k-2个房间爬动,所以相加递归即可. 注意: 递归的题目一般要用数组存上所求的解,防止给出较大值时造成的TLE

递归经典题

递归思想:方法自己调用自己,使用是要避免堆栈溢出 java.lang.StackOverflowError 递归步骤: 递推:将复杂的问题,变成简单问题,最后到一个最简单的状态,此时有一个已知值(追本溯源) 回归:再从已知值,从简单状态算到复杂状态 递归优点,思想简单:递归缺点,效率低 1.斐波那契数列 斐波那契数,亦称之为斐波那契数列(意大利语: Successione di Fibonacci),又称黄金分割数列.费波那西数列.费波拿契数.费氏数列,指的是这样一个数列:1.1.2.3.5.8

#2019122600027 递归五题

目录 1 全排列 2 01背包 3 自然数拆分 4 页码统计 5 汉诺塔 1 全排列 生成从\(1\)到\(n\)的全排列 #include <iostream> #include <cstdio> #include <cstring> #include <cmath> #include <algorithm> using namespace std; int a[25]; bool vis[25]; int n; int ans=0; void

递归好题,NOIP1998幂次方

先占坑提醒自己写这篇文章.回家再补,机房时间宝贵. 洛谷1010 幂次方 本题地址:http://www.luogu.org/problem/show?pid=1010 题目描述 任何一个正整数都可以用2的幂次方表示.例如         137=2^7+2^3+2^0         同时约定方次用括号来表示,即a^b 可表示为a(b). 由此可知,137可表示为:         2(7)+2(3)+2(0) 进一步:7= 2^2+2+2^0   (2^1用2表示)         3=2+

[hdoj]1143递归水题……可是我还没做出来……

1 #include <stdio.h> 2 #define MAX 31 3 int a[MAX]; 4 int main() { 5 int n; 6 a[0] = 1; 7 a[2] = 3; 8 for(int i = 4; i< MAX; i = i+2) 9 a[i] = 4*a[i-2] - a[i-4]; 10 while(scanf("%d",&n)==1&&n!=-1) 11 printf("%d\n",

HDU 2563 统计问题(递归,思维题)

统计问题 Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 8705    Accepted Submission(s): 5157 Problem Description 在一无限大的二维平面中,我们做如下假设: 1.  每次只能移动一格: 2.  不能向后走(假设你的目的地是“向上”,那么你可以向左走,可以向右走,也可以向上走,但是不

递归小题

T:写一个递归函数DigitSum(n),输入一个非负整数,返回组成它的数字之和,例如,调用DigitSum(1729),则应该返回1+7+2+9,它的和是19 #include <stdio.h> int DigitSum(int num) { if (num < 10) { return num; } else { return (num % 10) + DigitSum(num / 10); } } int main() { int ret = DigitSum(1729); pr

poj 1941 The Sierpinski Fractal 递归

//poj 1941 //sep9 #include <iostream> using namespace std; const int maxW=2048; const int maxH=1024; int pow2[32]; char g[maxH+10][maxW+10]; void print(int x,int y,int n) { if(n==1){ g[x][y+1]='/'; g[x][y+2]='\\'; g[x+1][y]='/'; g[x+1][y+1]='_'; g[x