POJ 2387 Til the Cows Come Home Dijkstra求最短路径

Til the Cows Come Home

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John‘s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.

题意:给你一个图,途中每一条边都带有权值(路径长度),求从1到n的最短路径。

思路:单元最短路问题,首先想到Dijkstra。在这里把最基础的Dij O(n^2)与邻接表存图、堆优化的Dij O((n+m)logn)作个比较。

基础Dij:

#include<stdio.h>
#include<string.h>
#include<limits.h>

int a[1005][1005];
int dis[1005],b[1005];
int n;

int min(int x,int y)
{
    return x<y?x:y;
}

void dij(int k)
{
    int i,j,mind,minj;
    memset(b,0,sizeof(b));
    for(i=1;i<=n;i++){
        dis[i]=INT_MAX;
    }
    dis[k]=0;
    for(i=1;i<n;i++){
        mind=INT_MAX;
        for(j=1;j<=n;j++){
            if(!b[j]&&dis[j]<mind){
                mind=dis[j];
                minj=j;
            }
        }
        b[minj]=1;
        for(j=1;j<=n;j++){
            if(!b[j]&&a[minj][j]>=0){
                dis[j]=min(dis[j],dis[minj]+a[minj][j]);
            }
        }
    }
}

int main()
{
    int t,x,y,z;
    memset(a,-1,sizeof(a));
    scanf("%d%d",&n,&t);
    while(t--){
        scanf("%d%d%d",&x,&y,&z);
        a[x][y]=z;
        a[y][x]=z;
    }
    dij(1);
    printf("%d\n",dis[n]);
    return 0;
}

优化Dij:

#include<stdio.h>
#include<string.h>
#include<limits.h>
#include<vector>
#include<queue>
using namespace std;

struct Node{
    int v,w;
    friend bool operator<(Node a,Node b)
    {
        return a.w>b.w;
    }
}node;

vector<Node> a[1005];
int dis[1005];
int n;

void dij(int k)
{
    int v1,v2,i;
    priority_queue<Node> q;
    dis[k]=0;
    node.w=0;
    node.v=k;
    q.push(node);
    while(q.size()){
        v1=q.top().v;
        q.pop();
        for(i=0;i<a[v1].size();i++){
            v2=a[v1][i].v;
            if(dis[v2]>dis[v1]+a[v1][i].w){
                dis[v2]=dis[v1]+a[v1][i].w;
                node.w=dis[v2];
                node.v=v2;
                q.push(node);
            }
        }
    }
}

int main()
{
    int t,x,y,z,i;
    scanf("%d%d",&n,&t);
    for(i=1;i<=n;i++){
        a[i].clear();
        dis[i]=INT_MAX;
    }
    while(t--){
        scanf("%d%d%d",&x,&y,&z);
        node.w=z;
        node.v=y;
        a[x].push_back(node);
        node.v=x;
        a[y].push_back(node);
    }
    dij(1);
    printf("%d\n",dis[n]);
    return 0;
}
时间: 2024-10-13 12:29:20

POJ 2387 Til the Cows Come Home Dijkstra求最短路径的相关文章

POJ 2387 Til the Cows Come Home dijkstra算法 用邻接表和邻接矩阵

题目如下: Til the Cows Come Home Time Limit: 1000MS        Memory Limit: 65536K Total Submissions: 27726        Accepted: 9353 Description Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wa

poj 2387 Til the Cows Come Home(dijkstra算法)

题目链接:http://poj.org/problem?id=2387 题目大意:起点一定是1,终点给出,然后求出1到所给点的最短路径. 注意的是先输入边,在输入的顶点数,不要弄反哦~~~ 1 #include <iostream> 2 #include <cstdio> 3 using namespace std; 4 int map[2010][2010],Min,node[2010],vis[2010],t,q; 5 const int INF=9999999; 6 7 vo

POJ 2387 Til the Cows Come Home (Dijkstra)

题目链接:POJ 2387 Description Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possib

POJ 2387 Til the Cows Come Home (最短路+Dijkstra)

Til the Cows Come Home Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 29550   Accepted: 9935 Description Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the

[2016-04-02][POJ][2387][Til the Cows Come Home]

时间:2016-04-02 10:34:36 星期六 题目编号:[2016-04-02][POJ][2387][Til the Cows Come Home] 题目大意:给定n个节点和t条路,求n到1的最短路长度 分析:跑一次最短路即可 遇到的问题: 据说是多重边,如果是用邻接矩阵的就要更新最小值, 此题是先输入t,再输入n,输入的时候读错,无限WA- #include <queue> #include <cstring> #include <cstdio> using

POJ 2387 Til the Cows Come Home(最短路 Dijkstra/spfa)

传送门 Til the Cows Come Home Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 46727   Accepted: 15899 Description Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for

怒学三算法 POJ 2387 Til the Cows Come Home (Bellman_Ford || Dijkstra || SPFA)

Til the Cows Come Home Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 33015   Accepted: 11174 Description Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the

(简单) POJ 2387 Til the Cows Come Home,Dijkstra。

Description Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. Farmer Joh

POJ 2387 Til the Cows Come Home (dijkstra模板题)

Description Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. Farmer Joh