uva10106 - Product

 Product 

The Problem

The problem is to multiply two integers X, Y. (0<=X,Y<10250)

The Input

The input will consist of a set of pairs of lines. Each line in pair contains one multiplyer.

The Output

For each input pair of lines the output line should consist one integer the product.

Sample Input

12
12
2
222222222222222222222222

Sample Output

144
444444444444444444444444

使用一个数组报春被乘数个位与乘数的相乘结果,在左移一位累加保存被乘数十位与乘数的相乘结果,以此类推,数组的下标为i的元素的值拥有权值为10^i,代码如下

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;

#define MAX 1000000
int ans[MAX];

int main(void){
	string str1, str2;

#ifndef ONLINE_JUDGE
	freopen("f:\\infile.txt", "r", stdin);
#endif

	while(cin >> str1 >> str2){
		int i;

		memset(ans, 0, sizeof(ans));
		for(i = str1.size()-1; i >= 0; i--){
			for(int j = str2.size()-1, p = str1.size()-1-i; j >=0; j--, p++){
				ans[p] += (str1[i]-‘0‘)*(str2[j]-‘0‘);
			}
		}

		for(i = 0; i < MAX; i++){
			ans[i+1] += ans[i]/10;
			ans[i] = ans[i]%10;
		}

		for(i = MAX-1; i >=0; i--){
			if(ans[i])
				break;
		}
		if(i == -1)
			cout << 0 << endl;
		else{
			for(int j = i; j >= 0; j--){
				cout << ans[j];
			}
			cout << endl;
		}
	}
	return 0;
}

uva10106 - Product

时间: 2024-09-28 16:15:56

uva10106 - Product的相关文章

LeetCode 238 Product of Array Except Self(除自身外数组其余数的乘积)

翻译 给定一个有n个数字的数组nums,其中n大于1,返回一个数组使得output[i]等于除nums[i]外所有元素的乘积. 不用分治并且在O(n)复杂度下解决这个问题. 例如,给定[1, 2, 3, 4],返回[24, 12, 8, 6]. 跟进: 你可以只在常量空间下完成它吗? (备注:在空间复杂度计算时输出数组不作为额外空间.) 原文 Given an array of n integers where n > 1, nums, return an array output such t

LeetCode-152 Maximum Product Subarray

Find the contiguous subarray within an array (containing at least one number) which has the largest product. For example, given the array [2,3,-2,4],the contiguous subarray [2,3] has the largest product = 6. 思路:使用动态规划. 设max[i]是以num[i]为结尾元素的子数组的最大乘积:

[LeetCode]Maximum Product Subarray

Find the contiguous subarray within an array (containing at least one number) which has the largest product. For example, given the array [2,3,-2,4], the contiguous subarray [2,3] has the largest product = 6. 这道题是找出数组中的一个子序列,要求这个子序列中数的乘积是所有子序列中最大的. 如

用itertools.product简化嵌套for循环

今天这一题叫做"偷瞄到的密码": 警察跟踪一名窃贼来到了一个仓库门前.仓库的密码锁盘如下: 1 2 3 4 5 6 7 8 9 0 窃贼输入密码后进了门.警察"觉得"自己看到了密码比如1357,但是也有可能是相邻的数字(相邻仅包括正上下左右,不包括对角线),比如第一位不是1,而是相邻的4和2(不包括5). 可能的密码是哪些组合呢? 这道题目可以抽象成: 1. 0-9各自都对应了一组相邻数字 现给定一个数字串: 2. 对数字串中的每个数字,找到对应的相邻数组 3. 计

mac上装eclipse报jvm is not suitable for this product错误时方法

mac上装好了jdk 1.80最新版后,下载eclipse安装,结果报jvm 1.605 is not suitalbe for this product 打开终端,java -version  结果显示是1.605的 我的最终解决方法:下载了java se 1.80版的 安装后,再安装eclipse就不抱错了 java -version显示1.80

关于iOS10 Xcode8真机测试项目出现的问题 &quot;code signing is required for product type &#39;xxxxx&#39; in SDK &#39;iOS 10.0&quot;..

昨天用真机测试项目出现这样的错误,在网上搜集了一些信息,所以将自己的经验分享出来帮助更多的人. 第一步: 检查你的1和2是否填写正确,如果你是运行别人的项目,BundleIdentifier要和你的Xcode之前填写的要一致,例如,我之前填写的com.baidu.xxxx,但是我真机测试的是com.alibaba.xxx,这样就不一致了,可能会导致错误 第二步: 在Bulid Setting 中找到Singning, 在3处,你可能会看到自己的开发者账号,不要选!!,还有下面 4 Develop

238. Product of Array Except Self

Given an array of n integers where n > 1, nums, return an array output such that output[i] is equal to the product of all the elements of nums except nums[i]. Solve it without division and in O(n). For example, given [1,2,3,4], return [24,12,8,6]. Fo

Maximum Pairwise Product

问题描述 Given a sequence of non-negative integers a0,…,an−1, find the maximum pairwise product, that is, the largest integer that can be obtained by multiplying two different elements from the sequence (or, more formally, max0≤i≠j≤n−1aiaj). Different el

Product in foldRight

object ProductFolderRight { def product(ld: List[Double]): Double = { def loop(ls: List[Double], acc: Double): Double = ls match { case Nil => acc case 0.0 :: t => 0.0 case h :: t => h * loop(t, acc) } loop(ld, 1.0) } def main(args: Array[String]