hdu149850 years, 50 colors (多个最小顶点覆盖)

50 years, 50 colors

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1516 Accepted Submission(s): 818

Problem Description

On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it‘s so nice, isn‘t it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing
color balloons".

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind
of balloon to crash, we define that the two balloons with the same color belong to the same kind.What‘s more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students
are waiting to play this game, so we just give every student k times to crash the balloons.

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.

Input

There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of
n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.

Output

For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1".

Sample Input

1 1
1
2 1
1 1
1 2
2 1
1 2
2 2
5 4
1 2 3 4 5
2 3 4 5 1
3 4 5 1 2
4 5 1 2 3
5 1 2 3 4
3 3
50 50 50
50 50 50
50 50 50
0 0

Sample Output

-1
1
2
1 2 3 4 5
-1

题意:在校庆活动其中,有n*n个格子,里面放有不同颜色的汽球,让学生去拍汽球,但一次仅仅能拍一行或一列的同样颜色的汽球。而且一个学生最多仅仅能拍k次,问那些颜色的汽球不能在4k次中拍完则输出汽球的颜色,按升序排列,假设没有则输出-1.

解题:看起来无从下手,但是依据题意可知,我们能够把不同颜色的汽球分开来,对每种汽球各求一次。这样就是一个最小顶覆盖问题了。

#include<stdio.h>
#include<string.h>
int map[55][105][105],vist[105],match[105],n;
int find(int i,int c)
{
    for(int j=1;j<=n;j++)
    if(!vist[j]&&map[c][i][j])
    {
        vist[j]=1;
        if(match[j]==0||find(match[j],c))
        {
            match[j]=i; return 1;
        }
    }
    return 0;
}
int main()
{
    int m,c,cc[55];
    while(scanf("%d%d",&n,&m)>0&&n+m!=0)
    {
        memset(map,0,sizeof(map));
        memset(cc,0,sizeof(cc));
        for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
        {
            scanf("%d",&c); map[c][i][j]=1; cc[c]=1;
        }
        int flag=0,ans;
        for(int c=1;c<=50;c++)
        if(cc[c])
        {
            ans=0; memset(match,0,sizeof(match));
            for(int i=1;i<=n;i++)
            {
                memset(vist,0,sizeof(vist));
                ans+=find(i,c);
            }
            if(ans>m)
            {
               if(flag)printf(" "); printf("%d",c); flag=1;
            }
        }
        if(flag==0)printf("-1");
        printf("\n");
    }
}

版权声明:本文博客原创文章。博客,未经同意,不得转载。

时间: 2024-10-08 12:21:21

hdu149850 years, 50 colors (多个最小顶点覆盖)的相关文章

hdu----149850 years, 50 colors(最小覆盖点)

50 years, 50 colors Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1695    Accepted Submission(s): 931 Problem Description On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating

hdu1498--50 years, 50 colors(二分匹配,题意。。。)

50 years, 50 colors Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1617    Accepted Submission(s): 881 Problem Description On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating

HDU149850 years, 50 colors(行列匹配+最小点覆盖)

题意:给出一个n*n的矩阵,里面的数字代表气球的颜色,你每次可以一行或者一列里的相同的某一颜色气球,并把它们全部打破,你一共有k次机会,问最后不能被某一位学生在k次操作里打破的气球,按字典序升序输出,没有的话输出-1 思路:我们反过来想,能被学生在K次里打破的话,那么这些气球的分布行列数必然不大于K,我们就以某一色气球的 X,Y建立二分图 ,X,Y对应二分图的左右两边,我们肯定是要选择最少点来覆盖所有的边,最小点覆盖就是最大匹配,然后枚举所有颜色的点即可 #include<iostream>

hdu 1498 50 years, 50 colors(最小顶点覆盖)

50 years, 50 colors Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1507    Accepted Submission(s): 811 Problem Description On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating

HDU 1498 50 years, 50 colors(最小点覆盖,坑题)

50 years, 50 colors Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1635    Accepted Submission(s): 892 Problem Description On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating

HDU 1498 50 years, 50 colors(二分最大匹配之最小点覆盖)

题目地址:HDU 1498 晕啊...三个人同时做的这个题,结果全都理解错意思了..而且每个人理解错的地方还都不一样..但是样例还都能过,...简直炫酷... 题意:n*n的矩阵放置不同的颜色(不同的数字代表不同的颜色),你有k次选择,每一次只能选择某一行或某一列,可以消除该行(列)的所有颜色,问有哪几种颜色,无论怎样经过k次选择后依然无法完全抹去. 这个题的思路就是分别求出每种颜色的最少操作次数.然后只要大于k次的就是不符合要求的.然后输出就行了. #include <iostream> #

HDU1498_50 years, 50 colors(二分图/最小点覆盖=最大匹配)

解题报告 题意: 给你一个矩阵,矩阵里面是气球,气球有1-50种颜色,问你在k次之内能不能把那种存在的颜色消掉(每种颜色k次机会),不能消掉的颜色按升序输出. 思路: 白想一上午了,理解错了题意,原来每种有k次可以消除的机会,还以为是总共k次机会消气球. 理解对了就很好做,类似POJ3041 求最小点覆盖.用最少的点覆盖最多的边. 每次枚举颜色看是否操作次数超过k次. 英语.................... ...................... #include <iostream

hdu 50 years, 50 colors(枚举点,最小点覆盖)

http://acm.hdu.edu.cn/showproblem.php?pid=1498 大致题意:给一个n*n的格子,每个格子中都放有不同颜色的气球.每次你可以选择一行或一列以及一种颜色的气球,然后将该行或该列上该种颜色的气球全部扎破.问经过K次,会有哪些气球是不可能被完全扎破的,按升序输出. 以行列为X,Y集合,对每一种颜色的气球构建二分图,求出二分图的最小点覆盖(最大匹配)m,即选取最少的点将所有的边覆盖.若m>k说明该颜色的气球不可能被完全扎破. #include <stdio.h

HDOJ 题目1498 50 years, 50 colors(最小点覆盖)

50 years, 50 colors Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1792    Accepted Submission(s): 981 Problem Description On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating