poj 2431 Expedition (贪心+优先队列)

Expedition

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6890   Accepted: 2065

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck‘s fuel tank. The truck now leaks one unit of fuel every unit of distance
it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows
can stop to acquire additional fuel (1..100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that
there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.

Input

* Line 1: A single integer, N

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS:

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply
up to 4, 2, 5, and 10 units of fuel, respectively.

OUTPUT DETAILS:

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

Source

USACO 2005 U S Open Gold

比较简单的一个题目,只不过题目意思比较难以理解,我读了好几遍题目才把意思弄明白,题目意思是一辆卡车距离城镇有L距离,车中还有P油量,每向前行驶一单位距离消耗一单位的油量,如果在途中卡车中就没有油了 ,就无法到达终点;途中有N个加油站,加油站提供的油量有限,卡车的油箱是无限的,给出每个加油站距离终点的距离和提供的油量,问卡车在途中最少需要加几次油。

这个题目就要用到贪心的思想,先去提供油量比较多的地方,距离又比较近的地方,用优先队列来储存每一次的油量;只要油量恰好能够到达终点,所加的次数就是最小的;

#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;
const int maxn=10001;
typedef struct node
{
    int dis,fuel;
}node;
node stop[maxn];
bool cmp(node x,node y)//比较大小,题目中给的是到终点的距离
{
   return x.dis>y.dis;
}
int main()
{
    int n,l,p;
    int ans=0,j=0,temp;
    while(scanf("%d",&n)!=EOF)
    {
    priority_queue<int>q;
    for(int i=0;i<n;i++)
        scanf("%d %d",&stop[i].dis,&stop[i].fuel);
    scanf("%d %d",&l,&p);
    sort(stop,stop+n,cmp);
    q.push(p);//起始的油量入队
    while(l>0 && !q.empty())
    {
        ans++;
        temp=q.top();
        q.pop();
        l-=temp;//油量能够支撑的距离
        while(j<n && l<=stop[j].dis)//到终点的距离进行比较
            q.push(stop[j++].fuel);//加油站提供的油量
    }
    printf("%d\n",l<=0?ans-1:-1);
    }
    return 0;
}

poj 2431 Expedition (贪心+优先队列),布布扣,bubuko.com

时间: 2024-08-02 06:59:17

poj 2431 Expedition (贪心+优先队列)的相关文章

poj 2431 Expedition 贪心+优先队列

Expedition Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 7707   Accepted: 2263 Description A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to

poj 2431 Expedition 贪心+最大堆

当油量不够时从走过的油站中选最大加油量的 #include<iostream> #include<queue> #include<stdlib.h> #include<algorithm> using namespace std; #define MAX_N 10005 struct node{ int dist,fuel; }t[MAX_N]; bool cmp(const node &a,const node &b) { return a

poj - 2431 Expedition (优先队列)

http://poj.org/problem?id=2431 你需要驾驶一辆卡车做一次长途旅行,但是卡车每走一单位就会消耗掉一单位的油,如果没有油就走不了,为了修复卡车,卡车需要被开到距离最近的城镇,在当前位置和城镇之间有n个加油站可以加油. 为了减少危险,需要最少的加油次数,卡车的油箱可以看作无限大,卡车初始距离城镇L单位,自身有P单位的油. 注意输入的距离是与城镇的距离不是与开始点的距离.转换一下就好. 思想:把经过的所有加油站都加入优先队列,当燃料不足时就取出优先队列的最大元素,用来给卡车

POJ 2431 Expedition 贪心 优先级队列

Expedition Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 30702   Accepted: 8457 Description A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed t

POJ 2431 Expedition 贪心

题意:一辆汽车由起点开往小镇,总路程为L,路上有N个加油站,第i个加油站距离小镇a[i],最多可为提供b[i]的汽油,汽车开始时有P单位汽油,问汽车内否到达小镇,若能到达输出最小的加油次数. 思路:每经过一个加油站i,汽车就获得了一次在任何时候加油b[i]的权利,当汽车不足以到达下一站时,就加入过往的最大的b值. #include<stdio.h> #include<queue> #include<iostream> #include<algorithm>

POJ 1862 Stripies 贪心+优先队列

http://poj.org/problem?id=1862 题目大意: 有一种生物能两两合并,合并之前的重量分别为m1和m2,合并之后变为2*sqrt(m1*m2),现在给定n个这样的生物,求合并成一个的最小重量 思路: m1+m2 >=  2*sqrt(m1*m2) 所以每次取大的去合并,能变小. 直接优先队列就可以啦. #include<cstdio> #include<cmath> #include<queue> using namespace std;

poj 2431 Expedition(优先队列)

题目链接 http://poj.org/problem?id=2431 Expedition Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 9243   Accepted: 2700 Description A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor driver

poj 2431 Expedition (贪心加优先队列)

Expedition Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 11538   Accepted: 3336 Description A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed t

POJ 2431 Expedition (贪心 + 优先级队列)

Expedition Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 7696   Accepted: 2260 Description A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to