素数三元组(南阳oj1156)(素数水题)

素数三元组

时间限制:1000 ms  |  内存限制:65535 KB

难度:1

描述

相邻三个奇数都是素数是一种非常少见的情形,也就是三个奇数p-2, p, p+2都是素数,这样就形成了一个素数三元组。请找出三个数都不超过n的所有这样的素数三元组。

输入
输入多组数据,每组测试数据为一个正整数n,n <= 5000000。
输出
输出大小不超过n的所有的素数三元组,每行按照从小到大的顺序输出一个三元组中的三个数,两个数之间用空格间隔。如果不存在这样的素数三元组,请输出“No triple”。
样例输入
1
样例输出
No triple
提示
○| ̄|_
来源
爱生活
上传者

TCM_张鹏

//素数打表超时!!!看来学新方法用来素数判定!!!
/*#include<stdio.h>
#include<string.h>
#define N 5000010
int s[N]={1,1,0};
int main()
{
	int i,j,n,k;
	for(i=2;i*i<N;i++)
	{
		if(!s[i])
		{
			for(j=i+i;j<N;j+=i)
			s[j]=1;
		}
	}
	while(scanf("%d",&n)!=EOF)
	{
		for(i=3,k=0;i<=n-4;)
		{
			if((!s[i])&&(!s[i+2])&&(!s[i+4]))
			{
			   printf("%d %d %d\n",i,i+2,i+4);
			   k=1;
			   i+=6;
		    }
		    else
		    i+=2;
		}
		if(k==0)
		printf("No triple\n");
	}
	return 0;
}*/
//其实可以思考下,连续三个奇数都为素数的情况也就 3,5,7。
#include<stdio.h>
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		if(n>=7)
		printf("3 5 7\n");
		else
		printf("No triple\n");
	}
	return 0;
}
时间: 2024-10-26 05:05:16

素数三元组(南阳oj1156)(素数水题)的相关文章

字母统计(南阳oj241)(水题)

字母统计 时间限制:3000 ms  |  内存限制:65535 KB 难度:1 描述 现在给你一个由小写字母组成字符串,要你找出字符串中出现次数最多的字母,如果出现次数最多字母有多个那么输出最小的那个. 输入 第一行输入一个正整数T(0<T<25) 随后T行输入一个字符串s,s长度小于1010. 输出 每组数据输出占一行,输出出现次数最多的字符: 样例输入 3 abcd bbaa jsdhfjkshdfjksahdfjkhsajkf 样例输出 a a j 来源 [路过这]原创 上传者 路过这

POJ2262_Goldbach&#39;s Conjecture【素数判断】【水题】

Goldbach's Conjecture Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 38024 Accepted: 14624 Description In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture:

POJ2909_Goldbach&#39;s Conjecture【素数判断】【水题】

Goldbach's Conjecture Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 10116 Accepted: 5973 Description For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2 This c

蓝桥杯 算法训练 Torry的困惑(基本型)(水题,筛法求素数)

算法训练 Torry的困惑(基本型) 时间限制:1.0s   内存限制:512.0MB 问题描述 Torry从小喜爱数学.一天,老师告诉他,像2.3.5.7--这样的数叫做质数.Torry突然想到一个问题,前10.100.1000.10000--个质数的乘积是多少呢?他把这个问题告诉老师.老师愣住了,一时回答不出来.于是Torry求助于会编程的你,请你算出前n个质数的乘积.不过,考虑到你才接触编程不久,Torry只要你算出这个数模上50000的值. 输入格式 仅包含一个正整数n,其中n<=100

POJ1595_Prime Cuts【素数】【水题】

Prime Cuts Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 10464 Accepted: 3994 Description A prime number is a counting number (1, 2, 3, ...) that is evenly divisible only by 1 and itself. In this problem you are to write a program that w

POJ3518_Prime Gap【素数】【水题】

Prime Gap Time Limit: 5000MSMemory Limit: 65536K Total Submissions: 8499Accepted: 4983 Description The sequence of n ? 1 consecutive composite numbers (positive integers that are not prime and not equal to 1) lying between two successive prime number

HDU ACM 2521 反素数 水题+因子打表

分析:水题,不解释. #include<iostream> using namespace std; int cnt[6000]; void init() //打表 { int i,j; memset(cnt,0,sizeof(cnt)); cnt[1]=1; //1只有他本身 for(i=2;i<=5005;i++) { cnt[i]+=2; //1和他本身 for(j=2;j<=i/2;j++) if(i%j==0) cnt[i]++; } } int main() { int

2015南阳CCPC L - Huatuo&#39;s Medicine 水题

L - Huatuo's Medicine Time Limit: 1 Sec Memory Limit: 256 MB 题目连接 无 Description Huatuo was a famous doctor. He use identical bottles to carry the medicine. There are different types of medicine. Huatuo put medicines into the bottles and chain these b

素数相关?(有关素数的题持续更新中)x

素数(大体举几个栗子): 素数相关知识: 素数概念: 最大公约数只有1和它本身的数叫做质数(素数) 素数小性质: 1.大于一的整数必有素因数. 2.设p是素数,n是任意一个整数 能够推出p|n,(p,n)=1; 3.设p是素数,a,b为整数,若p|ab,则ab中至少有一个能被p整除 4.素数有无穷多个证明: (素数与整数之间的关系:1整除2互素) 假定正整数中只有有限个素数 设p1,p2……pk为从小到大排列起来的数 且N=p1*p2*……pk 设M=N+1 如果M为素数,那么M要大于p1,p2