1105 Spiral Matrix(25 分)

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and nsatisfy the following: m×n must be equal to N; m≥n; and m?n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 1. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
const int maxn = 10010; //数字不能太大
int matrix[maxn][maxn],A[maxn];

bool cmp(int a,int b){
    return a > b;
}

int main(){
    int N;
    scanf("%d",&N);
    for(int i = 0; i < N; i++){
        scanf("%d",&A[i]);
    }
    if(N == 1){
        printf("%d",A[0]);
        return 0;
    }
    sort(A,A+N,cmp);
    int m = (int)ceil(sqrt(1.0*N));
    while(N % m != 0) m++;  //除不整的时候m++
    int n = N / m, i = 1, j = 1, now = 0;
    int U = 1, D = m, L = 1, R = n;
    while(now < N){
        while(now < N && j < R){
            matrix[i][j] = A[now++];
            j++;
        }
        while(now < N && i < D){
            matrix[i][j] = A[now++];
            i++;
        }
        while(now < N && j > L){
            matrix[i][j] = A[now++];
            j--;
        }
        while(now < N && i > U){
            matrix[i][j] = A[now++];
            i--;
        }
        U++,D--,L++,R--;
        i++,j++;
        if(now == N - 1){
            matrix[i][j] = A[now++];
        }
    }
    for(int i = 1; i <= m; i++){
        for(int j = 1; j <= n; j++){
            printf("%d",matrix[i][j]);
            if(j < n) printf(" "); //j < n,不是j < n - 1
            else printf("\n");
        }
    }
    return 0;
}

原文地址:https://www.cnblogs.com/wanghao-boke/p/9574335.html

时间: 2024-07-30 15:29:11

1105 Spiral Matrix(25 分)的相关文章

PAT 甲级 1105 Spiral Matrix (25分)(螺旋矩阵,简单模拟)

1105 Spiral Matrix (25分) This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The

1105. Spiral Matrix (25)【模拟】——PAT (Advanced Level) Practise

题目信息 1105. Spiral Matrix (25) 时间限制150 ms 内存限制65536 kB 代码长度限制16000 B This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left co

1105. Spiral Matrix (25)

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n c

PAT (Advanced Level) 1105. Spiral Matrix (25)

简单模拟. #include<cstdio> #include<cstring> #include<cmath> #include<map> #include<queue> #include<string> #include<algorithm> using namespace std; const int maxn=10000+10; int N,a[maxn]; int ans[maxn]; int m,n; int

PAT 1105 Spiral Matrix

1105 Spiral Matrix(25 分) This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The

PAT 甲级 1105 Spiral Matrix

https://pintia.cn/problem-sets/994805342720868352/problems/994805363117768704 This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upp

1105 Spiral Matrix

题意:给出含N个数的序列,要求把这N个数按从大到小的顺序顺时针填入m*n的矩阵中,m,n需满足m*n=N,同时m>=n且m-n尽量小. 思路:我是按如下的方式,先从左往右把第1层填满,然后从第2层到倒数第2层把最右侧填满... 然后设置flag来标记当前是第几圈,因为每一圈上下左右边界是变化的,如第一圈从左到右的边界是[0,n-1],第二圈(如果有的话)则是[1,n-2],用这个flag方便控制边界的变化,具体的看看代码,手动模拟即可. 注意:在for循环内不要忘记加idx<cnt进行控制!如

PAT1105:Spiral Matrix

1105. Spiral Matrix (25) 时间限制 150 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrixis filled in from the first elem

PAT_A1105#Spiral Matrix

Source: PAT A1105 Spiral Matrix (25 分) Description: This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move