实验拓扑图:
思科:
R1:
interface F1/0
ip address 192.168.1.1 255.255.255.255
no shutdown
interface F0/0
ip address 192.168.2.1 255.255.255.255
no shutdown
ip route 192.168.3.0 255.255.255.0 192.168.2.2
ip route 192.168.4.0 255.255.255.0 192.168.2.2
show ip interface brief
show ip route
R2:
interface F0/0
ip address 192.168.2.2 255.255.255.255
no shutdown
interface F1/0
ip address 192.168.3.2 255.255.255.255
no shutdown
ip route 192.168.1.0 255.255.255.0 192.168.2.1
ip route 192.168.4.0 255.255.255.0 192.168.3.3
show ip interface brief
show ip route
R3:
interface F0/0
ip address 192.168.3.3 255.255.255.0
no shutdown
interface F1/0
ip address 192.168.4.3 255.255.255.0
no shutdown
ip route 0.0.0.0 0.0.0.0 192.168.3.2(使用默认路由,或者静态路由:ip route 192.168.2.0 255.255.255.0 192.168.3.2 ip route 192.168.1.0 255.255.255.0 192.168.3.2 )
show ip interface brief
show ip route
华为:
R1:
interface F1/0
ip address 192.168.1.1 24
undo shutdown
interface F0/0
ip address 192.168.2.1 24
undo shutdown
ip route-static 192.168.3.0 24 192.168.2.2
ip route-static 192.168.4.0 24 192.168.2.2
display ip interface brief
display ip routing-table
R2:
interface F0/0
ip address 192.168.2.2 24
undo shutdown
interface F1/0
ip address 192.168.3.2 24
undo shutdown
ip route-static 192.168.1.0 24 192.168.2.1
ip route-static 192.168.4.0 24 192.168.3.3
display ip interface brief
display ip routing-table
R3:
interface F0/0
ip address 192.168.3.3 24
undo shutdown
interface F1/0
ip address 192.168.4.3 24
undo shutdown
ip route-static 0.0.0.0 0 192.168.3.2(使用默认路由,或者静态路由:ip route 192.168.2.0 24 192.168.3.2 ip route 192.168.1.0 24 192.168.3.2 )
display ip interface brief
display ip routing-table
原文地址:http://blog.51cto.com/12950413/2151056