poj 3264 Balanced Lineup(线段数求区间最大最小值)

链接:http://poj.org/problem?id=3264

Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 32772   Accepted: 15421
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John‘s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

=====================================================================思路也很清晰,就是重新弄一个root[]数组求最小值,开始把minn设为0,找了好久才找到

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <iostream>

using namespace std;
#define Maxx 50010
int str[Maxx],root[Maxx<<2],root1[Maxx<<2];
int n;
int minn,maxx;

void make_tree(int l,int r,int rt)
{
    if(l == r)
    {
        root[rt]=str[l];
        root1[rt]=str[l];
        return ;
    }

    int mid=(l+r)/2;
    make_tree(l,mid,rt*2);
    make_tree(mid+1,r,rt*2+1);
    root[rt]=max(root[rt*2],root[rt*2+1]);
    root1[rt]=min(root1[rt*2],root1[rt*2+1]);
}

void update(int l,int r,int rt,int a,int b)
{
    if(l == r && l == a)
    {
        root[rt]=b;
        root1[rt]=b;
        return ;
    }

    int mid=(l+r)/2;
    if(a<=mid)
        update(l,mid,rt*2,a,b);
    else
        update(mid+1,r,rt*2+1,a,b);

    root[rt]=max(root[rt*2],root[rt*2+1]);
    root1[rt]=min(root1[rt*2],root1[rt*2+1]);
}

void query(int l,int r,int rt,int left,int right)
{
    if(l == left&&r == right)
    {
        maxx=max(maxx,root[rt]);
        minn=min(minn,root1[rt]);
        return ;
    }

    int mid=(l+r)/2;
    if(left>mid)
    {
        query(mid+1,r,rt*2+1,left,right);
    }
    else if(right<=mid)
    {
        query(l,mid,rt*2,left,right);
    }
    else
    {
        query(l,mid,rt*2,left,mid);
        query(mid+1,r,rt*2+1,mid+1,right);
    }
}

int main()
{
    int q;
    int i,j;
    int a,b;
    while(scanf("%d%d",&n,&q)!=EOF)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d",&str[i]);
        }
        make_tree(1,n,1);
        for(i=1;i<=q;i++)
        {
            minn=100000000;maxx=0;
            scanf("%d%d",&a,&b);
            query(1,n,1,a,b);
            printf("%d\n",maxx-minn);
        }
    }
    return 0;
}

poj 3264 Balanced Lineup(线段数求区间最大最小值),布布扣,bubuko.com

时间: 2024-12-24 05:46:25

poj 3264 Balanced Lineup(线段数求区间最大最小值)的相关文章

POJ - 3264 Balanced Lineup (RMQ问题求区间最值)

RMQ (Range Minimum/Maximum Query)问题是指:对于长度为n的数列A,回答若干询问RMQ(A,i,j)(i,j<=n),返回数列A中下标在i,j里的最小(大)值,也就是说,RMQ问题是指求区间最值的问题. Balanced Lineup Time Limit: 5000MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u Submit Status Description For the daily

poj 3264 Balanced Lineup【RMQ-ST查询区间最大最小值之差 +模板应用】

题目地址:http://poj.org/problem?id=3264 Sample Input 6 3 1 7 3 4 2 5 1 5 4 6 2 2 Sample Output 6 3 0分析:标准的模板题,可以用线段树写,但用RMQ-ST来写代码比较短.每次输出区间[L, R]内最大值和最小值的差是多少.注意一个地方,代码里面用到了log2()函数,但是我用包含<math.h>和<cmath>头文件的代码以C++的方式提交到POJ反馈是编译错误.改成g++提交才AC了.(注意

POJ 3264 Balanced Lineup (线段树单点更新 区间查询)

Balanced Lineup Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 36820   Accepted: 17244 Case Time Limit: 2000MS Description For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer Joh

POJ 3264 Balanced Lineup 线段树 第三题

Balanced Lineup Description For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a

POJ 3264 Balanced Lineup (线段树)

Balanced Lineup For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous

[POJ 3264]Balanced Lineup(ST算法求RMQ)

Description For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous rang

POJ 3264 Balanced Lineup【线段树区间查询求最大值和最小值】

Balanced Lineup Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 53703   Accepted: 25237 Case Time Limit: 2000MS Description For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer Joh

【POJ】3264 Balanced Lineup ——线段树 区间最值

Balanced Lineup Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 34140   Accepted: 16044 Case Time Limit: 2000MS Description For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer Joh

POJ 3264 Balanced Lineup ST表

链接:http://poj.org/problem?id=3264 题意:给一串数字,多次询问,求区间最大值和区间最小值的差. 思路:RMQ问题,可以用O(N^2)的预处理,然后每次O(1)的查询,可以用线段树,O(N)的建树,O(logN)的查询,可以用ST表记录,O(NlogN)的预处理,O(1)的查询. 实际上ST表的预处理过程也是一个DP的过程dp[i][j]表示从第i位开始连续2^j位的区间最值. 预处理:dp[i][j]=min(dp[i][j],dp[i+2^j][j]),查询:q