杭电1102 Constructing Roads

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 13518    Accepted Submission(s): 5128

Problem Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B,
or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within
[1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

这道题也是用的最小生成树做的

代码:

#include<stdio.h>

#include<string.h>

#define INF 1 << 30

int map[101][101] ;

int dis[101] ;

int used[101] ;

void prim( int N )

{

for(int k = 1 ; k <= N ; k++)

{

dis[k] = map[1][k] ;

used[k] = 0 ;

}

int sum = 0 ;

for(int i = 1 ; i <= N ; i++ )

{

int min = INF ;

int c = 0 ;

for(int j = 1 ; j <= N ; j++ )

{

if(!used[j] && dis[j] < min )

{

min = dis[j] ;

c = j ;

}

}

used[c] = 1 ;

for(j = 1 ; j <= N ; j++)

{

if(!used[j] && dis[j] > map[c][j])

dis[j] = map[c][j] ;

}

}

for(i = 1 ; i <= N ; i++)

sum += dis[i] ;

printf("%d\n", sum);

}

int main()

{

int N = 0 ;

while(~scanf("%d" , &N))

{

memset(map , 0 , sizeof(map) ) ;

for(int i = 1 ; i <= N ; i++)

{

for(int j = 1 ; j <= N ; j++)

{

scanf("%d" , &map[i][j]) ;

}

}

int Q = 0 ;

scanf("%d" , &Q) ;

int x = 0 , y = 0 ;

for( int m = 1 ; m <= Q ; m++ )

{

scanf("%d%d" , &x , &y ) ;

map[x][y] = map[y][x] = 0 ;//已经建好的树不用再建了

}

prim( N ) ;

}

return 0 ;

}

时间: 2024-10-10 17:00:41

杭电1102 Constructing Roads的相关文章

杭电ACM1025——Constructing Roads In JGShining&#39;s Kingdom

题目的意思是,两行城市,从左到右为1,2,3--n个城市.上面的下面的城市要与上面某个的城市相连,在不出现相交的情况下,最多可以连多少条. 知道了题意,就知道了应该用DP来做. 这一题,数据量比较大,用普通的DP,时间复杂度为N^2,会超时,我们应该用另一种DP方法,时间复杂度为nlogn. nlogn的DP的思路大概就是给你一个数,插到一个数组中,该位置已存在,就覆盖它.也就是可以用二分查找提高效率. 注意:输出的时候,要注意英语的单复数... 下面的是AC的代码: #include <ios

杭电 1025 Constructing Roads In JGShining&#39;s Kingdom(二分查找)

http://acm.hdu.edu.cn/showproblem.php?pid=1025 Constructing Roads In JGShining's Kingdom Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 15515    Accepted Submission(s): 4412 Problem Descriptio

HDU 1102 Constructing Roads, Prim+优先队列

题目链接:HDU 1102 Constructing Roads Constructing Roads Problem Description There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are conne

hdu 1102 Constructing Roads (Prim算法)

题目连接:http://acm.hdu.edu.cn/showproblem.php?pid=1102 Constructing Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 21947    Accepted Submission(s): 8448 Problem Description There are N villa

HDU 1102 Constructing Roads (最小生成树)

最小生成树模板(嗯……在kuangbin模板里面抄的……) 最小生成树(prim) /** Prim求MST * 耗费矩阵cost[][],标号从0开始,0~n-1 * 返回最小生成树的权值,返回-1表示原图不连通 */ const int INF = 0x3f3f3f3f; const int MAXN = 110; bool vis[MAXN]; int lowc[MAXN]; int map[MAXN][MAXN]; int Prim(int cost[][MAXN], int n) {

hdu 1102 Constructing Roads (最小生成树)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1102 Constructing Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 14172    Accepted Submission(s): 5402 Problem Description There are N villa

hust 1102 Constructing Roads

Problem Description There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B

HDU 1102 Constructing Roads (裸的并查集)

Constructing Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 13210    Accepted Submission(s): 4995 Problem Description There are N villages, which are numbered from 1 to N, and you should

hdu 1102 Constructing Roads Kruscal

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1102 题意:这道题实际上和hdu 1242 Rescue 非常相似,改变了输入方式之后, 本题实际上更适合用Prim来做. 用Kruscal的话要做一些变化. /*Constructing Roads Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s)