Channel Allocation (poj 1129 dfs)


Language:
Default

Channel Allocation

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 12367   Accepted: 6325

Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere
with one another. This condition is satisfied if adjacent repeaters use different channels.

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of
channels required.

Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example,
ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input.

Following the number of repeaters is a list of adjacency relationships. Each line has the form:

A:BCDH

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line
has the form

A:

The repeaters are listed in alphabetical order.

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross.

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when
only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed. 

Source

Southern African 2001

题意:给你一个n,代表电台的数量。电台的编号是从A到Z。然后给你他们之间的邻接关系,让你求出最小需要的频率数。要求任意两个相邻的电台之间不允许用同一频率。

思路:数据不大,最多26,dfs暴力,用邻接表存图,color[x]=i表示x号电台使用i频率。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 30
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

struct Edge
{
    int u,v;
    int next;
}edge[maxn*maxn];

int N,edgenum;
int head[maxn];
int color[maxn];

void addedge(int u,int v)
{
    edge[edgenum].v=v;
    edge[edgenum].next=head[u];
    head[u]=edgenum++;
}

bool ISok(int x)
{
    for (int i=head[x];i!=-1;i=edge[i].next)
    {
        if (color[x]==color[edge[i].v])
            return false;
    }
    return true;
}

bool dfs(int point_num,int color_num)
{
    if (point_num>N)
        return true;
    for (int i=1;i<=color_num;i++)
    {
        color[point_num]=i;
        if (ISok(point_num))
        {
            if (dfs(point_num+1,color_num))
                return true;
        }
        color[point_num]=0;
    }
    return false;
}

int main()
{
    while (scanf("%d",&N)&&N)
    {
        getchar();
        memset(head,-1,sizeof(head));
        memset(color,0,sizeof(color));
        edgenum=0;
        for (int i=1;i<=N;i++)
        {
            getchar();
            getchar();
            char ch;
            while (ch=getchar())
            {
                if (ch=='\n')
                    break;
                addedge(i,ch-'A'+1);
            }
        }
        for (int i=1;i<=N;i++)//从1~N枚举颜色种类数
        {
            if (dfs(1,i))
            {
                if (i==1)//注意一个频率是用channel,多个时用channels
                    printf("1 channel needed.\n");
                else
                    printf("%d channels needed.\n",i);
                break;
            }
        }
    }
    return 0;
}
/*
2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0
*/
时间: 2024-10-08 10:08:48

Channel Allocation (poj 1129 dfs)的相关文章

poj 1129 Channel Allocation (dfs)

链接:poj 1129 题意:如果相邻的中继器使用不同的频道,就不会相互干扰. 给定一些中继器的相邻关系,问至少要选几个不同的频道,使得中继器都不互相干扰. 分析:这题可以转化为无向图的染色问题, 即相邻的点不能染同一种颜色,求至少需要的几种颜色? 本题顶点数最多为26,可以直接用暴力搜索即可 思路:若顶点总数为n,则最多需要n种颜色(编号为1,2...n), 从最小的顶点开始染色,每次将与该顶点相邻的已染色的颜色标记, 再从未标记(未用)的颜色中,选出一个最小的颜色,给该点染色, 所有点染色完

POJ 1129 Channel Allocation(DFS)

Channel Allocation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 13173   Accepted: 6737 Description When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a s

POJ 1129 Channel Allocation DFS 回溯

Channel Allocation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 15546   Accepted: 7871 Description When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a s

poj 1129 -- Channel Allocation

Channel Allocation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 12143   Accepted: 6218 Description When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a s

POJ 1129 Channel Allocation(暴力搜--涂色问题)

Channel Allocation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 13295   Accepted: 6806 Description When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a s

四色定理+dfs(poj 1129)

题目:Channel Allocation 题意:要求A:BCD,A与B,C,D都不相同,求不同的值,典型的四色定理: #include <iostream> #include <algorithm> #include <stdlib.h> #include <time.h> #include <cmath> #include <cstdio> #include <string> #include <cstring&

(DFS)poj 1129

Channel Allocation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 12983   Accepted: 6649 Description When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a s

poj 1129 搜索

Channel Allocation Time Limit: 1000 MS Memory Limit: 10000 KB 64-bit integer IO format: %I64d , %I64u Java class name: Main [Submit] [Status] [Discuss] Description When a radio station is broadcasting over a very large area, repeaters are used to ret

poj 1129(图的着色问题)

Channel Allocation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 12096   Accepted: 6191 Description When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a s