Oil Deposits(dfs)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15291    Accepted Submission(s): 8787

Problem Description

The
GeoSurvComp geologic survey company is responsible for detecting
underground oil deposits. GeoSurvComp works with one large rectangular
region of land at a time, and creates a grid that divides the land into
numerous square plots. It then analyzes each plot separately, using
sensing equipment to determine whether or not the plot contains oil. A
plot containing oil is called a pocket. If two pockets are adjacent,
then they are part of the same oil deposit. Oil deposits can be quite
large and may contain numerous pockets. Your job is to determine how
many different oil deposits are contained in a grid.

Input

The
input file contains one or more grids. Each grid begins with a line
containing m and n, the number of rows and columns in the grid,
separated by a single space. If m = 0 it signals the end of the input;
otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this
are m lines of n characters each (not counting the end-of-line
characters). Each character corresponds to one plot, and is either `*‘,
representing the absence of oil, or `@‘, representing an oil pocket.

Output

For
each grid, output the number of distinct oil deposits. Two different
pockets are part of the same oil deposit if they are adjacent
horizontally, vertically, or diagonally. An oil deposit will not contain
more than 100 pockets.

Sample Input

1 1

*

3 5

*@*@*

**@**

*@*@*

1 8

@@****@*

5 5

****@

*@@*@

*@**@

@@@*@

@@**@

0 0

Sample Output

0

1

2

#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
int n,m;
char grid[120][120];
int vis[120][120];
struct node{
    int x,y;
};
void in_put()
{
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;++i)
    scanf("%s",grid[i]+1);
}
int check(node v)
{
    if(!vis[v.x][v.y]&&v.x>=1&&v.x<=n&&v.y>=1&&v.y<=m&&grid[v.x][v.y]==‘@‘)
    return 1;
    else return 0;
}
void dfs(node v)
{
    node nex;
    vis[v.x][v.y]=1;grid[v.x][v.y]=‘?‘;

    nex.x=v.x+1;nex.y=v.y;if(check(nex))    dfs(nex);
    nex.x=v.x+1;nex.y=v.y+1;if(check(nex))  dfs(nex);
    nex.x=v.x+1;nex.y=v.y-1;if(check(nex))  dfs(nex);
    nex.x=v.x;nex.y=v.y-1;if(check(nex))    dfs(nex);
    nex.x=v.x;nex.y=v.y+1;if(check(nex))    dfs(nex);
    nex.x=v.x-1;nex.y=v.y-1;if(check(nex))  dfs(nex);
    nex.x=v.x-1;nex.y=v.y+1;if(check(nex))  dfs(nex);
    nex.x=v.x-1;nex.y=v.y;if(check(nex))    dfs(nex);
}
int main()
{
    while(scanf("%d%d",&n,&m))
    {
        int cnt=0;node now;
        if(!n&&!m) break;
        in_put();
        for(int i=1;i<=n;++i)
            for(int j=1;j<=m;++j)
                if(grid[i][j]==‘@‘)
            {now.x=i;now.y=j;dfs(now);cnt++;}

            printf("%d\n",cnt);
    }
}

2

时间: 2024-11-05 22:26:39

Oil Deposits(dfs)的相关文章

UVa 572 Oil Deposits(DFS)

 Oil Deposits  The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots.

HDU_1241 Oil Deposits(DFS深搜)

Problem Description The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square pl

Oil Deposits DFS FloodFill漫水填充法求连通块问题

Oil Deposits The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It

HDU 1241 Oil Deposits(DFS)

题目链接 Problem Description The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous squa

[POJ] 1562 Oil Deposits (DFS)

Oil Deposits Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 16655   Accepted: 8917 Description The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular r

hdoj 1241 Oil Deposits (dfs)

Oil Deposits Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 17683    Accepted Submission(s): 10172 Problem Description The GeoSurvComp geologic survey company is responsible for detecting under

UVa 572 Oil Deposits(DFS求8连通块)

题意  求n*m矩阵中'@'连通块的个数  两个'@'在一个九宫格内就属于一个连通块 最基础的DFS  遇到@就递归扫描周围8个并标记当前格子已访问  然后就得到答案了 #include<cstdio> using namespace std; const int N = 110; char mat[N][N]; int dfs(int r, int c) { if(mat[r][c] != '@') return 0; else { mat[r][c] = '*'; for(int i =

Oil Deposits(dfs水)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1241 Oil Deposits Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 18650    Accepted Submission(s): 10750 Problem Description The GeoSurvComp geolog

UVa 572 - Oil Deposits【图DFS】

Oil Deposits The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It