POJ 2965:The Pilots Brothers' refrigerator

The Pilots Brothers‘ refrigerator

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 18080   Accepted: 6855   Special Judge

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i,
j]
 (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “?” means “open”. At least one of the handles is
initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions,
you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

也是一道枚举DFS。。写着到题,可以先写http://blog.csdn.net/u013487051/article/details/37310817

两者一样的题。。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>

using namespace std;

bool door[6][6]={false};
int flag;
int step;
int x[105];
int y[105];

int all()
{
    for(int i=1; i<=4; i++)
        for(int j=1; j<=4; j++)
            if(!door[i][j])
                return 0;
    return 1;
}

void flip(int m,int n)//翻开关
{
    for(int i=1; i<=4; i++)
    {
         door[m][i]=!door[m][i];
         door[i][n]=!door[i][n];
    }
    door[m][n]=!door[m][n]; //因为被翻了偶数次,所以在翻一次

    return;
}

void dfs(int m,int n,int deep)
{
    if(deep==step)
    {
        flag=all();
        return;
    }
    if(flag||m==5)return;

    flip(m,n);       //翻开关
    if(n<4)
    {
        x[deep]=m;
        y[deep]=n;
        dfs(m,n+1,deep+1);
    }

    else
    {
        x[deep]=m;
        y[deep]=n;
        dfs(m+1,1,deep+1);
    }

    flip(m,n);      //不符合话就翻回来
    if(n<4)
        dfs(m,n+1,deep);

    else
        dfs(m+1,1,deep);

    return;
}

int main()
{
    char str;
    flag=0;
    for(int i=1; i<=4; i++)
        for(int j=1; j<=4; j++)
        {
            cin>>str;
            if(str=='-')
                door[i][j]=true;
        }
    for(step=0; step<=16; step++)
    {
        dfs(1, 1, 0);
        if(flag)
            break;
    }

    if(flag)
    {
        cout<<step<<endl;
        for(int i=0; i<step; i++)
            cout<<x[i]<<" "<<y[i]<<endl;
    }

    return 0;
}

还有一种高 效解法:

/*

参考高手的高效解法:
> 证明:要使一个为‘+‘的符号变为‘-‘,必须其相应的行和列的操作数为奇数;可以证明,如果‘+‘位置对应的行和列上每一个位置都进行一次操作,则整个图只有这一‘+‘位置的符号改变,其余都不会改变.
> 设置一个4*4的整型数组,初值为零,用于记录每个点的操作数,那么在每个‘+‘上的行和列的的位置都加1,得到结果模2(因为一个点进行偶数次操作的效果和没进行操作一样,这就是取反的原理),然后计算整型数组中一的
> 个数即为操作数,一的位置为要操作的位置(其他原来操作数为偶数的因为操作并不发生效果,因此不进行操作)
*********************************
此上证其可以按以上步骤使数组中值都为‘-’
********************************
在上述证明中将所有的行和列的位置都加1后,在将其模2之前,对给定的数组状态,将所有的位置操作其所存的操作数个次数,举例,如果a[i][j]==n,则对(i,j)操作n次,当所有的操作完后,即全为‘-’的数组。
其实就是不模2的操作,作了许多的无用功。
以上的操作次序对结果无影响,如果存在一个最小的步骤,则此步骤一定在以上操作之中。(简单说下:因为以上操作已经包含了所有可改变欲改变位置的操作了)
而模2后的操作是去掉了所有无用功之后的操作,此操作同样包含最小步骤。
但模2后的操作去掉任何一个或几个步骤后,都不可能再得到全为‘-’的。(此同样可证明:因为操作次序无影响,先进行最小步骤,得到全为‘-’,如果还剩下m步,则在全为‘-’的数组状态下进行这m步操作后还得到一个全为
‘-’的数组状态,此只能是在同一个位置进行偶数次操作,与前文模2后矛盾,所以m=0),因此模2后的操作即为最小步骤的操作。
*/

代码如下:

#include <iostream>
using namespace std;

bool mark[4][4];
char s[4][4];

int main()
{
    int i,j,k;
    int ci[16],cj[16];
    int nas = 0;
    memset(mark,0,sizeof(mark));
	for(i = 0;i < 4;i++)
		cin >> s[i];
    for(i = 0;i < 4;i++)
        for(j = 0;j < 4;j++)
        {
            char c = s[i][j];
            if(c == '+')
            {
                mark[i][j] = !mark[i][j];
                for(k = 0;k < 4;k++)
                {
                    mark[i][k] = !mark[i][k];
                    mark[k][j] = !mark[k][j];
                }
            }

        }
    for(i = 0;i < 4;i++)
        for(j = 0;j < 4;j++)
            if(mark[i][j] == true)
            {
                ci[nas] = i + 1;
                cj[nas] = j + 1;
                nas ++;
            }
    printf("%d\n",nas);
    for(i = 0;i < nas;i++)
    {
        printf("%d %d\n",ci[i],cj[i]);
    }
    return 0;
}

POJ 2965:The Pilots Brothers' refrigerator,布布扣,bubuko.com

POJ 2965:The Pilots Brothers' refrigerator

时间: 2024-08-08 05:22:07

POJ 2965:The Pilots Brothers' refrigerator的相关文章

【POJ 2965】 The Pilots Brothers&#39; refrigerator

[POJ 2965] The Pilots Brothers' refrigerator 跟1753(我博客里另一篇有讲)棋盘问题一个做法 预处理后用二进制(BFS)暴力枚举 用到异或运算 很方便 大大缩短代码量 代码如下 #include <cstdio> #include <queue> #include <cstring> #include <stack> #define INF 0x3f3f3f3f using namespace std; type

poj 2965 The Pilots Brothers&#39; refrigerator[ 枚举 ]

传送门:http://poj.org/problem?id=2965 思路:二进制枚举,递归输出路径.G++ 900+Ms勉强过,C++超时. 代码: #include<iostream> #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<queue> #include<stack> #include<map>

POJ 2965 The Pilots Brothers&#39; refrigerator

原题链接:http://poj.org/problem?id=2965 简单的dfs,因为是要求最小值,枚举深度来得到递归终止条件,和 poj1753很像,毕竟是放在一起的. #include <iostream> #include <cstdio> #include <queue> #include <cstring> #include <cmath> #include <cstdlib> #include <vector&g

POJ 2965 The Pilots Brothers&#39; refrigerator (想法题)

POJ 2965 题意: 输入一个形如: -+-- ---- ---- -+-- 4*4图案,+表示close,-表示open,定义一种操作为:改变某个单元格符号(+变-,-变+),同时单元格所在行与所在列的所有单元格符号都会发生改变. 求最少操作次数能使所有单元格内都是'-'.并输出要操作的单元格. 思路: 正常的做法和POJ 1573类似,dfs枚举即可,见code1. 这里提供一种高效的做法: 通过思考我们可以验证,某一个单元格内符号为'+',同时对其所在行与所在列的所有单元格进行操作(其

poj 2965 The Pilots Brothers&#39; refrigerator(dfs 枚举 +打印路径)

链接:poj 2965 题意:给定一个4*4矩阵状态,代表门的16个把手,'+'代表关,'-'代表开,当16个把手都为开(即'-')时,门才能打开,问至少要几步门才能打开 改变状态规则:选定16个把手中的任意一个,可以改变其本身以及同行同列的状态(即若为开,则变为关,若为关,则变为开),这一次操作为一步. 分析:这题与poj 1753思路差不多,每个把手最多改变一次状态, 所有整个矩阵最多改变16次状态 思路:直接dfs枚举所有状态,直到找到目标状态 但是要打印路径,所有应在dfs时记录路径 注

poj 2965 The Pilots Brothers&#39; refrigerator(高斯消元)

The Pilots Brothers' refrigerator Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 18641   Accepted: 7145   Special Judge Description The game "The Pilots Brothers: following the stripy elephant" has a quest where a player needs to o

POJ 2965 The Pilots Brothers&#39; refrigerator 搜索+枚举

Description The game "The Pilots Brothers: following the stripy elephant" has a quest where a player needs to open a refrigerator. There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refri

POJ 2965 The Pilots Brothers&#39; refrigerator (DFS)

题目:http://poj.org/problem?id=2965 也是以前就做过的题目,这次居然遇到了问题搞了一天. 关于最小步骤很容易就出来,DFS就可以,但是每一步是什么怎么也出不来了 DFS本质就是利用栈暴力,当出现正确结果的时候其过程都在栈中,我一直努力想还原这个栈,未果 然后思路大乱,然后问了RE,才发现根本不用这么麻烦,只需要建个存储步骤数组,在改变元素的时候记录并不停更新就好啦. 然后就简单的解决了问题:= = #include <stdio.h> #include <s

POJ - 2965 - The Pilots Brothers&#39; refrigerator (高效贪心!!)

The Pilots Brothers' refrigerator Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 19356   Accepted: 7412   Special Judge Description The game "The Pilots Brothers: following the stripy elephant" has a quest where a player needs to o