hdu4324

http://acm.hdu.edu.cn/showproblem.php?pid=4324

Problem Description

Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!

Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.

Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.

Input

The first line contains a single integer t (1 <= t <= 15), the number of test cases.

For each case, the first line contains one integer N (0 < N <= 2000).

In the next N lines contain the adjacency matrix A of the relationship (without spaces). Ai,j = 1 means i-th people loves j-th people, otherwise Ai,j = 0.

It is guaranteed that the given relationship is a tournament, that is, Ai,i= 0, Ai,j ≠ Aj,i(1<=i, j<=n,i≠j).

Output

For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.

Take the sample output for more details.

Sample Input

2
5
00100
10000
01001
11101
11000
5
01111
00000
01000
01100
01110

Sample Output

Case #1: Yes
Case #2: No
/**
hdu4324  dfs

题目大意:
         判断是否存在点数为3的环。
解题思路:
         dfs搜索即可,不做标记会TLE,dfs时做标记如果当前点u的下一个点v已经访问过了,
         那么就判断dist[u]==dist[[v]+2,成立返回true,否则更新dist[v]=dist[u]+1,继续深搜。
*/
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;

char s[2005][2005];
int n,dist[2005];

struct note
{
    int v,next;
} edge[2005*2005];

int head[2005],ip,flag[2005];

void init()
{
    memset(head,-1,sizeof(head));
    ip=0;
}

void addedge(int u,int v)
{
    edge[ip].v=v,edge[ip].next=head[u],head[u]=ip++;
}

bool dfs(int u)
{
    flag[u]=1;
    for(int i=head[u]; i!=-1; i=edge[i].next)
    {
        int v=edge[i].v;
        if(flag[v]&&dist[u]==dist[v]+2)
        {
            puts("Yes");
            return 1;
        }
        else if(flag[v]==0)
        {
            dist[v]=dist[u]+1;
            if(dfs(v))
                return 1;
        }
    }
    return 0;
}

int main()
{
    int T,tt=0;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=0; i<n; i++)
            scanf("%s",s[i]);
        init();
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<n; j++)
            {
                if(s[i][j]=='1')
                {
                    addedge(i+1,j+1);
                }
            }
        }
        memset(flag,0,sizeof(flag));
        memset(dist,0,sizeof(dist));
        int flag1=0;
        printf("Case #%d: ",++tt);
        for(int i=1; i<=n; i++)
        {
            if(dfs(i)==1)
            {
                flag1=1;
                break;
            }
        }
        if(flag1==0)
            puts("No");
    }
    return 0;
}
时间: 2024-10-21 11:23:38

hdu4324的相关文章

HDU4324 Triangle LOVE 【拓扑排序】

Triangle LOVE Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 2455    Accepted Submission(s): 997 Problem Description Recently, scientists find that there is love between any of two people. For

hdu4324(拓扑排序)

Triangle LOVE Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 2138    Accepted Submission(s): 898 Problem Description Recently, scientists find that there is love between any of two people. For

HDU4324 - Triangle LOVE 拓补排序

HDU4324 - Triangle LOVE : http://acm.showproblemhdu.edu.cn/.php?pid=4324 标准的拓补排序,上代码 : #include <iostream> #include <cstdio> #include <cstring> using namespace std; const int MAXN = 2010; int In[MAXN]; char Map[MAXN][MAXN]; int T,N; int

HDU4324 Triangle LOVE【拓扑排序】

Triangle LOVE Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 2683    Accepted Submission(s): 1084 Problem Description Recently, scientists find that there is love between any of two people. Fo

HDU4324——DFS——Triangle LOVE

http://acm.hdu.edu.cn/showproblem.php?pid=4324 /* 搜索一个三角形,用vector+vis来减少复杂度 */ /************************************************ * Author :Powatr * Created Time :2015-8-25 10:42:01 * File Name :E.cpp ************************************************/

图论及其应用——图

我们探索某个领域的知识,无不怀揣的核弹级的好奇心与求知欲,那么,今天,我们就将开始对图论的探索.   观察一副<机械迷城> 的一处谜题.    不得不承认,<机械迷城>这款解密游戏难度远胜于<纪念碑谷>, 其中一个困难点就在于——<纪念碑谷>的目标是很明确的,但是<机械迷城>往往需要自己凭感觉设立目标.而这里的关卡的目标,就是堵住第三个出水口. 为了解决这个谜题,如果不去考虑用暴力枚举的方法去试探(其实很多情况下都是用到这种情况)一开始,我们似乎

连通性总结

1.问矩阵连乘多少次可以每个值都大于0 cf402EStrictly Positive Matrix[tarjan前向星模板.矩阵] 矩阵乘法中有这样一个重要的步骤:a^k中a[i][j]如果是+说明从i点有正好走k步就可以到达j点的路(那么由于子环的存在>k的步数的路也存在)即i.j连通我们依次建边所有点对(大于0的)剩下的跑一边tarjan  强连通分量的个数=1,则输出"yes"反之"no" #include <iostream> #incl